libx86emu: update to 3.1
This commit is contained in:
parent
e2f669fe21
commit
6055c5536a
@ -1,7 +1,7 @@
|
||||
diff -uNr libx86emu-2.3/Makefile libx86emu-2.3.mod/Makefile
|
||||
--- libx86emu-2.3/Makefile 2019-04-24 09:37:42.000000000 +0300
|
||||
+++ libx86emu-2.3.mod/Makefile 2019-06-25 21:28:20.156286593 +0300
|
||||
@@ -11,17 +11,17 @@
|
||||
diff -uNr libx86emu-3.1/Makefile libx86emu-3.1.mod/Makefile
|
||||
--- libx86emu-3.1/Makefile 2020-01-28 16:19:00.000000000 +0200
|
||||
+++ libx86emu-3.1.mod/Makefile 2020-03-20 15:57:59.975825961 +0200
|
||||
@@ -11,18 +11,18 @@
|
||||
|
||||
MAJOR_VERSION := $(shell $(GIT2LOG) --version VERSION ; cut -d . -f 1 VERSION)
|
||||
|
||||
@ -9,6 +9,7 @@ diff -uNr libx86emu-2.3/Makefile libx86emu-2.3.mod/Makefile
|
||||
-CFLAGS = -g -O2 -fPIC -fvisibility=hidden -fomit-frame-pointer -Wall
|
||||
+CC ?= gcc
|
||||
+CFLAGS += -g -O2 -fPIC -fvisibility=hidden -fomit-frame-pointer -Wall $(CPPFLAGS)
|
||||
LDFLAGS =
|
||||
|
||||
-LIBDIR = /usr/lib$(shell ldd /bin/sh | grep -q /lib64/ && echo 64)
|
||||
+LIBDIR = @TERMUX_PREFIX@/lib
|
||||
@ -24,7 +25,7 @@ diff -uNr libx86emu-2.3/Makefile libx86emu-2.3.mod/Makefile
|
||||
|
||||
.PHONY: all shared install test demo clean
|
||||
|
||||
@@ -37,14 +37,10 @@
|
||||
@@ -38,14 +38,10 @@
|
||||
|
||||
install: shared
|
||||
install -D $(LIB_NAME) $(DESTDIR)$(LIBDIR)/$(LIB_NAME)
|
||||
@ -34,7 +35,7 @@ diff -uNr libx86emu-2.3/Makefile libx86emu-2.3.mod/Makefile
|
||||
+ install -m 644 -D include/x86emu.h $(DESTDIR)/@TERMUX_PREFIX@/include/x86emu.h
|
||||
|
||||
$(LIB_NAME): .depend $(OBJS)
|
||||
$(CC) -shared -Wl,-soname,$(LIB_SONAME) $(OBJS) -o $(LIB_NAME)
|
||||
$(CC) -shared -Wl,-soname,$(LIB_SONAME) $(OBJS) -o $(LIB_NAME) $(LDFLAGS)
|
||||
- @ln -snf $(LIB_NAME) $(LIB_SONAME)
|
||||
- @ln -snf $(LIB_SONAME) $(LIBX86).so
|
||||
|
||||
|
@ -1,9 +1,9 @@
|
||||
TERMUX_PKG_HOMEPAGE=https://github.com/wfeldt/libx86emu
|
||||
TERMUX_PKG_DESCRIPTION="x86 emulation library"
|
||||
TERMUX_PKG_LICENSE="BSD"
|
||||
TERMUX_PKG_VERSION=2.4
|
||||
TERMUX_PKG_VERSION=3.1
|
||||
TERMUX_PKG_SRCURL=https://github.com/wfeldt/libx86emu/archive/$TERMUX_PKG_VERSION.tar.gz
|
||||
TERMUX_PKG_SHA256=cf538e657091234c1835cf0df1fdbc4b5d6afac133776ab112c4be81c15faaf5
|
||||
TERMUX_PKG_SHA256=70b574ed84dcba2dc4f54a9a1c14539e84ddbe628842c638a2f98d987d879dac
|
||||
TERMUX_PKG_BREAKS="libx86emu-dev"
|
||||
TERMUX_PKG_REPLACES="libx86emu-dev"
|
||||
TERMUX_PKG_BUILD_IN_SRC=true
|
||||
|
Loading…
Reference in New Issue
Block a user