new package: libvbisam

This commit is contained in:
Tee KOBAYASHI 2021-12-28 05:26:08 +09:00 committed by Henrik Grimler
parent 0fee54ef37
commit 613b2fb75a
5 changed files with 297 additions and 0 deletions

View File

@ -0,0 +1,13 @@
TERMUX_PKG_HOMEPAGE=https://sourceforge.net/projects/vbisam/
TERMUX_PKG_DESCRIPTION="A replacement for IBM's C-ISAM"
TERMUX_PKG_LICENSE="GPL-2.0, LGPL-2.1"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=2.0
TERMUX_PKG_SRCURL=https://downloads.sourceforge.net/project/vbisam/vbisam2/vbisam-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=688b776e0030cce50fd7e44cbe40398ea93431f76510c7100433cc6313eabc4f
termux_step_pre_configure() {
cp $TERMUX_PKG_BUILDER_DIR/efgcvt_r-template.c $TERMUX_PKG_SRCDIR/libvbisam/
cp $TERMUX_PKG_BUILDER_DIR/efgcvt-dbl-macros.h $TERMUX_PKG_SRCDIR/libvbisam/
autoreconf -fi
}

View File

@ -0,0 +1,52 @@
/* Macros for the implementation of *cvt functions, double version.
Copyright (C) 1995-2021 Free Software Foundation, Inc.
This file is part of the GNU C Library.
The GNU C Library is free software; you can redistribute it and/or
modify it under the terms of the GNU Lesser General Public
License as published by the Free Software Foundation; either
version 2.1 of the License, or (at your option) any later version.
The GNU C Library is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
Lesser General Public License for more details.
You should have received a copy of the GNU Lesser General Public
License along with the GNU C Library; if not, see
<https://www.gnu.org/licenses/>. */
#include <float.h>
#define FLOAT_TYPE double
#define FUNC_PREFIX
#define FLOAT_FMT_FLAG
#define FLOAT_NAME_EXT
#define FLOAT_MIN_10_EXP DBL_MIN_10_EXP
/* Actually we have to write (DBL_DIG + log10 (DBL_MAX_10_EXP)) but we
don't have log10 available in the preprocessor. */
#define MAXDIG (NDIGIT_MAX + 3)
#define FCVT_MAXDIG (DBL_MAX_10_EXP + MAXDIG)
#if DBL_MANT_DIG == 53
# define NDIGIT_MAX 17
#elif DBL_MANT_DIG == 24
# define NDIGIT_MAX 9
#elif DBL_MANT_DIG == 56
# define NDIGIT_MAX 18
#else
/* See IEEE 854 5.6, table 2 for this formula. Unfortunately we need a
compile time constant here, so we cannot use it. */
# error "NDIGIT_MAX must be precomputed"
# define NDIGIT_MAX (lrint (ceil (M_LN2 / M_LN10 * DBL_MANT_DIG + 1.0)))
#endif
#if DBL_MIN_10_EXP == -37
# define FLOAT_MIN_10_NORM 1.0e-37
#elif DBL_MIN_10_EXP == -307
# define FLOAT_MIN_10_NORM 1.0e-307
#elif DBL_MIN_10_EXP == -4931
# define FLOAT_MIN_10_NORM 1.0e-4931
#else
/* libc can't depend on libm. */
# error "FLOAT_MIN_10_NORM must be precomputed"
# define FLOAT_MIN_10_NORM exp10 (DBL_MIN_10_EXP)
#endif

View File

@ -0,0 +1,205 @@
/* Compatibility functions for floating point formatting, reentrant versions.
Copyright (C) 1995-2021 Free Software Foundation, Inc.
This file is part of the GNU C Library.
The GNU C Library is free software; you can redistribute it and/or
modify it under the terms of the GNU Lesser General Public
License as published by the Free Software Foundation; either
version 2.1 of the License, or (at your option) any later version.
The GNU C Library is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
Lesser General Public License for more details.
You should have received a copy of the GNU Lesser General Public
License along with the GNU C Library; if not, see
<https://www.gnu.org/licenses/>. */
#include <errno.h>
#include <stdio.h>
#include <string.h>
#include <ctype.h>
#include <math.h>
#include <stdlib.h>
#include <sys/param.h>
#ifndef __ANDROID__
#include <math_ldbl_opt.h>
#else
#include "efgcvt-dbl-macros.h"
#define __FCVT_R fcvt
#define __ECVT_R ecvt
#define SNPRINTF snprintf
#endif
#ifndef SNPRINTF
# define SNPRINTF __snprintf
#endif
#define APPEND(a, b) APPEND2 (a, b)
#define APPEND2(a, b) a##b
int
__FCVT_R (FLOAT_TYPE value, int ndigit, int *decpt, int *sign,
char *buf, size_t len)
{
ssize_t n;
ssize_t i;
int left;
if (buf == NULL)
{
__set_errno (EINVAL);
return -1;
}
left = 0;
if (isfinite (value))
{
*sign = signbit (value) != 0;
if (*sign)
value = -value;
if (ndigit < 0)
{
/* Rounding to the left of the decimal point. */
while (ndigit < 0)
{
FLOAT_TYPE new_value = value * 0.1;
if (new_value < 1.0)
{
ndigit = 0;
break;
}
value = new_value;
++left;
++ndigit;
}
}
}
else
/* Value is Inf or NaN. */
*sign = 0;
n = SNPRINTF (buf, len, "%.*" FLOAT_FMT_FLAG "f", MIN (ndigit, NDIGIT_MAX),
value);
/* Check for a too small buffer. */
if (n >= (ssize_t) len)
return -1;
i = 0;
while (i < n && isdigit (buf[i]))
++i;
*decpt = i;
if (i == 0)
/* Value is Inf or NaN. */
return 0;
if (i < n)
{
do
++i;
while (i < n && !isdigit (buf[i]));
if (*decpt == 1 && buf[0] == '0' && value != 0.0)
{
/* We must not have leading zeroes. Strip them all out and
adjust *DECPT if necessary. */
--*decpt;
while (i < n && buf[i] == '0')
{
--*decpt;
++i;
}
}
memmove (&buf[MAX (*decpt, 0)], &buf[i], n - i);
buf[n - (i - MAX (*decpt, 0))] = '\0';
}
if (left)
{
*decpt += left;
if ((ssize_t) --len > n)
{
while (left-- > 0 && n < (ssize_t) len)
buf[n++] = '0';
buf[n] = '\0';
}
}
return 0;
}
int
__ECVT_R (FLOAT_TYPE value, int ndigit, int *decpt, int *sign,
char *buf, size_t len)
{
int exponent = 0;
if (isfinite (value) && value != 0.0)
{
/* Slow code that doesn't require -lm functions. */
FLOAT_TYPE d;
FLOAT_TYPE f = 1.0;
if (value < 0.0)
d = -value;
else
d = value;
/* For denormalized numbers the d < 1.0 case below won't work,
as f can overflow to +Inf. */
if (d < FLOAT_MIN_10_NORM)
{
value /= FLOAT_MIN_10_NORM;
if (value < 0.0)
d = -value;
else
d = value;
exponent += FLOAT_MIN_10_EXP;
}
if (d < 1.0)
{
do
{
f *= 10.0;
--exponent;
}
while (d * f < 1.0);
value *= f;
}
else if (d >= 10.0)
{
do
{
f *= 10;
++exponent;
}
while (d >= f * 10.0);
value /= f;
}
}
else if (value == 0.0)
/* SUSv2 leaves it unspecified whether *DECPT is 0 or 1 for 0.0.
This could be changed to -1 if we want to return 0. */
exponent = 0;
if (ndigit <= 0 && len > 0)
{
buf[0] = '\0';
*decpt = 1;
*sign = isfinite (value) ? signbit (value) != 0 : 0;
}
else
if (__FCVT_R (value, MIN (ndigit, NDIGIT_MAX) - 1,
decpt, sign, buf, len))
return -1;
*decpt += exponent;
return 0;
}

View File

@ -0,0 +1,13 @@
--- a/libvbisam/Makefile.am
+++ b/libvbisam/Makefile.am
@@ -1,8 +1,8 @@
lib_LTLIBRARIES = libvbisam.la
libvbisam_la_SOURCES = isdecimal.c ishelper.c isaudit.c isbuild.c isdelete.c \
isopen.c isread.c isrecover.c isrewrite.c istrans.c iswrite.c ischeck.c \
- vbdataio.c vbindexio.c vbkeysio.c vblocking.c \
- vblowlevel.c vbmemio.c vbnodememio.c isinternal.h byteswap.h
+ vbdataio.c vbindexio.c vbkeysio.c vblocking.c efgcvt_r-template.c \
+ vblowlevel.c vbmemio.c vbnodememio.c isinternal.h byteswap.h efgcvt-dbl-macros.h
libvbisam_la_CFLAGS = -I$(top_srcdir)
libvbisam_la_LDFLAGS = -no-undefined -version-info 1:0:0

View File

@ -0,0 +1,14 @@
--- a/vbisam.h
+++ b/vbisam.h
@@ -25,7 +25,11 @@
#define VBISAM_USE_LONG_LONG /* Note hack for now */
#ifdef VBISAM_USE_LONG_LONG
+#ifdef __ANDROID__
+#define vbisam_off_t off_t
+#else
#define vbisam_off_t long long
+#endif
#else
#define vbisam_off_t int
#endif