New package: n-t-roff-sc, a maintained fork of sc 7.16 (#9997)
This commit is contained in:
parent
d811379efb
commit
619c3b9529
35
packages/n-t-roff-sc/Makefile.patch
Normal file
35
packages/n-t-roff-sc/Makefile.patch
Normal file
@ -0,0 +1,35 @@
|
||||
diff -uNr sc/configure sc.mod/configure
|
||||
--- sc/configure 2022-04-12 17:42:09.891984764 -0700
|
||||
+++ sc.mod/configure 2022-04-12 21:21:41.160050820 -0700
|
||||
@@ -30,9 +30,7 @@
|
||||
while [ $# -gt 0 ]; do
|
||||
case $1 in
|
||||
-s) SFLAG=1;;
|
||||
- *)
|
||||
- echo "$0: $1: Unknown option" >&2
|
||||
- usage 1;;
|
||||
+ *) ;;
|
||||
esac
|
||||
shift
|
||||
done
|
||||
diff -uNr sc/Makefile.in sc.mod/Makefile.in
|
||||
--- sc/Makefile.in 2022-04-12 17:45:34.738634444 -0700
|
||||
+++ sc.mod/Makefile.in 2022-04-12 18:04:04.218706481 -0700
|
||||
@@ -20,7 +20,7 @@
|
||||
# packaging this with an O/S, for example, you'll probably want to change
|
||||
# this to /usr. Otherwise, /usr/local is probably more appropriate, unless
|
||||
# you're replacing the vendor-supplied version.
|
||||
-prefix=/usr/local
|
||||
+prefix=@TERMUX_PREFIX@
|
||||
|
||||
# This is where the install step puts it.
|
||||
EXDIR=${prefix}/bin
|
||||
@@ -169,7 +169,7 @@
|
||||
# Command to use to make temporary copies of some source files.
|
||||
#LN=ln -s
|
||||
#LN=cp
|
||||
-LN=ln
|
||||
+LN=ln -s
|
||||
|
||||
#### SYSTEM DEFINES ####
|
||||
|
19
packages/n-t-roff-sc/build.sh
Normal file
19
packages/n-t-roff-sc/build.sh
Normal file
@ -0,0 +1,19 @@
|
||||
TERMUX_PKG_HOMEPAGE="https://github.com/n-t-roff/sc"
|
||||
TERMUX_PKG_DESCRIPTION="A vi-like spreadsheet calculator"
|
||||
TERMUX_PKG_LICENSE="Public Domain"
|
||||
TERMUX_PKG_MAINTAINER="@termux"
|
||||
# TERMUX_PKG_VERSION does not support underscores
|
||||
_REAL_VERSION=7.16_1.1.2
|
||||
TERMUX_PKG_VERSION=${_REAL_VERSION//_/-}
|
||||
TERMUX_PKG_SRCURL=https://github.com/n-t-roff/sc/archive/refs/tags/$_REAL_VERSION.tar.gz
|
||||
TERMUX_PKG_SHA256=1802c9d3d60dac85feb783adf967bc0d2fd7e5f592d9d1df15e4e87d83efcf14
|
||||
TERMUX_PKG_DEPENDS="ncurses"
|
||||
TERMUX_PKG_BUILD_IN_SRC=true
|
||||
# n-t-roff-sc is a maintained fork of sc and thus replaces the original
|
||||
TERMUX_PKG_CONFLICTS="sc"
|
||||
TERMUX_PKG_REPLACES="sc"
|
||||
TERMUX_PKG_PROVIDES="sc"
|
||||
|
||||
termux_step_post_configure () {
|
||||
CFLAGS+=" -I$TERMUX_PREFIX/include"
|
||||
}
|
Loading…
x
Reference in New Issue
Block a user