new package: cuse

This commit is contained in:
Tee KOBAYASHI 2022-01-31 01:31:24 +09:00 committed by Yaksh Bariya
parent fbac053c98
commit 6279216b94
No known key found for this signature in database
GPG Key ID: F7486BA7D3D27581
4 changed files with 61 additions and 0 deletions

View File

@ -0,0 +1,18 @@
TERMUX_PKG_HOMEPAGE=https://pi4.informatik.uni-mannheim.de/~haensel/cuse/
TERMUX_PKG_DESCRIPTION="A MIDI-Sequencer which targets both terminal purists and visually impaired people"
TERMUX_PKG_LICENSE="GPL-2.0"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=0.6
TERMUX_PKG_SRCURL=https://downloads.sourceforge.net/project/cuse/cuse-${TERMUX_PKG_VERSION}.tgz
TERMUX_PKG_SHA256=dc2306c68eeb0eefb2da4739cf42bf3bf49fde3adba6ca58900fb3f78d4f9ad6
TERMUX_PKG_DEPENDS="libc++, libcdk, sdl-mixer"
termux_step_post_get_source() {
make distclean || :
}
termux_step_pre_configure() {
autoreconf -fi
LDFLAGS+=" -lSDL"
}

View File

@ -0,0 +1,12 @@
--- a/configure.ac
+++ b/configure.ac
@@ -25,8 +25,7 @@
# Checks for header files.
AC_HEADER_STDC
AC_CHECK_HEADERS([netinet/in.h stdint.h stdlib.h sys/time.h])
-CPPFLAGS="$CPPFLAGS -I/usr/include/cdk"
-AC_CHECK_HEADERS([cdk/cdk.h],,[
+AC_CHECK_HEADERS([cdk.h],,[
echo 'cdk version >= 5.0 and includes (developer-version) required'
exit 1
])

View File

@ -0,0 +1,20 @@
--- a/src/CuSE.cxx
+++ b/src/CuSE.cxx
@@ -56,7 +56,7 @@
#include <pthread.h>
#include <curses.h>
#include <math.h>
-#include <cdk/cdk.h>
+#include <cdk.h>
#include <netinet/in.h>
#include <SDL/SDL.h>
#include <SDL/SDL_mixer.h>
@@ -79,7 +79,7 @@
/* GUI-Components */
Track *p_first_displayed_track, *p_last_displayed_track;
-static char *menulist[MAX_MENU_ITEMS][MAX_SUB_ITEMS];
+static const char *menulist[MAX_MENU_ITEMS][MAX_SUB_ITEMS];
char status_text[LENGTH_DISPLAY_TEXT];
bool display_top_line, popup_active;
short cursor_column; // current cursor column in track display

View File

@ -0,0 +1,11 @@
--- a/src/sequencer.h
+++ b/src/sequencer.h
@@ -9,7 +9,7 @@
#include <pthread.h>
#include <curses.h>
#include <math.h>
-#include <cdk/cdk.h>
+#include <cdk.h>
#include <netinet/in.h>
#include "midi_event.h"