cowsay: switch to fork, update to 3.7.0

This commit is contained in:
Henrik Grimler 2022-03-09 08:48:37 +01:00
parent bf56580acd
commit 637269e494
No known key found for this signature in database
GPG Key ID: B0076E490B71616B
3 changed files with 15 additions and 89 deletions

View File

@ -0,0 +1,11 @@
--- ./Makefile~ 2020-05-29 03:40:10.000000000 +0200
+++ ./Makefile 2022-03-09 08:47:03.919629517 +0100
@@ -2,7 +2,7 @@
PACKAGE_TARNAME = cowsay
-prefix = /usr/local
+prefix ?= /usr/local
exec_prefix = ${prefix}
bindir = ${exec_prefix}/bin
datarootdir = ${prefix}/share

View File

@ -2,13 +2,9 @@ TERMUX_PKG_HOMEPAGE=https://en.wikipedia.org/wiki/Cowsay
TERMUX_PKG_DESCRIPTION="Program which generates ASCII pictures of a cow with a message"
TERMUX_PKG_LICENSE="GPL-2.0"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=3.04
TERMUX_PKG_SRCURL=http://http.debian.net/debian/pool/main/c/cowsay/cowsay_3.03+dfsg1.orig.tar.gz
TERMUX_PKG_SHA256=10bae895d9afb2d720d2211db58f396352b00fe1386c369ca3608cbf6497b839
TERMUX_PKG_VERSION=3.7.0
TERMUX_PKG_SRCURL=https://github.com/cowsay-org/cowsay/archive/refs/tags/v${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=af13a93f1559ea435403cf11eaa6c46be5bf03ac165a4acb471c66a4976167e0
TERMUX_PKG_DEPENDS="perl"
TERMUX_PKG_PLATFORM_INDEPENDENT=true
termux_step_make_install() {
cd $TERMUX_PKG_SRCDIR
sh install.sh
}
TERMUX_PKG_BUILD_IN_SRC=true

View File

@ -1,81 +0,0 @@
Only in .: install.pl
diff -u -r ../cowsay-3.03+dfsg1/install.sh ./install.sh
--- ../cowsay-3.03+dfsg1/install.sh 1999-11-01 15:19:21.000000000 -0500
+++ ./install.sh 2016-04-14 21:14:44.715683710 -0400
@@ -14,55 +14,8 @@
filelist='cows'
-cat <<DOG
-===================
-cowsay Installation
-===================
-
-Searching for useful perl executables...
-DOG
-
-backdoor=$1
-
-pathdirs=`echo $PATH | tr : " "`
-for p in $pathdirs; do
- set $p/perl $p/perl5*
- while [ ! -z "$1" ]; do
- if [ -x "$1" ]; then
- echo Found perl in $1
- perls="$perls $1"
- fi
- shift
- done
-done
-for perl in $perls; do
- if $perl -MText::Wrap -e0 >/dev/null 2>&1; then
- echo Found a good perl in $perl
- goodperls="$goodperls $perl"
- fi
-done
-echo The following perl executables will run cowsay:
-echo $goodperls
-echo I recommend the latest stable perl you can find.
-set $goodperls
-if [ -z "$1" ]; then
- echo Ack! You do not have Perl 5 installed correctly!
- echo Get thee to CPAN!
- exit 1
-fi
-usethisperl=$1
-echo I will be using $1 because I know it will work.
-
-echo Now I need an installation prefix. I will use /usr/local unless
-printf "you give me a better idea here: "
-if [ -n "$backdoor" ]; then
- prefix=$backdoor
- printf "%s (specified on command line)\n" $prefix
-else
- read prefix
-fi
-
-PREFIX=${prefix:-/usr/local}
+usethisperl=@TERMUX_PREFIX@/bin/perl
+PREFIX=@TERMUX_PREFIX@
echo Okay, time to install this puppy.
@@ -70,13 +23,13 @@
echo s,%PREFIX%,$PREFIX,\; >> install.pl
set -x
mkdir -p $PREFIX/bin || (mkdir $PREFIX; mkdir $PREFIX/bin)
-$usethisperl -p install.pl cowsay > $PREFIX/bin/cowsay
+perl -p install.pl cowsay > $PREFIX/bin/cowsay
chmod a+x $PREFIX/bin/cowsay
ln -s cowsay $PREFIX/bin/cowthink
-mkdir -p $PREFIX/man/man1 || ($mkdir $PREFIX; mkdir $PREFIX/man; mkdir $PREFIX/man/man1)
-$usethisperl -p install.pl cowsay.1 > $PREFIX/man/man1/cowsay.1
-chmod a+r $PREFIX/man/man1/cowsay.1
-ln -s cowsay.1 $PREFIX/man/man1/cowthink.1
+mkdir -p $PREFIX/share/man/man1
+perl -p install.pl cowsay.1 > $PREFIX/share/man/man1/cowsay.1
+chmod a+r $PREFIX/share/man/man1/cowsay.1
+(cd $PREFIX/share/man/man1; ln -f -s cowsay.1 cowthink.1 )
mkdir -p $PREFIX/share/cows || (mkdir $PREFIX; mkdir $PREFIX/share; mkdir $PREFIX/share/cows)
tar -cf - $filelist | (cd $PREFIX/share && tar -xvf -)
set +x