lexter: add package

This commit is contained in:
Henrik Grimler 2020-05-10 14:53:41 +02:00
parent 9fe700504a
commit 63bae47c6d
3 changed files with 64 additions and 0 deletions

View File

@ -0,0 +1,40 @@
--- ../acinclude.m4.orig 2020-05-10 13:41:17.038645158 +0200
+++ ./acinclude.m4 2020-05-10 13:43:55.788790346 +0200
@@ -43,6 +43,37 @@
fi
])
+# AM_LC_MESSAGES version: 5 updated: 2015/05/10 19:52:14
+# --------------
+# Inserted as requested by gettext 0.10.40
+# File from /usr/share/aclocal
+# lcmessage.m4
+# ====================
+# Check whether LC_MESSAGES is available in <locale.h>.
+# Ulrich Drepper <drepper@cygnus.com>, 1995.
+#
+# This file can be copied and used freely without restrictions. It can
+# be used in projects which are not available under the GNU General Public
+# License or the GNU Library General Public License but which still want
+# to provide support for the GNU gettext functionality.
+# Please note that the actual code of the GNU gettext library is covered
+# by the GNU Library General Public License, and the rest of the GNU
+# gettext package package is covered by the GNU General Public License.
+# They are *not* in the public domain.
+
+# serial 2
+
+AC_DEFUN([AM_LC_MESSAGES],
+[if test $ac_cv_header_locale_h = yes; then
+ AC_CACHE_CHECK([for LC_MESSAGES], am_cv_val_LC_MESSAGES,
+ [AC_TRY_LINK([#include <locale.h>], [return LC_MESSAGES],
+ am_cv_val_LC_MESSAGES=yes, am_cv_val_LC_MESSAGES=no)])
+ if test $am_cv_val_LC_MESSAGES = yes; then
+ AC_DEFINE(HAVE_LC_MESSAGES, 1,
+ [Define if your <locale.h> file defines LC_MESSAGES.])
+ fi
+fi])
+
# Macro to add for using GNU gettext.
# Ulrich Drepper <drepper@cygnus.com>, 1995.
#

13
packages/lexter/build.sh Normal file
View File

@ -0,0 +1,13 @@
TERMUX_PKG_HOMEPAGE=https://www.kyne.com.au/~mark/software/lexter.php
TERMUX_PKG_DESCRIPTION="A real-time word puzzle for text terminals"
TERMUX_PKG_LICENSE="GPL-2.0"
TERMUX_PKG_MAINTAINER="Henrik Grimler @Grimler91"
TERMUX_PKG_VERSION=1.0.3
TERMUX_PKG_SRCURL=https://www.kyne.com.au/~mark/software/download/lexter-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=b61a28fd5249b7d6c0df9be91c97c2acd00ccd9ad1e7b0c99808f6cdc96d5188
TERMUX_PKG_DEPENDS="ncurses, gettext"
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--datadir=$TERMUX_PREFIX/share/lexter"
termux_step_pre_configure() {
autoreconf -vfi
}

View File

@ -0,0 +1,11 @@
--- ../configure.in.orig 2020-05-10 14:28:06.173300836 +0200
+++ ./configure.in 2020-05-10 14:36:06.592909972 +0200
@@ -44,7 +44,7 @@
AC_HEADER_TIME
dnl Checks for library functions.
-AC_CHECK_FUNCS(getcwd gettimeofday getwd putenv select strdup strerror,,
+AC_CHECK_FUNCS(getcwd gettimeofday putenv select strdup strerror,,
AC_MSG_ERROR([Missing required function]))
AC_FUNC_ALLOCA
AC_FUNC_MMAP