dopewars: update to 1.6.1

This commit is contained in:
Henrik Grimler 2021-02-13 12:41:23 +01:00
parent bb8f52c522
commit 64385bb14d
4 changed files with 21 additions and 28 deletions

View File

@ -1,12 +1,15 @@
TERMUX_PKG_HOMEPAGE=https://dopewars.sourceforge.io
TERMUX_PKG_DESCRIPTION="Drug-dealing game set in streets of New York City"
TERMUX_PKG_LICENSE="GPL-2.0"
TERMUX_PKG_VERSION=1.5.12
TERMUX_PKG_REVISION=3
TERMUX_PKG_VERSION=1.6.1
TERMUX_PKG_SRCURL=https://prdownloads.sourceforge.net/dopewars/dopewars-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=23059dcdea96c6072b148ee21d76237ef3535e5be90b3b2d8239d150feee0c19
TERMUX_PKG_DEPENDS="ncurses, glib, pcre"
TERMUX_PKG_SHA256=83127903a61d81cda251a022f9df150d11e27bdd040e858c09c57927cc0edea6
TERMUX_PKG_DEPENDS="ncurses, glib, pcre, curl"
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
--without-sdl
"
TERMUX_PKG_RM_AFTER_INSTALL="share/gnome"
termux_step_pre_configure() {
autoreconf -vfi
}

View File

@ -1,16 +0,0 @@
--- ../configure.orig 2019-10-24 14:56:07.273121338 +0200
+++ ./configure 2019-10-24 14:58:24.726415961 +0200
@@ -21930,11 +21930,8 @@
LIBS="$ac_save_LIBS"
fi
fi
- GLIB_CFLAGS=""
- GLIB_LIBS=""
- { { echo "$as_me:$LINENO: error: Cannot find glib - aborting" >&5
-echo "$as_me: error: Cannot find glib - aborting" >&2;}
- { (exit 1); exit 1; }; }
+ GLIB_CFLAGS="-I@TERMUX_PREFIX@/include/glib-2.0 -I@TERMUX_PREFIX@/lib/glib-2.0/include"
+ GLIB_LIBS="-lglib-2.0"
fi

View File

@ -0,0 +1,8 @@
--- ../src-curses_client-Makefile.am.orig 2021-02-13 11:27:53.001589614 +0000
+++ ./src/curses_client/Makefile.am 2021-02-13 11:28:07.268708391 +0000
@@ -1,4 +1,4 @@
noinst_LIBRARIES = libcursesclient.a
libcursesclient_a_SOURCES = curses_client.c curses_client.h
-AM_CPPFLAGS= -I${srcdir} @GLIB_CFLAGS@
+AM_CPPFLAGS= -I${srcdir} -I$(top_srcdir)/src @GLIB_CFLAGS@
DEFS = @DEFS@

View File

@ -1,13 +1,11 @@
diff -u -r ../dopewars-1.5.12.orig/src/serverside.c ./src/serverside.c
--- ../dopewars-1.5.12.orig/src/serverside.c 2005-12-30 22:26:13.000000000 +0100
+++ ./src/serverside.c 2019-11-26 08:24:17.264944596 +0100
@@ -1847,7 +1847,7 @@
--- ../serverside.c.orig 2021-02-12 21:30:27.870154851 +0000
+++ ./src/serverside.c 2021-02-12 21:31:05.391626081 +0000
@@ -1807,7 +1807,7 @@
*/
void DropPrivileges()
{
-#ifndef CYGWIN
+#if !defined(CYGWIN) && !defined(__ANDROID__)
/* Ignore the return from setregid; we'll check it ourselves to be sure
* (this avoids problems when running under fakeroot) */
setregid(getgid(), getgid());
Only in ./src: serverside.c~
#ifdef HAVE_ISSETUGID
if (issetugid() == 0) return;