glib: Update from 2.58.3 to 2.60.2
This commit is contained in:
parent
7fb3f5ead6
commit
6523dda1e4
@ -1,9 +1,9 @@
|
||||
TERMUX_PKG_HOMEPAGE=https://developer.gnome.org/glib/
|
||||
TERMUX_PKG_DESCRIPTION="Library providing core building blocks for libraries and applications written in C"
|
||||
TERMUX_PKG_LICENSE="LGPL-2.1"
|
||||
TERMUX_PKG_VERSION=2.58.3
|
||||
TERMUX_PKG_REVISION=4
|
||||
TERMUX_PKG_SHA256=8f43c31767e88a25da72b52a40f3301fefc49a665b56dc10ee7cc9565cbe7481
|
||||
TERMUX_PKG_VERSION=2.60.2
|
||||
TERMUX_PKG_REVISION=1
|
||||
TERMUX_PKG_SHA256=2ef15475060addfda0443a7e8a52b28a10d5e981e82c083034061daf9a8f80d9
|
||||
TERMUX_PKG_SRCURL=https://ftp.gnome.org/pub/gnome/sources/glib/${TERMUX_PKG_VERSION:0:4}/glib-${TERMUX_PKG_VERSION}.tar.xz
|
||||
# libandroid-support to get langinfo.h in include path.
|
||||
TERMUX_PKG_DEPENDS="libffi, libiconv, pcre, libandroid-support, zlib"
|
||||
@ -11,32 +11,12 @@ TERMUX_PKG_RM_AFTER_INSTALL="share/gtk-doc lib/locale share/glib-2.0/gettext sha
|
||||
# Needed by pkg-config for glib-2.0:
|
||||
TERMUX_PKG_DEVPACKAGE_DEPENDS="pcre-dev"
|
||||
TERMUX_PKG_INCLUDE_IN_DEVPACKAGE="lib/glib-2.0/include"
|
||||
|
||||
# --enable-compile-warnings=no to get rid of format strings causing errors.
|
||||
# --disable-znodelete to avoid DF_1_NODELETE which most Android 5.0 linkers does not support.
|
||||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
|
||||
--cache-file=termux_configure.cache
|
||||
--disable-compile-warnings
|
||||
--disable-gtk-doc
|
||||
--disable-gtk-doc-html
|
||||
--disable-libelf
|
||||
--disable-libmount
|
||||
--disable-znodelete
|
||||
--with-pcre=system
|
||||
--with-libiconv=gnu
|
||||
-Dlibmount=false
|
||||
-Diconv=gnu
|
||||
"
|
||||
|
||||
termux_step_pre_configure() {
|
||||
NOCONFIGURE=1 ./autogen.sh
|
||||
|
||||
# glib checks for __BIONIC__ instead of __ANDROID__:
|
||||
CFLAGS="$CFLAGS -D__BIONIC__=1"
|
||||
|
||||
cd $TERMUX_PKG_BUILDDIR
|
||||
|
||||
# https://developer.gnome.org/glib/stable/glib-cross-compiling.html
|
||||
echo "glib_cv_long_long_format=ll" >> termux_configure.cache
|
||||
echo "glib_cv_stack_grows=no" >> termux_configure.cache
|
||||
echo "glib_cv_uscore=no" >> termux_configure.cache
|
||||
chmod a-w termux_configure.cache
|
||||
CFLAGS+=" -D__BIONIC__=1"
|
||||
}
|
||||
|
@ -341,42 +341,3 @@ diff -uNr glib-2.58.3/glib/gcharset.c glib-2.58.3.mod/glib/gcharset.c
|
||||
g_once_init_leave (&alias_table, table);
|
||||
}
|
||||
|
||||
diff -uNr glib-2.58.3/glib/gutils.c glib-2.58.3.mod/glib/gutils.c
|
||||
--- glib-2.58.3/glib/gutils.c 2019-01-21 15:38:50.000000000 +0200
|
||||
+++ glib-2.58.3.mod/glib/gutils.c 2019-03-02 02:10:27.148655478 +0200
|
||||
@@ -381,7 +381,7 @@
|
||||
* what to search if PATH is unset. POSIX may, dunno.
|
||||
*/
|
||||
|
||||
- path = "/bin:/usr/bin:.";
|
||||
+ path = "@TERMUX_PREFIX@/bin:@TERMUX_PREFIX@/bin/applets:.";
|
||||
}
|
||||
#else
|
||||
n = GetModuleFileNameW (NULL, wfilename, MAXPATHLEN);
|
||||
@@ -959,7 +959,7 @@
|
||||
if (tmp == NULL || *tmp == '\0')
|
||||
{
|
||||
g_free (tmp);
|
||||
- tmp = g_strdup ("/tmp");
|
||||
+ tmp = g_strdup ("@TERMUX_PREFIX@/tmp");
|
||||
}
|
||||
#endif /* !G_OS_WIN32 */
|
||||
|
||||
@@ -2043,7 +2043,7 @@
|
||||
|
||||
#ifndef G_OS_WIN32
|
||||
if (!data_dirs || !data_dirs[0])
|
||||
- data_dirs = "/usr/local/share/:/usr/share/";
|
||||
+ data_dirs = "@TERMUX_PREFIX@/share/";
|
||||
|
||||
data_dir_vector = g_strsplit (data_dirs, G_SEARCHPATH_SEPARATOR_S, 0);
|
||||
#else
|
||||
@@ -2119,7 +2119,7 @@
|
||||
}
|
||||
#else
|
||||
if (!conf_dirs || !conf_dirs[0])
|
||||
- conf_dirs = "/etc/xdg";
|
||||
+ conf_dirs = "@TERMUX_PREFIX@/etc/xdg";
|
||||
|
||||
conf_dir_vector = g_strsplit (conf_dirs, G_SEARCHPATH_SEPARATOR_S, 0);
|
||||
#endif
|
||||
|
8
packages/glib/gio-meson.build.patch
Normal file
8
packages/glib/gio-meson.build.patch
Normal file
@ -0,0 +1,8 @@
|
||||
diff -u -r ../glib-2.60.2/gio/meson.build ./gio/meson.build
|
||||
--- ../glib-2.60.2/gio/meson.build 2019-05-03 13:43:28.000000000 +0000
|
||||
+++ ./gio/meson.build 2019-05-11 20:18:56.264103995 +0000
|
||||
@@ -994,4 +994,3 @@
|
||||
endif
|
||||
|
||||
subdir('fam')
|
||||
-subdir('tests')
|
39
packages/glib/glib-gutils.c.patch
Normal file
39
packages/glib/glib-gutils.c.patch
Normal file
@ -0,0 +1,39 @@
|
||||
diff -u -r ../glib-2.60.2/glib/gutils.c ./glib/gutils.c
|
||||
--- ../glib-2.60.2/glib/gutils.c 2019-05-03 13:43:28.000000000 +0000
|
||||
+++ ./glib/gutils.c 2019-05-11 19:59:12.830415366 +0000
|
||||
@@ -378,7 +378,7 @@
|
||||
* what to search if PATH is unset. POSIX may, dunno.
|
||||
*/
|
||||
|
||||
- path = "/bin:/usr/bin:.";
|
||||
+ path = "@TERMUX_PREFIX@/bin:@TERMUX_PREFIX@/bin/applets:.";
|
||||
}
|
||||
#else
|
||||
n = GetModuleFileNameW (NULL, wfilename, MAXPATHLEN);
|
||||
@@ -958,7 +958,7 @@
|
||||
if (tmp == NULL || *tmp == '\0')
|
||||
{
|
||||
g_free (tmp);
|
||||
- tmp = g_strdup ("/tmp");
|
||||
+ tmp = g_strdup ("@TERMUX_PREFIX@/tmp");
|
||||
}
|
||||
#endif /* !G_OS_WIN32 */
|
||||
|
||||
@@ -2080,7 +2080,7 @@
|
||||
*/
|
||||
#ifndef G_OS_WIN32
|
||||
if (!data_dirs || !data_dirs[0])
|
||||
- data_dirs = "/usr/local/share/:/usr/share/";
|
||||
+ data_dirs = "@TERMUX_PREFIX@/share/";
|
||||
|
||||
data_dir_vector = g_strsplit (data_dirs, G_SEARCHPATH_SEPARATOR_S, 0);
|
||||
#else
|
||||
@@ -2174,7 +2174,7 @@
|
||||
}
|
||||
#else
|
||||
if (!conf_dirs || !conf_dirs[0])
|
||||
- conf_dirs = "/etc/xdg";
|
||||
+ conf_dirs = "@TERMUX_PREFIX@/etc/xdg";
|
||||
|
||||
conf_dir_vector = g_strsplit (conf_dirs, G_SEARCHPATH_SEPARATOR_S, 0);
|
||||
#endif
|
11
packages/glib/meson.build.patch
Normal file
11
packages/glib/meson.build.patch
Normal file
@ -0,0 +1,11 @@
|
||||
diff -u -r ../glib-2.60.2/meson.build ./meson.build
|
||||
--- ../glib-2.60.2/meson.build 2019-05-03 13:43:28.000000000 +0000
|
||||
+++ ./meson.build 2019-05-11 20:10:26.054269305 +0000
|
||||
@@ -360,7 +360,6 @@
|
||||
# https://wiki.gnome.org/Projects/GLib/CompilerRequirements#Function_pointer_conversions.
|
||||
'-Wno-pedantic',
|
||||
'-Werror=declaration-after-statement',
|
||||
- '-Werror=format=2',
|
||||
'-Werror=implicit-function-declaration',
|
||||
'-Werror=init-self',
|
||||
'-Werror=missing-include-dirs',
|
Loading…
Reference in New Issue
Block a user