Using host wayland scanner.

This commit is contained in:
sergiotarxz 2022-05-13 19:39:14 +02:00
parent 6a7f946dad
commit 655e9089fc
1 changed files with 13 additions and 0 deletions

View File

@ -0,0 +1,13 @@
diff --git a/hw/xwayland/meson.build b/hw/xwayland/meson.build
index e848daf0d..42e7b529b 100644
--- a/hw/xwayland/meson.build
+++ b/hw/xwayland/meson.build
@@ -29,7 +29,7 @@ srcs = [
]
scanner_dep = dependency('wayland-scanner', native: true)
-scanner = find_program(scanner_dep.get_pkgconfig_variable('wayland_scanner'))
+scanner = '/usr/bin/wayland-scanner'
protocols_dep = dependency('wayland-protocols', version: wayland_protocols_req)
protodir = protocols_dep.get_pkgconfig_variable('pkgdatadir')