xorgproto: force redefine __FDS_BITS in Xpoll.h

Always use 'fallback' definition of __FDS_BITS:

 '#define __FDS_BITS(p)  ((p)->__X_FDS_BITS)'

Fixes compilation errors for some programs.
This commit is contained in:
Leonid Pliushch 2018-09-28 13:22:30 +03:00 committed by Yaksh Bariya
parent 3aa1afadb6
commit 6908b084f3
No known key found for this signature in database
GPG Key ID: F7486BA7D3D27581
4 changed files with 20 additions and 4 deletions

View File

@ -1,9 +1,9 @@
TERMUX_PKG_MAINTAINER="Leonid Plyushch <leonid.plyushch@gmail.com> @xeffyr"
TERMUX_PKG_HOMEPAGE=https://xorg.freedesktop.org/
TERMUX_PKG_DESCRIPTION="X11 headers"
TERMUX_PKG_DESCRIPTION="X.Org X11 Protocol headers"
TERMUX_PKG_VERSION=2018.4
TERMUX_PKG_REVISION=3
TERMUX_PKG_REVISION=4
TERMUX_PKG_SRCURL=https://xorg.freedesktop.org/archive/individual/proto/xorgproto-${TERMUX_PKG_VERSION}.tar.bz2
TERMUX_PKG_SHA256=fee885e0512899ea5280c593fdb2735beb1693ad170c22ebcc844470eec415a0
TERMUX_PKG_DEPENDS="xorg-util-macros"

View File

@ -1,6 +1,6 @@
diff -uNr xorgproto-2018.4/Makefile.am xorgproto-2018.4.mod/Makefile.am
--- xorgproto-2018.4/Makefile.am 2018-02-28 18:45:07.000000000 +0200
+++ xorgproto-2018.4.mod/Makefile.am 2018-04-09 19:14:29.228322693 +0300
+++ xorgproto-2018.4.mod/Makefile.am 2018-09-28 13:17:51.638785712 +0300
@@ -3,7 +3,7 @@
include/X11/extensions/applewmconst.h \
include/X11/extensions/applewmproto.h

View File

@ -1,6 +1,6 @@
diff -uNr xorgproto-2018.4/Makefile.in xorgproto-2018.4.mod/Makefile.in
--- xorgproto-2018.4/Makefile.in 2018-02-28 18:45:10.000000000 +0200
+++ xorgproto-2018.4.mod/Makefile.in 2018-04-09 19:14:16.616218688 +0300
+++ xorgproto-2018.4.mod/Makefile.in 2018-09-28 13:17:51.642119182 +0300
@@ -475,21 +475,21 @@
include/X11/extensions/applewmconst.h \
include/X11/extensions/applewmproto.h

View File

@ -0,0 +1,16 @@
diff -uNr xorgproto-2018.4/include/X11/Xpoll.h.in xorgproto-2018.4.mod/include/X11/Xpoll.h.in
--- xorgproto-2018.4/include/X11/Xpoll.h.in 2018-02-28 18:45:07.000000000 +0200
+++ xorgproto-2018.4.mod/include/X11/Xpoll.h.in 2018-09-28 13:19:06.115194995 +0300
@@ -98,9 +98,10 @@
#define __X_FDS_BITS @USE_FDS_BITS@
-#ifndef __FDS_BITS
-# define __FDS_BITS(p) ((p)->__X_FDS_BITS)
+#ifdef __FDS_BITS
+# undef __FDS_BITS
#endif
+#define __FDS_BITS(p) ((p)->__X_FDS_BITS)
#define __XFDS_BITS(p, n) (__FDS_BITS(p))[n]