Merge branch 'updates/openal-soft'
This commit is contained in:
commit
69431211e1
@ -1,21 +0,0 @@
|
||||
diff -uNr openal-soft-1.18.2/Alc/alcConfig.c openal-soft-1.18.2.mod/Alc/alcConfig.c
|
||||
--- openal-soft-1.18.2/Alc/alcConfig.c 2017-09-24 16:41:50.000000000 +0300
|
||||
+++ openal-soft-1.18.2.mod/Alc/alcConfig.c 2019-03-02 02:17:37.066950410 +0200
|
||||
@@ -424,7 +424,7 @@
|
||||
al_string ppath;
|
||||
FILE *f;
|
||||
|
||||
- str = "/etc/openal/alsoft.conf";
|
||||
+ str = "@TERMUX_PREFIX@/etc/openal/alsoft.conf";
|
||||
|
||||
TRACE("Loading config %s...\n", str);
|
||||
f = al_fopen(str, "r");
|
||||
@@ -435,7 +435,7 @@
|
||||
}
|
||||
|
||||
if(!(str=getenv("XDG_CONFIG_DIRS")) || str[0] == 0)
|
||||
- str = "/etc/xdg";
|
||||
+ str = "@TERMUX_PREFIX@/etc/xdg";
|
||||
strncpy(buffer, str, sizeof(buffer)-1);
|
||||
buffer[sizeof(buffer)-1] = 0;
|
||||
/* Go through the list in reverse, since "the order of base directories
|
21
packages/openal-soft/alconfig.c.patch
Normal file
21
packages/openal-soft/alconfig.c.patch
Normal file
@ -0,0 +1,21 @@
|
||||
diff -uNr openal-soft-openal-soft-1.19.1/Alc/alconfig.c openal-soft-openal-soft-1.19.1.mod/Alc/alconfig.c
|
||||
--- openal-soft-openal-soft-1.19.1/Alc/alconfig.c 2018-10-12 01:05:31.000000000 +0300
|
||||
+++ openal-soft-openal-soft-1.19.1.mod/Alc/alconfig.c 2019-07-24 14:49:05.040838897 +0300
|
||||
@@ -428,7 +428,7 @@
|
||||
const char *str;
|
||||
FILE *f;
|
||||
|
||||
- str = "/etc/openal/alsoft.conf";
|
||||
+ str = "@TERMUX_PREFIX@/etc/openal/alsoft.conf";
|
||||
|
||||
TRACE("Loading config %s...\n", str);
|
||||
f = al_fopen(str, "r");
|
||||
@@ -439,7 +439,7 @@
|
||||
}
|
||||
|
||||
if(!(str=getenv("XDG_CONFIG_DIRS")) || str[0] == 0)
|
||||
- str = "/etc/xdg";
|
||||
+ str = "@TERMUX_PREFIX@/etc/xdg";
|
||||
alstr_copy_cstr(&confpaths, str);
|
||||
/* Go through the list in reverse, since "the order of base directories
|
||||
* denotes their importance; the first directory listed is the most
|
@ -1,10 +1,9 @@
|
||||
TERMUX_PKG_HOMEPAGE=https://openal-soft.org/
|
||||
TERMUX_PKG_DESCRIPTION="Software implementation of the OpenAL API"
|
||||
TERMUX_PKG_LICENSE="LGPL-2.0"
|
||||
TERMUX_PKG_VERSION=1.18.2
|
||||
TERMUX_PKG_REVISION=2
|
||||
TERMUX_PKG_SHA256=a598241d1af2e90c25a1b91da4c9ddc0e7cb6a4b5f1477fc680d139c57cd38cc
|
||||
TERMUX_PKG_VERSION=1.19.1
|
||||
TERMUX_PKG_SRCURL=https://github.com/kcat/openal-soft/archive/openal-soft-$TERMUX_PKG_VERSION.tar.gz
|
||||
TERMUX_PKG_SHA256=9f3536ab2bb7781dbafabc6a61e0b34b17edd16bd6c2eaf2ae71bc63078f98c7
|
||||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
|
||||
-DALSOFT_UTILS=OFF
|
||||
-DALSOFT_EXAMPLES=OFF
|
||||
|
15
packages/openal-soft/native-tools-CMakeLists.txt.patch
Normal file
15
packages/openal-soft/native-tools-CMakeLists.txt.patch
Normal file
@ -0,0 +1,15 @@
|
||||
diff -uNr openal-soft-openal-soft-1.19.1/native-tools/CMakeLists.txt openal-soft-openal-soft-1.19.1.mod/native-tools/CMakeLists.txt
|
||||
--- openal-soft-openal-soft-1.19.1/native-tools/CMakeLists.txt 2018-10-12 01:05:31.000000000 +0300
|
||||
+++ openal-soft-openal-soft-1.19.1.mod/native-tools/CMakeLists.txt 2019-07-24 15:09:41.667923002 +0300
|
||||
@@ -4,6 +4,11 @@
|
||||
|
||||
include(CheckLibraryExists)
|
||||
|
||||
+set(CMAKE_C_COMPILER gcc)
|
||||
+set(CMAKE_C_FLAGS "")
|
||||
+set(CMAKE_LINKER "")
|
||||
+set(CMAKE_EXE_LINKER_FLAGS "")
|
||||
+
|
||||
set(CPP_DEFS )
|
||||
if(WIN32)
|
||||
set(CPP_DEFS ${CPP_DEFS} _WIN32)
|
Loading…
Reference in New Issue
Block a user