Merge branch 'master' into fast_build_rebased

This commit is contained in:
Henrik Grimler 2019-01-27 10:36:50 +01:00
commit 6b6fb7e5d3
21 changed files with 166 additions and 28 deletions

View File

@ -330,6 +330,7 @@ termux_step_setup_variables() {
: "${TERMUX_REPO_URL:="https://termux.net/dists"}"
: "${TERMUX_REPO_DISTRIBUTION:="stable"}"
: "${TERMUX_REPO_COMPONENT:="main"}"
: "${TERMUX_PKG_MAINTAINER:="Fredrik Fornwall @fornwall"}"
if [ "x86_64" = "$TERMUX_ARCH" ] || [ "aarch64" = "$TERMUX_ARCH" ]; then
TERMUX_ARCH_BITS=64
@ -394,7 +395,6 @@ termux_step_setup_variables() {
TERMUX_PKG_DEVPACKAGE_DEPENDS=""
# Set if a host build should be done in TERMUX_PKG_HOSTBUILD_DIR:
TERMUX_PKG_HOSTBUILD=""
TERMUX_PKG_MAINTAINER="Fredrik Fornwall @fornwall"
TERMUX_PKG_FORCE_CMAKE=no # if the package has autotools as well as cmake, then set this to prefer cmake
TERMUX_CMAKE_BUILD=Ninja # Which cmake generator to use
TERMUX_PKG_HAS_DEBUG=yes # set to no if debug build doesn't exist or doesn't work, for example for python based packages

View File

@ -323,7 +323,7 @@ termux_step_make_install () {
rm -rf android-jar
mkdir android-jar
cd android-jar
cp $ANDROID_HOME/platforms/android-27/android.jar .
cp $ANDROID_HOME/platforms/android-28/android.jar .
unzip -q android.jar
mkdir -p $TERMUX_PREFIX/share/aapt
jar cfM $TERMUX_PREFIX/share/aapt/android.jar AndroidManifest.xml resources.arsc

View File

@ -2,8 +2,8 @@ TERMUX_PKG_HOMEPAGE=https://www.gnu.org/software/bison/
TERMUX_PKG_DESCRIPTION="General-purpose parser generator"
TERMUX_PKG_LICENSE="GPL-3.0"
TERMUX_PKG_DEPENDS="m4"
TERMUX_PKG_VERSION=3.2.4
TERMUX_PKG_SHA256=523d44419f4df68286503740c95c7b3400b748d7d8b797209195ee5d67f05634
TERMUX_PKG_VERSION=3.3
TERMUX_PKG_SHA256=162ea71d21e134c44942f4ebb74685e19c942dcf40a7120eba165ba5e2553bb9
TERMUX_PKG_SRCURL=https://mirrors.kernel.org/gnu/bison/bison-${TERMUX_PKG_VERSION}.tar.xz
TERMUX_PKG_BUILD_IN_SRC=yes
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="M4=m4"

View File

@ -1,9 +1,8 @@
TERMUX_PKG_HOMEPAGE=http://bs1770gain.sourceforge.net/
TERMUX_PKG_DESCRIPTION="Tool to normalize the loudness of different audio files to the same level"
TERMUX_PKG_LICENSE="GPL-2.0"
TERMUX_PKG_VERSION=0.5.1
TERMUX_PKG_REVISION=1
TERMUX_PKG_VERSION=0.5.2
TERMUX_PKG_SHA256=73e5738786b57afb89582333ed18206fd2c6d5245717d3b24ace7f7670f9dedc
TERMUX_PKG_SRCURL=https://downloads.sourceforge.net/project/bs1770gain/bs1770gain/${TERMUX_PKG_VERSION}/bs1770gain-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=06749f866417e6bcdb9fb24883cb08ae54248333a532380c7ddc56f7a45a8e64
TERMUX_PKG_DEPENDS="ffmpeg, sox"

View File

@ -51,7 +51,7 @@ termux_step_make () {
cd android-jar
# We need the android classes for JDT to compile against.
cp $ANDROID_HOME/platforms/android-27/android.jar .
cp $ANDROID_HOME/platforms/android-28/android.jar .
unzip -q android.jar
rm -Rf android.jar resources.arsc res assets
jar cfM android.jar .

View File

@ -51,7 +51,7 @@ termux_step_make () {
cd android-jar
# We need the android classes for JDT to compile against.
cp $ANDROID_HOME/platforms/android-27/android.jar .
cp $ANDROID_HOME/platforms/android-28/android.jar .
unzip -q android.jar
rm -Rf android.jar resources.arsc res assets
jar cfM android.jar .

View File

@ -1,8 +1,8 @@
TERMUX_PKG_HOMEPAGE=https://www.erlang.org/
TERMUX_PKG_DESCRIPTION="General-purpose concurrent functional programming language"
TERMUX_PKG_LICENSE="Apache-2.0"
TERMUX_PKG_VERSION=21.2.3
TERMUX_PKG_SHA256=109a5722e398bdcd3aeb4f4833cde90bf441a9c014006439643aab550a770923
TERMUX_PKG_VERSION=21.2.4
TERMUX_PKG_SHA256=833d31ac102536b752e474dc6d69be7cc3e37d2d944191317312b30b1ea8ef0d
TERMUX_PKG_SRCURL=https://github.com/erlang/otp/archive/OTP-$TERMUX_PKG_VERSION.tar.gz
TERMUX_PKG_DEPENDS="openssl, ncurses, libutil"
TERMUX_PKG_HOSTBUILD="yes"

View File

@ -1,8 +1,8 @@
TERMUX_PKG_HOMEPAGE=https://hub.github.com/
TERMUX_PKG_DESCRIPTION="Command-line wrapper for git that makes you better at GitHub"
TERMUX_PKG_LICENSE="MIT"
TERMUX_PKG_VERSION=2.7.1
TERMUX_PKG_SHA256=83fac8b47b2f56da1e7366688df4bd0eeb5fa20bde5d3de39792ea1cc1d15cd4
TERMUX_PKG_VERSION=2.8.3
TERMUX_PKG_SHA256=26bc1bc6fd8b6af379445728450d9c1e26a6d1861fdff5c2b552562eb7487a96
TERMUX_PKG_SRCURL=https://github.com/github/hub/archive/v${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_DEPENDS="git"

View File

@ -0,0 +1,12 @@
diff -u -r ../hub-2.8.3/script/build ./script/build
--- ../hub-2.8.3/script/build 2019-01-26 17:47:05.000000000 +0000
+++ ./script/build 2019-01-27 08:10:53.521236847 +0000
@@ -14,7 +14,7 @@
build_hub() {
mkdir -p "$(dirname "$1")"
go build \
- -ldflags "-X github.com/github/hub/version.Version=`./script/version` $LDFLAGS" \
+ -ldflags "-X github.com/github/hub/version.Version=`./script/version`" \
-gcflags "$GCFLAGS" \
-asmflags "$ASMFLAGS" \
-o "$1"

View File

@ -2,8 +2,8 @@ TERMUX_PKG_HOMEPAGE=https://www.gnutls.org/
TERMUX_PKG_DESCRIPTION="Secure communications library implementing the SSL, TLS and DTLS protocols and technologies around them"
TERMUX_PKG_LICENSE="LGPL-2.1"
TERMUX_PKG_DEPENDS="libgmp, libnettle, ca-certificates, libidn2, libunistring"
TERMUX_PKG_VERSION=3.6.5
TERMUX_PKG_SHA256=073eced3acef49a3883e69ffd5f0f0b5f46e2760ad86eddc6c0866df4e7abb35
TERMUX_PKG_VERSION=3.6.6
TERMUX_PKG_SHA256=bb9acab8af2ac430edf45faaaa4ed2c51f86e57cb57689be6701aceef4732ca7
TERMUX_PKG_SRCURL=https://www.gnupg.org/ftp/gcrypt/gnutls/v${TERMUX_PKG_VERSION:0:3}/gnutls-${TERMUX_PKG_VERSION}.tar.xz
TERMUX_PKG_DEVPACKAGE_DEPENDS="libidn2-dev, libnettle-dev"
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
@ -15,3 +15,7 @@ TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
--with-included-libtasn1
--without-p11-kit
"
termux_step_pre_configure() {
CFLAGS+=" -DNO_INLINE_GETPASS=1"
}

View File

@ -1,8 +1,8 @@
TERMUX_PKG_HOMEPAGE=https://nodejs.org/
TERMUX_PKG_DESCRIPTION="Platform built on Chrome's JavaScript runtime for easily building fast, scalable network applications"
TERMUX_PKG_LICENSE="MIT"
TERMUX_PKG_VERSION=11.7.0
TERMUX_PKG_SHA256=07febdd8722f6e24ad0cb9360e183baa75a07cad390c14896e3d97027e0fada2
TERMUX_PKG_VERSION=11.8.0
TERMUX_PKG_SHA256=7041550b94211d65ef0bee76c02bd5ddfdd9122c6d4b289323194edbfbe447a0
TERMUX_PKG_SRCURL=https://nodejs.org/dist/v${TERMUX_PKG_VERSION}/node-v${TERMUX_PKG_VERSION}.tar.xz
# Note that we do not use a shared libuv to avoid an issue with the Android
# linker, which does not use symbols of linked shared libraries when resolving

View File

@ -1,7 +1,7 @@
diff -u -r ../node-v11.0.0/node.gyp ./node.gyp
--- ../node-v11.0.0/node.gyp 2018-10-23 15:59:38.000000000 +0000
+++ ./node.gyp 2018-10-25 20:46:25.481050534 +0000
@@ -848,78 +848,7 @@
diff -u -r ../node-v11.8.0/node.gyp ./node.gyp
--- ../node-v11.8.0/node.gyp 2019-01-24 23:19:08.000000000 +0000
+++ ./node.gyp 2019-01-27 08:15:48.080455307 +0000
@@ -945,101 +945,7 @@
],
} ],
]
@ -75,6 +75,29 @@ diff -u -r ../node-v11.0.0/node.gyp ./node.gyp
- 'OTHER_LDFLAGS': [ '-Wl,-rpath,@loader_path', ],
- },
- }],
- [ 'node_report=="true"', {
- 'defines': [
- 'NODE_REPORT',
- 'NODE_ARCH="<(target_arch)"',
- 'NODE_PLATFORM="<(OS)"',
- ],
- 'conditions': [
- ['OS=="win"', {
- 'libraries': [
- 'dbghelp.lib',
- 'Netapi32.lib',
- 'PsApi.lib',
- 'Ws2_32.lib',
- ],
- 'dll_files': [
- 'dbghelp.dll',
- 'Netapi32.dll',
- 'PsApi.dll',
- 'Ws2_32.dll',
- ],
- }],
- ],
- }],
- ],
- }, # cctest
+ } # rename_node_bin_win

View File

@ -2,6 +2,7 @@ TERMUX_PKG_HOMEPAGE=https://rada.re
TERMUX_PKG_DESCRIPTION="Advanced Hexadecimal Editor"
TERMUX_PKG_LICENSE="GPL-3.0"
TERMUX_PKG_VERSION=3.2.1
TERMUX_PKG_REVISION=1
TERMUX_PKG_SHA256=a4d0c1b3a3dfd810749578227940b8ea77e517d2c4d284c9687e49224a272796
TERMUX_PKG_SRCURL=https://github.com/radare/radare2/archive/$TERMUX_PKG_VERSION.tar.gz
TERMUX_PKG_DEPENDS="libuv"

View File

@ -0,0 +1,13 @@
--- radare2-3.2.1_2/shlr/Makefile
+++ radare2-3.2.1/shlr/Makefile
@@ -25,8 +25,8 @@
CS_URL=$(GIT_PREFIX)github.com/aquynh/capstone.git
CS_UPD=20181224
# NOTE: when you update CS_TIP or CS_BRA, also update them in shlr/meson.build
-CS_BRA=v4.1
-CS_TIP=0ff8220adef16a942697afd245afc5ab0f70cbf8
+CS_BRA=master
+CS_TIP=58a80a93f995c23a8681dcc38dccfc6bab9cd7a4
# REVERT THIS COMMIT BECAUSE ITS WRONG
CS_REV=
CS_PATCHES=1

View File

@ -2,7 +2,13 @@ TERMUX_PKG_HOMEPAGE=https://www.tarsnap.com/scrypt.html
TERMUX_PKG_DESCRIPTION="scrypt KDF library and file encryption tool"
TERMUX_PKG_LICENSE="BSD 2-Clause"
TERMUX_PKG_VERSION=1.2.1
TERMUX_PKG_REVISION=1
TERMUX_PKG_REVISION=2
TERMUX_PKG_SRCURL=https://www.tarsnap.com/scrypt/scrypt-1.2.1.tgz
TERMUX_PKG_SHA256=4621f5e7da2f802e20850436219370092e9fcda93bd598f6d4236cce33f4c577
TERMUX_PKG_DEPENDS="openssl"
termux_step_pre_configure() {
# Work around miscompilation on at least aarch64 with -Oz,
# see https://github.com/termux/termux-packages/issues/3260:
export CFLAGS=${CFLAGS/-Oz/-Os}
}

View File

@ -0,0 +1,43 @@
Submitted upstream at https://github.com/michalbednarski/TermuxAm/pull/4
diff --git a/app/build.gradle b/app/build.gradle
index 7888fcd..07c189e 100644
--- a/app/build.gradle
+++ b/app/build.gradle
@@ -1,11 +1,11 @@
apply plugin: 'com.android.application'
android {
- compileSdkVersion 26
+ compileSdkVersion 28
defaultConfig {
applicationId "com.example.termuxam"
minSdkVersion 21
- targetSdkVersion 26
+ targetSdkVersion 28
versionCode 1
versionName "0.1"
testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
diff --git a/build.gradle b/build.gradle
index e6b32bc..6c2bb63 100644
--- a/build.gradle
+++ b/build.gradle
@@ -7,7 +7,7 @@ buildscript {
jcenter()
}
dependencies {
- classpath 'com.android.tools.build:gradle:3.0.1'
+ classpath 'com.android.tools.build:gradle:3.3.0'
// NOTE: Do not place your application dependencies here; they belong
diff --git a/gradle/wrapper/gradle-wrapper.properties b/gradle/wrapper/gradle-wrapper.properties
index a23653e..4f86dee 100644
--- a/gradle/wrapper/gradle-wrapper.properties
+++ b/gradle/wrapper/gradle-wrapper.properties
@@ -3,4 +3,4 @@ distributionBase=GRADLE_USER_HOME
distributionPath=wrapper/dists
zipStoreBase=GRADLE_USER_HOME
zipStorePath=wrapper/dists
-distributionUrl=https\://services.gradle.org/distributions/gradle-4.1-all.zip
+distributionUrl=https\://services.gradle.org/distributions/gradle-5.1.1-all.zip

View File

@ -5,7 +5,7 @@ TERMUX_PKG_VERSION=6.0
TERMUX_PKG_REVISION=3
TERMUX_PKG_SRCURL=https://downloads.sourceforge.net/infozip/unzip60.tar.gz
TERMUX_PKG_SHA256=036d96991646d0449ed0aa952e4fbe21b476ce994abc276e49d30e686708bd37
TERMUX_PKG_DEPENDS="libandroid-support, libbz2"
TERMUX_PKG_DEPENDS="libbz2"
TERMUX_PKG_BUILD_IN_SRC=yes
termux_step_configure () {

View File

@ -0,0 +1,38 @@
diff -u -r ../unzip60/unzip.c ./unzip.c
--- ../unzip60/unzip.c 2009-04-16 18:26:52.000000000 +0000
+++ ./unzip.c 2019-01-27 06:36:11.933232400 +0000
@@ -762,34 +762,7 @@
/* see if can use UTF-8 Unicode locale */
# ifdef UTF8_MAYBE_NATIVE
{
- char *codeset;
-# if !(defined(NO_NL_LANGINFO) || defined(NO_LANGINFO_H))
- /* get the codeset (character set encoding) currently used */
-# include <langinfo.h>
-
- codeset = nl_langinfo(CODESET);
-# else /* NO_NL_LANGINFO || NO_LANGINFO_H */
- /* query the current locale setting for character classification */
- codeset = setlocale(LC_CTYPE, NULL);
- if (codeset != NULL) {
- /* extract the codeset portion of the locale name */
- codeset = strchr(codeset, '.');
- if (codeset != NULL) ++codeset;
- }
-# endif /* ?(NO_NL_LANGINFO || NO_LANGINFO_H) */
- /* is the current codeset UTF-8 ? */
- if ((codeset != NULL) && (strcmp(codeset, "UTF-8") == 0)) {
- /* successfully found UTF-8 char coding */
G.native_is_utf8 = TRUE;
- } else {
- /* Current codeset is not UTF-8 or cannot be determined. */
- G.native_is_utf8 = FALSE;
- }
- /* Note: At least for UnZip, trying to change the process codeset to
- * UTF-8 does not work. For the example Linux setup of the
- * UnZip maintainer, a successful switch to "en-US.UTF-8"
- * resulted in garbage display of all non-basic ASCII characters.
- */
}
# endif /* UTF8_MAYBE_NATIVE */

View File

@ -1,9 +1,8 @@
TERMUX_PKG_HOMEPAGE=https://www.zsh.org
TERMUX_PKG_DESCRIPTION="Shell with lots of features"
TERMUX_PKG_LICENSE="BSD"
TERMUX_PKG_VERSION=5.6.2
TERMUX_PKG_REVISION=1
TERMUX_PKG_SHA256=a50bd66c0557e8eca3b8fa24e85d0de533e775d7a22df042da90488623752e9e
TERMUX_PKG_VERSION=5.7
TERMUX_PKG_SHA256=7807b290b361d9fa1e4c2dfafc78cb7e976e7015652e235889c6eff7468bd613
TERMUX_PKG_SRCURL=https://fossies.org/linux/misc/zsh-${TERMUX_PKG_VERSION}.tar.xz
# Remove hard link to bin/zsh as Android does not support hard links:
TERMUX_PKG_RM_AFTER_INSTALL="bin/zsh-${TERMUX_PKG_VERSION}"

View File

@ -1,5 +1,5 @@
TERMUX_NDK_VERSION=18
TERMUX_ANDROID_BUILD_TOOLS_VERSION=28.0.2
TERMUX_ANDROID_BUILD_TOOLS_VERSION=28.0.3
test -f "$HOME/.termuxrc" && . "$HOME/.termuxrc"

View File

@ -43,4 +43,4 @@ fi
yes | $ANDROID_HOME/tools/bin/sdkmanager --licenses
# The android-21 platform is used in the ecj package:
yes | $ANDROID_HOME/tools/bin/sdkmanager "build-tools;${TERMUX_ANDROID_BUILD_TOOLS_VERSION}" "platforms;android-27" "platforms;android-21"
yes | $ANDROID_HOME/tools/bin/sdkmanager "platform-tools" "build-tools;${TERMUX_ANDROID_BUILD_TOOLS_VERSION}" "platforms;android-28" "platforms;android-21"