libjxl: update to 0.6

This commit is contained in:
Lucy Phipps 2021-10-04 22:36:08 +01:00
parent 684dc2c781
commit 6c9358d89c
No known key found for this signature in database
GPG Key ID: 8F688A3DB7869BFE
2 changed files with 5 additions and 6 deletions

View File

@ -2,10 +2,9 @@ TERMUX_PKG_HOMEPAGE=https://jpegxl.info/
TERMUX_PKG_DESCRIPTION="JPEG XL image format reference implementation"
TERMUX_PKG_LICENSE="BSD 3-Clause"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=0.5
TERMUX_PKG_REVISION=1
TERMUX_PKG_VERSION=0.6
TERMUX_PKG_SRCURL=https://github.com/libjxl/libjxl/archive/refs/tags/v${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=911cb4b50eb621131ca22382166f40d4914a4ff4453dd299ade1e3292f311f89
TERMUX_PKG_SHA256=89584e20c6e537d8d65d286fd6ae48d5d6abb087ca89f3207238d8d7e6ced4dc
TERMUX_PKG_AUTO_UPDATE=true
TERMUX_PKG_DEPENDS=brotli

View File

@ -2,15 +2,15 @@ diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
index 1ff120c99..6e577ceb6 100644
--- a/tools/CMakeLists.txt
+++ b/tools/CMakeLists.txt
@@ -166,7 +166,7 @@ if(${JPEGXL_ENABLE_BENCHMARK})
@@ -210,7 +210,7 @@ if(${JPEGXL_ENABLE_BENCHMARK})
speed_stats.h
../third_party/dirent.cc
)
- target_link_libraries(benchmark_xl Threads::Threads)
+ target_link_libraries(benchmark_xl Threads::Threads -landroid-spawn)
target_compile_definitions(benchmark_xl
PRIVATE "-DJPEGXL_VERSION=\"${JPEGXL_VERSION}\"")
if(MINGW)
# MINGW doesn't support glob.h.
target_compile_definitions(benchmark_xl PRIVATE "-DHAS_GLOB=0")
diff --git a/third_party/sjpeg/CMakeLists.txt b/third_party/sjpeg/CMakeLists.txt
index 5b0048265..ab385a117 100644
--- a/third_party/sjpeg/CMakeLists.txt