nushell: update from 0.15.0 to 0.17.0

This commit is contained in:
Butta 2020-07-27 13:23:45 +05:30 committed by buttaface
parent 54f3771d1c
commit 6cec619ea0
4 changed files with 22 additions and 58 deletions

View File

@ -1,12 +1,22 @@
diff -uNr nushell-0.15.0/Cargo.toml nushell-0.15.0.mod/Cargo.toml
--- nushell-0.15.0/Cargo.toml 2020-06-09 23:39:15.000000000 +0300
+++ nushell-0.15.0.mod/Cargo.toml 2020-06-21 19:36:42.914555630 +0300
@@ -57,7 +57,7 @@
nu-build = { version = "0.15.0", path = "./crates/nu-build" }
diff --git a/Cargo.toml b/Cargo.toml
index ddc8f2a8..5a269394 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -51,7 +51,7 @@ dunce = "1.0.1"
futures = {version = "0.3", features = ["compat", "io-compat"]}
log = "0.4.8"
pretty_env_logger = "0.4.0"
-starship = "0.43.0"
+#starship = "0.43.0"
[dev-dependencies]
nu-test-support = {version = "0.17.0", path = "./crates/nu-test-support"}
@@ -63,8 +63,6 @@ toml = "0.5.6"
[features]
-default = ["sys", "ps", "textview", "inc"]
+default = ["textview", "inc"]
stable = ["default", "starship-prompt", "binaryview", "match", "tree", "post", "fetch", "clipboard-cli", "trash-support", "start"]
# Default
default = [
- "sys",
- "ps",
"textview",
"inc",
"git-support",

View File

@ -1,9 +1,8 @@
TERMUX_PKG_HOMEPAGE=https://www.nushell.sh
TERMUX_PKG_DESCRIPTION="A new type of shell operating on structured data"
TERMUX_PKG_LICENSE="MIT"
TERMUX_PKG_VERSION=0.15.0
TERMUX_PKG_REVISION=1
TERMUX_PKG_VERSION=0.17.0
TERMUX_PKG_SRCURL=https://github.com/nushell/nushell/archive/$TERMUX_PKG_VERSION.tar.gz
TERMUX_PKG_SHA256=f19e580b645ff047e3b7cb2e0823654e020cd5c62b22e601caf6be579204dc2a
TERMUX_PKG_SHA256=85203e8f5531a8a362d25a1b9ae0135a605b70770cb249e268f17dc5bd794249
TERMUX_PKG_DEPENDS="zlib"
TERMUX_PKG_BUILD_IN_SRC=true

View File

@ -1,12 +0,0 @@
diff -uNr nushell-0.15.0/crates/nu-cli/Cargo.toml nushell-0.15.0.mod/crates/nu-cli/Cargo.toml
--- nushell-0.15.0/crates/nu-cli/Cargo.toml 2020-06-09 23:39:15.000000000 +0300
+++ nushell-0.15.0.mod/crates/nu-cli/Cargo.toml 2020-06-21 20:37:20.916311059 +0300
@@ -26,7 +26,7 @@
async-stream = "0.2"
base64 = "0.12.1"
bigdecimal = { version = "0.1.2", features = ["serde"] }
-bson = { version = "0.14.1", features = ["decimal128"] }
+bson = "0.14.1"
byte-unit = "3.1.3"
bytes = "0.5.4"
calamine = "0.16"

View File

@ -1,33 +0,0 @@
diff --git a/crates/nu-cli/src/commands/from_bson.rs b/crates/nu-cli/src/commands/from_bson.rs
index 92849e67..599c08f5 100644
--- a/crates/nu-cli/src/commands/from_bson.rs
+++ b/crates/nu-cli/src/commands/from_bson.rs
@@ -74,18 +74,18 @@ fn convert_bson_value_to_nu_value(v: &Bson, tag: impl Into<Tag>) -> Result<Value
}
Bson::I32(n) => UntaggedValue::int(*n).into_value(&tag),
Bson::I64(n) => UntaggedValue::int(*n).into_value(&tag),
- Bson::Decimal128(n) => {
+ //Bson::Decimal128(n) => {
// TODO: this really isn't great, and we should update this to do a higher
// fidelity translation
- let decimal = BigDecimal::from_str(&format!("{}", n)).map_err(|_| {
- ShellError::range_error(
- ExpectedRange::BigDecimal,
- &n.spanned(span),
- "converting BSON Decimal128 to BigDecimal".to_owned(),
- )
- })?;
- UntaggedValue::Primitive(Primitive::Decimal(decimal)).into_value(&tag)
- }
+ //let decimal = BigDecimal::from_str(&format!("{}", n)).map_err(|_| {
+ //ShellError::range_error(
+ //ExpectedRange::BigDecimal,
+ //&n.spanned(span),
+ //"converting BSON Decimal128 to BigDecimal".to_owned(),
+ //)
+ //})?;
+ //UntaggedValue::Primitive(Primitive::Decimal(decimal)).into_value(&tag)
+ //}
Bson::JavaScriptCode(js) => {
let mut collected = TaggedDictBuilder::new(tag.clone());
collected.insert_value(