luv: Add package

This commit is contained in:
Fredrik Fornwall 2019-09-17 22:27:55 +02:00
parent 72860206c4
commit 6cf01c56cb
3 changed files with 44 additions and 0 deletions

View File

@ -0,0 +1,11 @@
diff -u -r ../luv-1.30.1-0/CMakeLists.txt ./CMakeLists.txt
--- ../luv-1.30.1-0/CMakeLists.txt 2019-08-02 04:08:32.000000000 +0000
+++ ./CMakeLists.txt 2019-09-17 19:52:12.573735604 +0000
@@ -107,7 +107,6 @@
include_directories(${LUAJIT_INCLUDE_DIR})
link_directories(${LUAJIT_LIBRARIES})
else (USE_LUAJIT)
- find_package(Lua REQUIRED)
include_directories(${LUA_INCLUDE_DIR})
endif (USE_LUAJIT)

21
packages/luv/build.sh Normal file
View File

@ -0,0 +1,21 @@
TERMUX_PKG_HOMEPAGE=https://github.com/luvit/luv
TERMUX_PKG_DESCRIPTION="Bare libuv bindings for lua"
TERMUX_PKG_LICENSE="Apache-2.0"
TERMUX_PKG_VERSION="1.30.1-0"
TERMUX_PKG_SHA256=420fc299f3b25aff55b839e9fe590982f45045b3e53ebeab2449eca7e23a106a
TERMUX_PKG_SRCURL=https://github.com/luvit/luv/releases/download/$TERMUX_PKG_VERSION/luv-$TERMUX_PKG_VERSION.tar.gz
TERMUX_PKG_DEPENDS="liblua, libuv"
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
-DBUILD_MODULE=OFF
-DBUILD_SHARED_LIBS=ON
-DLUA_BUILD_TYPE=System
-DLUA_INCLUDE_DIR=$TERMUX_PREFIX/include
-DLUA_LIBRARY=$TERMUX_PREFIX/lib/liblua.so
-DWITH_LUA_ENGINE=Lua
-DWITH_SHARED_LIBUV=ON
"
termux_step_post_extract_package() {
# https://github.com/luvit/luv/issues/376
cp $TERMUX_PKG_BUILDER_DIR/libluv.pc.in $TERMUX_PKG_SRCDIR
}

12
packages/luv/libluv.pc.in Normal file
View File

@ -0,0 +1,12 @@
prefix=@prefix@
exec_prefix=${prefix}
libdir=@libdir@
includedir=@includedir@
Name: libluv
Version: @LUV_VERSION@
Description: Bare and full libuv bindings for Lua/LuaJIT.
URL: https://github.com/luvit/luv
Libs: -L${libdir} -lluv @LIBS@
Cflags: -I${includedir}