chore(starship): update to 1.6.2

Signed-off-by: Aditya Alok <dev.aditya.alok@gmail.com>
This commit is contained in:
Aditya Alok 2022-04-16 10:11:54 +05:30
parent 755074b1df
commit 6e63cf1832
No known key found for this signature in database
GPG Key ID: 345AE134142077D8
2 changed files with 37 additions and 37 deletions

View File

@ -1,14 +1,22 @@
See https://github.com/starship/starship/issues/3488
--- ./Cargo.toml.orig 2022-02-21 15:42:58.538685423 +0530
+++ ./Cargo.toml 2022-02-21 15:43:19.478685415 +0530
@@ -22,10 +22,6 @@
is-it-maintained-open-issues = { repository = "starship/starship" }
maintenance = { status = "actively-developed" }
--- a/Cargo.toml 2022-04-16 06:14:30.643293763 +0000
+++ b/Cargo.toml 2022-04-16 06:42:14.845895669 +0000
@@ -30,8 +30,7 @@
"""
-[features]
-default = ["battery"]
[features]
-default = ["battery", "notify"]
-battery = ["starship-battery"]
-
[dependencies]
ansi_term = "0.12.1"
byte-unit = "4.0.13"
+default = ["notify"]
config-schema = ["schemars"]
notify = ["notify-rust"]
@@ -67,9 +66,6 @@
serde_json = "1.0.79"
sha-1 = "0.10.0"
shadow-rs = "0.11.0"
-# battery is optional (on by default) because the crate doesn't currently build for Termux
-# see: https://github.com/svartalf/rust-battery/issues/33
-starship-battery = { version = "0.7.9", optional = true }
strsim = "0.10.0"
sys-info = "0.9.1"
terminal_size = "0.1.17"

View File

@ -2,13 +2,13 @@ TERMUX_PKG_HOMEPAGE=https://starship.rs
TERMUX_PKG_DESCRIPTION="A minimal, blazing fast, and extremely customizable prompt for any shell"
TERMUX_PKG_LICENSE="ISC"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=1.5.4
TERMUX_PKG_VERSION=1.6.2
TERMUX_PKG_SRCURL=https://github.com/starship/starship/archive/v$TERMUX_PKG_VERSION.tar.gz
TERMUX_PKG_SHA256=158003cd192f9375e504b9ab84d9239a06a8f9732cdd201243ab2fdcd38043f8
TERMUX_PKG_SHA256=4151b3133f3fb0e649847f7714ac77282a4e2dd47fda7f5a08a4f7e87f44b277
TERMUX_PKG_AUTO_UPDATE=true
TERMUX_PKG_DEPENDS="openssl, zlib"
TERMUX_PKG_BUILD_IN_SRC=true
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--no-default-features --features http"
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--all-features"
termux_step_pre_configure() {
termux_setup_rust
@ -20,7 +20,7 @@ termux_step_pre_configure() {
local d
for d in $CARGO_HOME/registry/src/github.com-*/libgit2-sys-*/libgit2; do
patch --silent -p1 -d ${d} \
< $TERMUX_SCRIPTDIR/packages/libgit2/src-rand.c.patch || :
<$TERMUX_SCRIPTDIR/packages/libgit2/src-rand.c.patch || :
cp $TERMUX_SCRIPTDIR/packages/libgit2/getloadavg.c ${d}/src/ || :
done
@ -40,14 +40,6 @@ termux_step_pre_configure() {
$_CARGO_TARGET_LIBDIR/libz.so
}
termux_step_make() {
cargo build --jobs $TERMUX_MAKE_PROCESSES --target ${CARGO_TARGET_NAME} --release
}
termux_step_make_install() {
install -Dm755 -t $TERMUX_PREFIX/bin target/${CARGO_TARGET_NAME}/release/starship
}
termux_step_post_make_install() {
mv $TERMUX_PREFIX/lib/libz.so.1{.tmp,}
mv $TERMUX_PREFIX/lib/libz.so{.tmp,}
@ -59,21 +51,21 @@ termux_step_post_massage() {
}
termux_step_create_debscripts() {
cat <<- EOF > ./postinst
#!$TERMUX_PREFIX/bin/sh
mkdir -p $TERMUX_PREFIX/share/bash-completions/completions
mkdir -p $TERMUX_PREFIX/share/fish/vendor_completions.d
mkdir -p $TERMUX_PREFIX/share/zsh/site-functions
cat <<-EOF >./postinst
#!$TERMUX_PREFIX/bin/sh
mkdir -p $TERMUX_PREFIX/share/bash-completions/completions
mkdir -p $TERMUX_PREFIX/share/fish/vendor_completions.d
mkdir -p $TERMUX_PREFIX/share/zsh/site-functions
starship completions bash > $TERMUX_PREFIX/share/bash-completions/completions/starship
starship completions fish > $TERMUX_PREFIX/share/fish/vendor_completions.d/starship.fish
starship completions zsh > $TERMUX_PREFIX/share/zsh/site-functions/_starship
starship completions bash > $TERMUX_PREFIX/share/bash-completions/completions/starship
starship completions fish > $TERMUX_PREFIX/share/fish/vendor_completions.d/starship.fish
starship completions zsh > $TERMUX_PREFIX/share/zsh/site-functions/_starship
EOF
cat <<- EOF > ./prerm
#!$TERMUX_PREFIX/bin/sh
rm -f $TERMUX_PREFIX/share/bash-completions/completions/starship
rm -f $TERMUX_PREFIX/share/fish/vendor_completions.d/starship.fish
rm -f $TERMUX_PREFIX/share/zsh/site-functions/_starship
cat <<-EOF >./prerm
#!$TERMUX_PREFIX/bin/sh
rm -f $TERMUX_PREFIX/share/bash-completions/completions/starship
rm -f $TERMUX_PREFIX/share/fish/vendor_completions.d/starship.fish
rm -f $TERMUX_PREFIX/share/zsh/site-functions/_starship
EOF
}