libuv: update patches
This commit is contained in:
parent
abd4236c29
commit
6ee315200b
@ -1,9 +1,9 @@
|
|||||||
diff -u -r ../libuv-v1.34.0/Makefile.am ./Makefile.am
|
diff -uNr libuv-v1.38.1/Makefile.am libuv-v1.38.1.mod/Makefile.am
|
||||||
--- ../libuv-v1.34.0/Makefile.am 2019-12-04 03:11:28.000000000 +0000
|
--- libuv-v1.38.1/Makefile.am 2020-07-03 19:51:27.000000000 +0300
|
||||||
+++ ./Makefile.am 2020-01-02 19:24:23.274396000 +0000
|
+++ libuv-v1.38.1.mod/Makefile.am 2020-07-22 19:44:17.806814523 +0300
|
||||||
@@ -387,14 +387,7 @@
|
@@ -382,13 +382,7 @@
|
||||||
if ANDROID
|
|
||||||
uvinclude_HEADERS += include/uv/android-ifaddrs.h
|
uvinclude_HEADERS += include/uv/android-ifaddrs.h
|
||||||
|
libuv_la_CFLAGS += -D_GNU_SOURCE
|
||||||
libuv_la_SOURCES += src/unix/android-ifaddrs.c \
|
libuv_la_SOURCES += src/unix/android-ifaddrs.c \
|
||||||
- src/unix/linux-core.c \
|
- src/unix/linux-core.c \
|
||||||
- src/unix/linux-inotify.c \
|
- src/unix/linux-inotify.c \
|
||||||
@ -11,8 +11,7 @@ diff -u -r ../libuv-v1.34.0/Makefile.am ./Makefile.am
|
|||||||
- src/unix/procfs-exepath.c \
|
- src/unix/procfs-exepath.c \
|
||||||
- src/unix/pthread-fixes.c \
|
- src/unix/pthread-fixes.c \
|
||||||
- src/unix/random-getrandom.c \
|
- src/unix/random-getrandom.c \
|
||||||
- src/unix/random-sysctl-linux.c \
|
- src/unix/random-sysctl-linux.c
|
||||||
- src/unix/sysinfo-loadavg.c
|
|
||||||
+ src/unix/pthread-fixes.c
|
+ src/unix/pthread-fixes.c
|
||||||
endif
|
endif
|
||||||
|
|
||||||
|
@ -1,46 +1,28 @@
|
|||||||
diff -u -r ../libuv-v1.9.1/src/unix/internal.h ./src/unix/internal.h
|
diff -uNr libuv-v1.38.1/src/unix/internal.h libuv-v1.38.1.mod/src/unix/internal.h
|
||||||
--- ../libuv-v1.9.1/src/unix/internal.h 2016-05-16 17:22:19.000000000 -0400
|
--- libuv-v1.38.1/src/unix/internal.h 2020-07-03 19:51:27.000000000 +0300
|
||||||
+++ ./src/unix/internal.h 2016-05-18 10:48:45.456553752 -0400
|
+++ libuv-v1.38.1.mod/src/unix/internal.h 2020-07-22 19:48:38.768135484 +0300
|
||||||
@@ -55,14 +55,6 @@
|
@@ -70,7 +70,7 @@
|
||||||
# include <CoreServices/CoreServices.h>
|
# define UV__PATH_MAX 8192
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
-#if defined(__ANDROID__)
|
-#if defined(__ANDROID__)
|
||||||
-int uv__pthread_sigmask(int how, const sigset_t* set, sigset_t* oset);
|
+#if defined(__ANDROID__) && !defined(__TERMUX__)
|
||||||
-# ifdef pthread_sigmask
|
int uv__pthread_sigmask(int how, const sigset_t* set, sigset_t* oset);
|
||||||
-# undef pthread_sigmask
|
# ifdef pthread_sigmask
|
||||||
-# endif
|
# undef pthread_sigmask
|
||||||
-# define pthread_sigmask(how, set, oldset) uv__pthread_sigmask(how, set, oldset)
|
diff -uNr libuv-v1.38.1/src/unix/pthread-fixes.c libuv-v1.38.1.mod/src/unix/pthread-fixes.c
|
||||||
-#endif
|
--- libuv-v1.38.1/src/unix/pthread-fixes.c 2020-07-03 19:51:27.000000000 +0300
|
||||||
-
|
+++ libuv-v1.38.1.mod/src/unix/pthread-fixes.c 2020-07-22 19:47:31.267794580 +0300
|
||||||
#define ACCESS_ONCE(type, var) \
|
@@ -36,6 +36,7 @@
|
||||||
(*(volatile type*) &(var))
|
|
||||||
|
|
||||||
diff -u -r ../libuv-v1.9.1/src/unix/pthread-fixes.c ./src/unix/pthread-fixes.c
|
|
||||||
--- ../libuv-v1.9.1/src/unix/pthread-fixes.c 2016-05-16 17:22:19.000000000 -0400
|
|
||||||
+++ ./src/unix/pthread-fixes.c 2016-05-18 10:47:54.209328719 -0400
|
|
||||||
@@ -33,24 +33,3 @@
|
|
||||||
#include <errno.h>
|
|
||||||
#include <pthread.h>
|
#include <pthread.h>
|
||||||
#include <signal.h>
|
#include <signal.h>
|
||||||
-
|
|
||||||
-int uv__pthread_sigmask(int how, const sigset_t* set, sigset_t* oset) {
|
+#ifndef __TERMUX__
|
||||||
- static int workaround;
|
int uv__pthread_sigmask(int how, const sigset_t* set, sigset_t* oset) {
|
||||||
- int err;
|
static int workaround;
|
||||||
-
|
int err;
|
||||||
- if (workaround) {
|
@@ -56,3 +57,4 @@
|
||||||
- return sigprocmask(how, set, oset);
|
|
||||||
- } else {
|
return 0;
|
||||||
- err = pthread_sigmask(how, set, oset);
|
}
|
||||||
- if (err) {
|
+#endif
|
||||||
- if (err == EINVAL && sigprocmask(how, set, oset) == 0) {
|
|
||||||
- workaround = 1;
|
|
||||||
- return 0;
|
|
||||||
- } else {
|
|
||||||
- return -1;
|
|
||||||
- }
|
|
||||||
- }
|
|
||||||
- }
|
|
||||||
-
|
|
||||||
- return 0;
|
|
||||||
-}
|
|
||||||
|
Loading…
x
Reference in New Issue
Block a user