luv: update from 1.36.0-0 to 1.41.0-0

This commit is contained in:
Butta 2021-06-23 03:54:12 +05:30
parent dd30bd774e
commit 70a35fd241
2 changed files with 9 additions and 9 deletions

View File

@ -2,13 +2,13 @@ diff -uNr luv-1.36.0-0/CMakeLists.txt luv-1.36.0-0.mod/CMakeLists.txt
--- luv-1.36.0-0/CMakeLists.txt 2020-04-19 08:44:19.000000000 +0000
+++ luv-1.36.0-0.mod/CMakeLists.txt 2021-02-05 22:07:47.397165825 +0000
@@ -108,7 +108,6 @@
include_directories(${LUAJIT_INCLUDE_DIR})
find_package(LuaJIT REQUIRED)
link_directories(${LUAJIT_LIBRARIES})
else (USE_LUAJIT)
- find_package(Lua REQUIRED)
include_directories(${LUA_INCLUDE_DIR})
endif (USE_LUAJIT)
else()
- find_package(LuaJIT)
endif()
if(NOT LUAJIT_INCLUDE_DIR)
message( FATAL_ERROR "Failed to find LuaJIT headers. Variable `LUAJIT_INCLUDE_DIR' expected to be defined.")
@@ -187,7 +186,7 @@
elseif("${CMAKE_SYSTEM_NAME}" MATCHES "Linux")
target_link_libraries(${TARGET_NAME} ${LIBUV_LIBRARIES} rt)

View File

@ -2,9 +2,9 @@ TERMUX_PKG_HOMEPAGE=https://github.com/luvit/luv
TERMUX_PKG_DESCRIPTION="Bare libuv bindings for lua"
TERMUX_PKG_LICENSE="Apache-2.0"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION="1.36.0-0"
TERMUX_PKG_VERSION="1.41.0-0"
TERMUX_PKG_SRCURL=https://github.com/luvit/luv/releases/download/$TERMUX_PKG_VERSION/luv-$TERMUX_PKG_VERSION.tar.gz
TERMUX_PKG_SHA256=f2e7eb372574f25c6978c1dc74280d22efdcd7df2dda4a286c7fe7dceda26445
TERMUX_PKG_SHA256=4018f293d71c2d75757b64fcdacf982729c9dc8b0bf8eda4015a8818a5a29321
TERMUX_PKG_DEPENDS="liblua53, libuv"
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
-DBUILD_MODULE=OFF