fd: Update from 7.3.0 to 7.4.0
This commit is contained in:
parent
2a14f56430
commit
72860206c4
13
packages/fd/Cargo.toml.patch
Normal file
13
packages/fd/Cargo.toml.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff -u -r ../fd-7.4.0/Cargo.toml ./Cargo.toml
|
||||
--- ../fd-7.4.0/Cargo.toml 2019-09-15 17:29:15.000000000 +0000
|
||||
+++ ./Cargo.toml 2019-09-17 19:37:35.384516258 +0000
|
||||
@@ -52,9 +52,6 @@
|
||||
[target.'cfg(all(unix, not(target_os = "redox")))'.dependencies]
|
||||
libc = "0.2"
|
||||
|
||||
-[target.'cfg(all(not(windows), not(target_env = "musl")))'.dependencies]
|
||||
-jemallocator = "0.3.0"
|
||||
-
|
||||
[dev-dependencies]
|
||||
diff = "0.1"
|
||||
tempdir = "0.3"
|
@ -1,9 +1,8 @@
|
||||
TERMUX_PKG_HOMEPAGE=https://github.com/sharkdp/fd
|
||||
TERMUX_PKG_DESCRIPTION="Simple, fast and user-friendly alternative to find"
|
||||
TERMUX_PKG_LICENSE="Apache-2.0"
|
||||
TERMUX_PKG_VERSION=7.3.0
|
||||
TERMUX_PKG_REVISION=1
|
||||
TERMUX_PKG_SHA256=fbd48cc83c90a0ab09fc3bbe865708a3a528876a99f8304a17d07af7fb378170
|
||||
TERMUX_PKG_VERSION=7.4.0
|
||||
TERMUX_PKG_SHA256=33570ba65e7f8b438746cb92bb9bc4a6030b482a0d50db37c830c4e315877537
|
||||
TERMUX_PKG_SRCURL=https://github.com/sharkdp/fd/archive/v$TERMUX_PKG_VERSION.tar.gz
|
||||
TERMUX_PKG_BUILD_IN_SRC=true
|
||||
|
||||
|
15
packages/fd/src-main.rs.patch
Normal file
15
packages/fd/src-main.rs.patch
Normal file
@ -0,0 +1,15 @@
|
||||
diff -u -r ../fd-7.4.0/src/main.rs ./src/main.rs
|
||||
--- ../fd-7.4.0/src/main.rs 2019-09-15 17:29:15.000000000 +0000
|
||||
+++ ./src/main.rs 2019-09-17 19:37:47.620364849 +0000
|
||||
@@ -35,11 +35,6 @@
|
||||
pattern_has_uppercase_char, transform_args_with_exec, FileTypes,
|
||||
};
|
||||
|
||||
-// We use jemalloc for performance reasons, see https://github.com/sharkdp/fd/pull/481
|
||||
-#[cfg(all(not(windows), not(target_env = "musl")))]
|
||||
-#[global_allocator]
|
||||
-static ALLOC: jemallocator::Jemalloc = jemallocator::Jemalloc;
|
||||
-
|
||||
fn main() {
|
||||
let checked_args = transform_args_with_exec(env::args_os());
|
||||
let matches = app::build_app().get_matches_from(checked_args);
|
Loading…
Reference in New Issue
Block a user