hfsutils: New package.

This is a set of tools for manipulating of HFS images in userspace.
This commit is contained in:
Vladimir Serbinenko 2017-08-03 05:01:12 +02:00 committed by Fredrik Fornwall
parent 0ed9e937a1
commit 73e4437907
3 changed files with 52 additions and 0 deletions

View File

@ -0,0 +1,12 @@
TERMUX_PKG_HOMEPAGE=https://www.mars.org/home/rob/proj/hfs/
TERMUX_PKG_DESCRIPTION="Tool for manipulating HFS images."
TERMUX_PKG_VERSION=3.2.6
TERMUX_PKG_SRCURL=ftp://ftp.mars.org/pub/hfs/hfsutils-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=bc9d22d6d252b920ec9cdf18e00b7655a6189b3f34f42e58d5bb152957289840
TERMUX_PKG_DEPENDS="libandroid-support"
TERMUX_PKG_BUILD_IN_SRC=yes
termux_step_post_configure() {
mkdir -p ${TERMUX_PREFIX}/man/man1
}

View File

@ -0,0 +1,14 @@
Support >4GiB images. Based on Debian patch
--- hfsutils-3.2.6.orig/libhfs/os/unix.c
+++ hfsutils-3.2.6/libhfs/os/unix.c
@@ -19,6 +19,9 @@
* $Id: unix.c,v 1.8 1998/11/02 22:09:13 rob Exp $
*/
+#define _FILE_OFFSET_BITS 64
+#define _LARGE_FILES
+
# ifdef HAVE_CONFIG_H
# include "config.h"
# endif

View File

@ -0,0 +1,26 @@
diff -ur hfsutils-3.2.6-orig/Makefile.in hfsutils-3.2.6/Makefile.in
--- hfsutils-3.2.6-orig/Makefile.in 2017-08-03 04:55:38.195906965 +0200
+++ hfsutils-3.2.6/Makefile.in 2017-08-03 04:57:31.204993434 +0200
@@ -114,11 +114,9 @@
$(BININSTALL) $(HFSUTIL) "$(BINDEST)/."
for file in $(CLITARGETS); do \
- $(HARDLINK) "$(BINDEST)/$(HFSUTIL)" "$(BINDEST)/$$file"; \
+ ln -sf "$(HFSUTIL)" "$(BINDEST)/$$file"; \
done
- rm -f "$(BINDEST)/$(HFSUTIL)"
-
for file in $(GENERALDOCS) $(CLIDOCS); do \
$(LIBINSTALL) doc/man/$$file \
"$(MANDEST)/man$(MANEXT)/`basename $$file .1`.$(MANEXT)"; \
@@ -232,7 +230,7 @@
-lhfs $(LIBS) $(LIBOBJS) -o $@
$(CLITARGETS): $(HFSUTIL)
- -$(HARDLINK) $(HFSUTIL) $@
+ -ln -sf $(HFSUTIL) $@
hfssh: $(LIBHFS) hfssh.o tclhfs.o $(UTILOBJS) $(LIBOBJS)
$(CC) $(LDFLAGS) hfssh.o tclhfs.o $(UTILOBJS) \
Only in hfsutils-3.2.6: Makefile.in~