fzf: Update from 0.16.4 to 0.16.5
This commit is contained in:
parent
054b43f4ec
commit
77a282662d
@ -1,19 +1,36 @@
|
|||||||
TERMUX_PKG_HOMEPAGE=https://github.com/junegunn/fzf
|
TERMUX_PKG_HOMEPAGE=https://github.com/junegunn/fzf
|
||||||
TERMUX_PKG_DESCRIPTION="Command-line fuzzy finder"
|
TERMUX_PKG_DESCRIPTION="Command-line fuzzy finder"
|
||||||
TERMUX_PKG_VERSION=0.16.4
|
TERMUX_PKG_VERSION=0.16.5
|
||||||
TERMUX_PKG_SRCURL=https://github.com/junegunn/fzf/archive/${TERMUX_PKG_VERSION}.tar.gz
|
TERMUX_PKG_SRCURL=https://github.com/junegunn/fzf/archive/${TERMUX_PKG_VERSION}.tar.gz
|
||||||
TERMUX_PKG_SHA256=294034747b0739d716d88670e830a97080fb73b8d6172b2ae695074316903e8a
|
TERMUX_PKG_SHA256=7add1b5290af779fc1c6a3e306d696fb0e833d4efb5b60d94f9c424ac1b6f9fe
|
||||||
TERMUX_PKG_FOLDERNAME=fzf-$TERMUX_PKG_VERSION
|
TERMUX_PKG_FOLDERNAME=fzf-$TERMUX_PKG_VERSION
|
||||||
TERMUX_PKG_BUILD_IN_SRC="yes"
|
TERMUX_PKG_BUILD_IN_SRC="yes"
|
||||||
TERMUX_PKG_DEPENDS="bash"
|
# Depend on findutils as fzf uses the -fstype option, which busybox
|
||||||
|
# find does not support, when invoking find:
|
||||||
|
TERMUX_PKG_DEPENDS="bash, findutils"
|
||||||
|
|
||||||
termux_step_make_install () {
|
termux_step_make_install () {
|
||||||
termux_setup_golang
|
termux_setup_golang
|
||||||
export CGO_CFLAGS="-I$TERMUX_PREFIX/include"
|
export CGO_CFLAGS="-I$TERMUX_PREFIX/include"
|
||||||
export CGO_LDFLAGS="-L$TERMUX_PREFIX/lib"
|
export CGO_LDFLAGS="-L$TERMUX_PREFIX/lib"
|
||||||
|
|
||||||
|
# See the fzf Makefile:
|
||||||
|
local _BINARY="fzf/fzf-${GOOS}_"
|
||||||
|
if [ $TERMUX_ARCH = "arm" ]; then
|
||||||
|
_BINARY+="arm7"
|
||||||
|
elif [ $TERMUX_ARCH = "i686" ]; then
|
||||||
|
_BINARY+="386"
|
||||||
|
elif [ $TERMUX_ARCH = "x86_64" ]; then
|
||||||
|
_BINARY+="amd64"
|
||||||
|
elif [ $TERMUX_ARCH = "aarch64" ]; then
|
||||||
|
_BINARY+="arm8"
|
||||||
|
else
|
||||||
|
termux_error_exit "Unsupported arch: $TERMUX_ARCH"
|
||||||
|
fi
|
||||||
|
|
||||||
cd $TERMUX_PKG_SRCDIR/src
|
cd $TERMUX_PKG_SRCDIR/src
|
||||||
make android-build
|
LDFLAGS="-pie" make $_BINARY
|
||||||
|
cp $_BINARY $TERMUX_PREFIX/bin/fzf
|
||||||
|
|
||||||
# Install fzf-tmux, a bash script for launching fzf in a tmux pane:
|
# Install fzf-tmux, a bash script for launching fzf in a tmux pane:
|
||||||
cp $TERMUX_PKG_SRCDIR/bin/fzf-tmux $TERMUX_PREFIX/bin
|
cp $TERMUX_PKG_SRCDIR/bin/fzf-tmux $TERMUX_PREFIX/bin
|
||||||
|
@ -1,16 +0,0 @@
|
|||||||
diff -u -r ../fzf-0.16.1/src/Makefile ./src/Makefile
|
|
||||||
--- ../fzf-0.16.1/src/Makefile 2017-01-16 04:27:40.000000000 +0100
|
|
||||||
+++ ./src/Makefile 2017-01-16 10:30:50.941798907 +0100
|
|
||||||
@@ -53,10 +53,8 @@
|
|
||||||
cd $(SRCDIR) && go get -tags "$(TAGS)"
|
|
||||||
|
|
||||||
android-build: $(SRCDIR)
|
|
||||||
- cd $(SRCDIR) && GOARCH=arm GOARM=7 CGO_ENABLED=1 go get
|
|
||||||
- cd $(SRCDIR)/fzf && GOARCH=arm GOARM=7 CGO_ENABLED=1 go build -a -ldflags="-w -extldflags=-pie" -o $(BINARYARM7)
|
|
||||||
- cd $(SRCDIR)/fzf && cp $(BINARYARM7) $(RELEASEARM7) && tar -czf $(RELEASEARM7).tgz $(RELEASEARM7) && \
|
|
||||||
- rm -f $(RELEASEARM7)
|
|
||||||
+ cd $(SRCDIR) && CGO_ENABLED=1 go get
|
|
||||||
+ cd $(SRCDIR)/fzf && CGO_ENABLED=1 go build -a -ldflags="-w -extldflags=-pie" -o $(PREFIX)/bin/fzf
|
|
||||||
|
|
||||||
test: deps
|
|
||||||
SHELL=/bin/sh GOOS=$(GOOS) go test -v -tags "$(TAGS)" ./...
|
|
Loading…
Reference in New Issue
Block a user