fish: fix undefined reference to posix_spawn
This commit is contained in:
parent
0f6d16ea6a
commit
7a1cc468bc
11
packages/fish/CMakeLists.txt.patch
Normal file
11
packages/fish/CMakeLists.txt.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- ../CMakeLists.txt.orig 2020-07-08 08:28:32.537413275 +0000
|
||||
+++ ./CMakeLists.txt 2020-07-08 08:29:04.404046585 +0000
|
||||
@@ -191,7 +191,7 @@
|
||||
TARGET_SOURCES(fishlib PRIVATE ${FISH_HEADERS})
|
||||
TARGET_LINK_LIBRARIES(fishlib
|
||||
${CURSES_LIBRARY} ${CURSES_EXTRA_LIBRARY} Threads::Threads ${CMAKE_DL_LIBS}
|
||||
- ${PCRE2_LIB} ${Intl_LIBRARIES} ${ATOMIC_LIBRARY})
|
||||
+ ${PCRE2_LIB} ${Intl_LIBRARIES} ${ATOMIC_LIBRARY} -landroid-spawn)
|
||||
|
||||
# Define fish.
|
||||
ADD_EXECUTABLE(fish src/fish.cpp)
|
Loading…
Reference in New Issue
Block a user