libxkbcommon: add libxml2 dependency and update patch

This commit is contained in:
Leonid Pliushch 2020-09-12 19:43:57 +00:00 committed by Yaksh Bariya
parent 4c5d05b87b
commit 7ad94967dd
No known key found for this signature in database
GPG Key ID: F7486BA7D3D27581
2 changed files with 58 additions and 58 deletions

View File

@ -5,7 +5,7 @@ TERMUX_PKG_MAINTAINER="Leonid Pliushch <leonid.pliushch@gmail.com>"
TERMUX_PKG_VERSION=1.0.1
TERMUX_PKG_SRCURL=https://github.com/xkbcommon/libxkbcommon/archive/xkbcommon-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=270e2ad4ce5699f633e49042114cb68a5697fa1ed45b65c1d96a833cfac20954
TERMUX_PKG_DEPENDS="libxcb, xkeyboard-config"
TERMUX_PKG_DEPENDS="libxcb, libxml2, xkeyboard-config"
TERMUX_PKG_BUILD_DEPENDS="xorg-util-macros"
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="

View File

@ -1,9 +1,9 @@
diff -uNr libxkbcommon-xkbcommon-0.10.0/meson.build libxkbcommon-xkbcommon-0.10.0.mod/meson.build
--- libxkbcommon-xkbcommon-0.10.0/meson.build 2020-01-18 23:08:45.000000000 +0200
+++ libxkbcommon-xkbcommon-0.10.0.mod/meson.build 2020-01-30 22:51:08.757256489 +0200
@@ -294,182 +294,6 @@
endif
diff -uNr libxkbcommon-xkbcommon-1.0.1/meson.build libxkbcommon-xkbcommon-1.0.1.mod/meson.build
--- libxkbcommon-xkbcommon-1.0.1/meson.build 2020-09-11 12:07:49.000000000 +0000
+++ libxkbcommon-xkbcommon-1.0.1.mod/meson.build 2020-09-12 19:40:19.523612699 +0000
@@ -493,224 +493,6 @@
output: 'xkeyboard-config-test',
configuration: xkct_config)
-# Tests
-test_env = environment()
@ -11,9 +11,13 @@ diff -uNr libxkbcommon-xkbcommon-0.10.0/meson.build libxkbcommon-xkbcommon-0.10.
-test_env.set('XKB_LOG_VERBOSITY', '10')
-test_env.set('top_srcdir', meson.source_root())
-test_env.set('top_builddir', meson.build_root())
-test_env.set('HAVE_XKBCLI_INTERACTIVE_EVDEV', configh_data.get('HAVE_XKBCLI_INTERACTIVE_EVDEV', 0).to_string())
-test_env.set('HAVE_XKBCLI_INTERACTIVE_WAYLAND', configh_data.get('HAVE_XKBCLI_INTERACTIVE_WAYLAND', 0).to_string())
-test_env.set('HAVE_XKBCLI_INTERACTIVE_X11', configh_data.get('HAVE_XKBCLI_INTERACTIVE_X11', 0).to_string())
-test_env.set('HAVE_XKBCLI_LIST', configh_data.get('HAVE_XKBCLI_LIST', 0).to_string())
-
-test_configh_data = configuration_data()
-test_configh_data.set_quoted('TEST_XKB_CONFIG_ROOT', join_paths(meson.source_root(), 'test', 'data'))
-test_configh_data.set_quoted('TEST_XKB_CONFIG_ROOT', meson.source_root()/'test'/'data')
-configure_file(output: 'test-config.h', configuration: test_configh_data)
-
-# Some tests need to use unexported symbols, so we link them against
@ -31,6 +35,16 @@ diff -uNr libxkbcommon-xkbcommon-0.10.0/meson.build libxkbcommon-xkbcommon-0.10.
- link_with: libxkbcommon_test_internal,
-)
-if get_option('enable-x11')
- libxkbcommon_x11_internal = static_library(
- 'xkbcommon-x11-internal',
- libxkbcommon_x11_sources,
- include_directories: include_directories('src'),
- link_with: libxkbcommon_test_internal,
- dependencies: [
- xcb_dep,
- xcb_xkb_dep,
- ],
- )
- x11_test_dep = declare_dependency(
- link_with: libxkbcommon_x11_internal,
- dependencies: [
@ -119,10 +133,16 @@ diff -uNr libxkbcommon-xkbcommon-0.10.0/meson.build libxkbcommon-xkbcommon-0.10.
- env: test_env,
-)
-test(
- 'symbols-leak-test',
- find_program('test/symbols-leak-test.bash'),
- 'utils',
- executable('test-utils', 'test/utils.c', dependencies: test_dep),
- env: test_env,
-)
-test(
- 'symbols-leak-test',
- find_program('test/symbols-leak-test.py'),
- env: test_env,
- suite: ['python-tests'],
-)
-if get_option('enable-x11')
- test(
- 'x11',
@ -133,6 +153,34 @@ diff -uNr libxkbcommon-xkbcommon-0.10.0/meson.build libxkbcommon-xkbcommon-0.10.
- # See: https://github.com/xkbcommon/libxkbcommon/issues/30
- executable('test-x11comp', 'test/x11comp.c', dependencies: x11_test_dep)
-endif
-if get_option('enable-xkbregistry')
- test(
- 'registry',
- executable('test-registry', 'test/registry.c',
- include_directories: include_directories('src'),
- dependencies: dep_libxkbregistry),
- env: test_env,
- )
-endif
-if build_tools
- test('tool-option-parsing',
- find_program('test/tool-option-parsing.py'),
- env: test_env,
- suite: ['python-tests'])
-endif
-
-valgrind = find_program('valgrind', required: false)
-if valgrind.found()
- add_test_setup('valgrind',
- exe_wrapper: [valgrind,
- '--leak-check=full',
- '--track-origins=yes',
- '--gen-suppressions=all',
- '--error-exitcode=99'],
- timeout_multiplier : 10)
-else
- message('valgrind not found, disabling valgrind test setup')
-endif
-
-
-# Fuzzing target programs.
@ -140,54 +188,6 @@ diff -uNr libxkbcommon-xkbcommon-0.10.0/meson.build libxkbcommon-xkbcommon-0.10.
-executable('fuzz-compose', 'fuzz/compose/target.c', dependencies: test_dep)
-
-
-# Demo programs.
-if cc.has_header_symbol('getopt.h', 'getopt_long', prefix: '#define _GNU_SOURCE')
- executable('rmlvo-to-kccgst', 'test/rmlvo-to-kccgst.c', dependencies: test_dep)
- executable('rmlvo-to-keymap', 'test/rmlvo-to-keymap.c', dependencies: test_dep)
- executable('print-compiled-keymap', 'test/print-compiled-keymap.c', dependencies: test_dep)
-endif
-if cc.has_header('linux/input.h')
- executable('interactive-evdev', 'test/interactive-evdev.c', dependencies: test_dep)
-endif
-if get_option('enable-x11')
- executable('interactive-x11', 'test/interactive-x11.c', dependencies: x11_test_dep)
-endif
-if get_option('enable-wayland')
- wayland_client_dep = dependency('wayland-client', version: '>=1.2.0', required: false)
- wayland_protocols_dep = dependency('wayland-protocols', version: '>=1.12', required: false)
- wayland_scanner_dep = dependency('wayland-scanner', required: false, native: true)
- if not wayland_client_dep.found() or not wayland_protocols_dep.found() or not wayland_scanner_dep.found()
- error('''The Wayland demo programs require wayland-client >= 1.2.0, wayland-protocols >= 1.7 which were not found.
-You can disable the Wayland demo programs with -Denable-wayland=false.''')
- endif
-
- wayland_scanner = find_program(wayland_scanner_dep.get_pkgconfig_variable('wayland_scanner'))
- wayland_scanner_code_gen = generator(
- wayland_scanner,
- output: '@BASENAME@-protocol.c',
- arguments: ['code', '@INPUT@', '@OUTPUT@'],
- )
- wayland_scanner_client_header_gen = generator(
- wayland_scanner,
- output: '@BASENAME@-client-protocol.h',
- arguments: ['client-header', '@INPUT@', '@OUTPUT@'],
- )
- wayland_protocols_datadir = wayland_protocols_dep.get_pkgconfig_variable('pkgdatadir')
- xdg_shell_xml = join_paths(wayland_protocols_datadir, 'stable/xdg-shell/xdg-shell.xml')
- xdg_shell_sources = [
- wayland_scanner_code_gen.process(xdg_shell_xml),
- wayland_scanner_client_header_gen.process(xdg_shell_xml),
- ]
- executable('interactive-wayland', 'test/interactive-wayland.c', xdg_shell_sources, dependencies: [test_dep, wayland_client_dep])
-endif
-
# xkeyboard-config "verifier"
xkct_config = configuration_data()
xkct_config.set('MESON_BUILD_ROOT', meson.build_root())
@@ -480,41 +304,6 @@
install: false)
-# Benchmarks.
-libxkbcommon_bench_internal = static_library(
- 'xkbcommon-bench-internal',