radare2: Patches to build on all arches

This commit is contained in:
Fredrik Fornwall 2016-09-16 18:19:27 -04:00
parent af14ff2341
commit 7d23a2ae26
3 changed files with 38 additions and 0 deletions

View File

@ -0,0 +1,12 @@
diff -u -r ../radare2-0.10.5/libr/debug/p/debug_native.c ./libr/debug/p/debug_native.c
--- ../radare2-0.10.5/libr/debug/p/debug_native.c 2016-08-16 19:28:34.000000000 -0400
+++ ./libr/debug/p/debug_native.c 2016-09-16 17:37:57.879695115 -0400
@@ -75,7 +75,7 @@
# define WIFCONTINUED(s) ((s) == 0xffff)
# endif
# endif
-#if __x86_64__
+#if __x86_64__ && !defined(__ANDROID__)
#include "native/linux/linux_coredump.h"
#endif
#else // OS

View File

@ -0,0 +1,12 @@
diff -u -r ../radare2-0.10.5/libr/debug/p/native/linux/linux_debug.c ./libr/debug/p/native/linux/linux_debug.c
--- ../radare2-0.10.5/libr/debug/p/native/linux/linux_debug.c 2016-08-16 19:28:34.000000000 -0400
+++ ./libr/debug/p/native/linux/linux_debug.c 2016-09-16 17:53:45.280118204 -0400
@@ -426,7 +426,7 @@
if (ret1 != 0) return false;
if (sizeof(fpregs) < size) size = sizeof(fpregs);
memcpy (buf, &fpregs, size);
- return sizeof(fpregs)
+ return sizeof(fpregs);
#endif // !__ANDROID__
#elif __i386__
#if !__ANDROID__

View File

@ -0,0 +1,14 @@
diff -u -r ../radare2-0.10.5/mk/termux-host.mk ./mk/termux-host.mk
--- ../radare2-0.10.5/mk/termux-host.mk 2016-08-16 19:28:34.000000000 -0400
+++ ./mk/termux-host.mk 2016-09-16 16:58:13.067871972 -0400
@@ -2,10 +2,7 @@
#CC=gcc -fPIC -fPIE
#RANLIB=ndk-ranlib
USERCC=gcc -fPIC -fPIE
-ARCH=arm
-RANLIB=aarch64-linux-android-ranlib
-AR=aarch64-linux-android-ar
CC_AR=${AR} -r ${LIBAR}
ONELIB=0