move from unstable: progress
This commit is contained in:
parent
9c64c4b063
commit
7d549998c0
10
packages/progress/Makefile.patch
Normal file
10
packages/progress/Makefile.patch
Normal file
@ -0,0 +1,10 @@
|
||||
--- progress/Makefile 2019-09-06 19:43:06.150151728 +0800
|
||||
+++ progress_mod/Makefile 2019-09-07 13:12:22.559267641 +0800
|
||||
@@ -12,6 +12,7 @@
|
||||
$(error "ncurses package not found")
|
||||
endif
|
||||
override LDFLAGS += $(shell $(PKG_CONFIG) ncurses --libs)
|
||||
+ override CFLAGS += $(shell $(PKG_CONFIG) ncurses --cflags)
|
||||
endif
|
||||
ifeq ($(UNAME), Darwin)
|
||||
override LDFLAGS += -lncurses
|
24
packages/progress/WithoutWordexp.patch
Normal file
24
packages/progress/WithoutWordexp.patch
Normal file
@ -0,0 +1,24 @@
|
||||
--- progress/progress.c 2019-09-06 19:43:06.150151728 +0800
|
||||
+++ progress_mod/progress.c 2019-09-08 10:27:05.529574702 +0800
|
||||
@@ -32,7 +32,20 @@
|
||||
#include <assert.h>
|
||||
#include <curses.h>
|
||||
|
||||
-#include <wordexp.h>
|
||||
+/*
|
||||
+*#include <wordexp.h>
|
||||
+*Android without wordexp support
|
||||
+*/
|
||||
+typedef struct {
|
||||
+ size_t we_wordc;
|
||||
+ char **we_wordv;
|
||||
+ size_t we_offs;
|
||||
+} wordexp_t;
|
||||
+static inline int wordexp(const char *c, wordexp_t *w, int _i)
|
||||
+{
|
||||
+ return -1;
|
||||
+}
|
||||
+
|
||||
#include <getopt.h>
|
||||
|
||||
#include <sys/ioctl.h>
|
11
packages/progress/build.sh
Normal file
11
packages/progress/build.sh
Normal file
@ -0,0 +1,11 @@
|
||||
TERMUX_PKG_HOMEPAGE=https://github.com/Xfennec/progress
|
||||
TERMUX_PKG_DESCRIPTION="Linux tool to show progress for cp, mv, dd and more"
|
||||
TERMUX_PKG_LICENSE="GPL-3.0"
|
||||
TERMUX_PKG_MAINTAINER="Leonid Plyushch <leonid.plyushch@gmail.com>"
|
||||
TERMUX_PKG_VERSION=0.14
|
||||
TERMUX_PKG_REVISION=3
|
||||
TERMUX_PKG_SRCURL=https://github.com/Xfennec/progress/archive/v$TERMUX_PKG_VERSION.tar.gz
|
||||
TERMUX_PKG_SHA256=214a0d84b3ee5dde57ec9952ec9aa68ad9261fb336ef025324b344ed7ab48af1
|
||||
TERMUX_PKG_DEPENDS="ncurses"
|
||||
TERMUX_PKG_BUILD_IN_SRC=true
|
||||
|
Loading…
Reference in New Issue
Block a user