starship: add --features http arg and remove patch
Following discussion in https://github.com/termux/termux-packages/pull/6501.
This commit is contained in:
parent
5aef4fbeaf
commit
819b17a347
@ -3,11 +3,12 @@ TERMUX_PKG_DESCRIPTION="A minimal, blazing fast, and extremely customizable prom
|
||||
TERMUX_PKG_LICENSE="ISC"
|
||||
TERMUX_PKG_MAINTAINER="@termux"
|
||||
TERMUX_PKG_VERSION=0.53.0
|
||||
TERMUX_PKG_REVISION=1
|
||||
TERMUX_PKG_SRCURL=https://github.com/starship/starship/archive/v$TERMUX_PKG_VERSION.tar.gz
|
||||
TERMUX_PKG_SHA256=42353977aba8cf711591381d713814140d9bb602015e8d6c589ef1a42d116ae1
|
||||
TERMUX_PKG_DEPENDS="zlib"
|
||||
TERMUX_PKG_DEPENDS="zlib, openssl"
|
||||
TERMUX_PKG_BUILD_IN_SRC=true
|
||||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--no-default-features"
|
||||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--no-default-features --features http"
|
||||
TERMUX_PKG_BLACKLISTED_ARCHES="x86_64"
|
||||
|
||||
termux_step_pre_configure() {
|
||||
@ -16,4 +17,3 @@ termux_step_pre_configure() {
|
||||
CFLAGS+=" -fno-integrated-as"
|
||||
fi
|
||||
}
|
||||
|
||||
|
@ -1,13 +0,0 @@
|
||||
diff -u -r ../starship-0.48.0/Cargo.toml ./Cargo.toml
|
||||
--- ../starship-0.48.0/Cargo.toml 2021-01-06 15:03:16.000000000 +0800
|
||||
+++ ./Cargo.toml 2021-01-06 15:04:13.000000000 +0800
|
||||
@@ -70,6 +70,9 @@
|
||||
native-tls = { version = "0.2.7", optional = true }
|
||||
shell-words = "1.0.0"
|
||||
|
||||
+[patch.crates-io]
|
||||
+sys-info = { git = 'https://github.com/FillZpp/sys-info-rs' }
|
||||
+
|
||||
[target.'cfg(windows)'.dependencies]
|
||||
winapi = { version = "0.3.9", features = [
|
||||
"winuser",
|
Loading…
Reference in New Issue
Block a user