newsboat: Update from 2.13 to 2.14
This commit is contained in:
parent
83b5a05506
commit
81a4936bd9
@ -1,6 +1,6 @@
|
||||
diff -u -r ../newsboat-2.11/Makefile ./Makefile
|
||||
--- ../newsboat-2.11/Makefile 2018-03-25 21:36:30.000000000 +0200
|
||||
+++ ./Makefile 2018-03-30 22:52:36.721339528 +0200
|
||||
diff -u -r ../newsboat-2.14/Makefile ./Makefile
|
||||
--- ../newsboat-2.14/Makefile 2018-12-29 13:07:06.000000000 +0000
|
||||
+++ ./Makefile 2018-12-31 02:05:43.501854145 +0000
|
||||
@@ -9,6 +9,7 @@
|
||||
|
||||
# compiler
|
||||
@ -36,7 +36,13 @@ diff -u -r ../newsboat-2.11/Makefile ./Makefile
|
||||
|
||||
RSSPPLIB_SOURCES=$(sort $(wildcard rss/*.cpp))
|
||||
RSSPPLIB_OBJS=$(patsubst rss/%.cpp,rss/%.o,$(RSSPPLIB_SOURCES))
|
||||
@@ -57,7 +58,7 @@
|
||||
@@ -62,12 +63,12 @@
|
||||
LDFLAGS+=-L.//target/release
|
||||
CARGO_FLAGS+=--release
|
||||
endif
|
||||
-LDFLAGS+=-lnewsboat -lpthread -ldl
|
||||
+LDFLAGS+=-lnewsboat
|
||||
|
||||
PODBOAT=podboat
|
||||
PODBOAT_SOURCES:=$(shell cat mk/podboat.deps)
|
||||
PODBOAT_OBJS:=$(patsubst %.cpp,%.o,$(PODBOAT_SOURCES))
|
||||
@ -45,7 +51,7 @@ diff -u -r ../newsboat-2.11/Makefile ./Makefile
|
||||
|
||||
ifeq (, $(filter Linux GNU GNU/%, $(shell uname -s)))
|
||||
NEWSBOAT_LIBS+=-liconv -lintl
|
||||
@@ -168,13 +169,13 @@
|
||||
@@ -186,13 +187,13 @@
|
||||
echo "td > pre { margin: 0; white-space: pre-wrap; }" >> doc/xhtml/docbook-xsl.css
|
||||
|
||||
doc/generate: doc/generate.cpp doc/split.h
|
||||
@ -61,7 +67,7 @@ diff -u -r ../newsboat-2.11/Makefile ./Makefile
|
||||
|
||||
doc/newsboat-keycmds.txt: doc/generate2 doc/keycmds.dsv
|
||||
doc/generate2 doc/keycmds.dsv > doc/newsboat-keycmds.txt
|
||||
@@ -192,7 +193,7 @@
|
||||
@@ -210,7 +211,7 @@
|
||||
$(A2X) -f manpage doc/manpage-podboat.txt
|
||||
|
||||
doc/gen-example-config: doc/gen-example-config.cpp doc/split.h
|
||||
@ -69,4 +75,4 @@ diff -u -r ../newsboat-2.11/Makefile ./Makefile
|
||||
+ $(CXX_host) -o doc/gen-example-config doc/gen-example-config.cpp
|
||||
|
||||
doc/example-config: doc/gen-example-config doc/configcommands.dsv
|
||||
cat doc/configcommands.dsv | doc/gen-example-config > doc/example-config
|
||||
sed 's/+{backslash}"+/`\\"`/g' doc/configcommands.dsv | doc/gen-example-config > doc/example-config
|
||||
|
@ -1,11 +1,23 @@
|
||||
TERMUX_PKG_HOMEPAGE=https://newsboat.org/
|
||||
TERMUX_PKG_DESCRIPTION="RSS/Atom feed reader for the text console"
|
||||
TERMUX_PKG_API_LEVEL=24
|
||||
TERMUX_PKG_VERSION=2.13
|
||||
TERMUX_PKG_SHA256=c73613b4f08c875bae2c4e7828e67291e7599e9cabed528089f8378f520b335e
|
||||
TERMUX_PKG_VERSION=2.14
|
||||
TERMUX_PKG_SHA256=67bcbaac3ebed5cea07aee502803364a01e7b45a022c886932cc18d5b9e56d8d
|
||||
TERMUX_PKG_SRCURL=https://newsboat.org/releases/${TERMUX_PKG_VERSION}/newsboat-${TERMUX_PKG_VERSION}.tar.xz
|
||||
TERMUX_PKG_DEPENDS="libandroid-support, libandroid-glob, json-c, libsqlite, libcurl, libxml2, stfl, ncurses, openssl"
|
||||
TERMUX_PKG_BUILD_IN_SRC=yes
|
||||
TERMUX_PKG_RM_AFTER_INSTALL="share/locale"
|
||||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="ac_cv_lib_bsd_main=no"
|
||||
TERMUX_PKG_CONFLICTS=newsbeuter
|
||||
TERMUX_PKG_REPLACES=newsbeuter
|
||||
|
||||
termux_step_pre_configure() {
|
||||
termux_setup_rust
|
||||
|
||||
# The newsboat Makefile assumes that the built library is in target/release,
|
||||
# which is not the case when cross compiling:
|
||||
LDFLAGS+=" -L.//target/$CARGO_TARGET_NAME/release"
|
||||
|
||||
# Used by newsboat Makefile:
|
||||
export CARGO_FLAGS="--target $CARGO_TARGET_NAME"
|
||||
}
|
||||
|
Loading…
Reference in New Issue
Block a user