New pacakge: libimobiledevice, libplist, libusbmuxd and usbmuxd (#5745)

* New package: libplist

* New package: usbmuxd

* New package: libimobiledevice

* add patch file

* add some patch file

* del some unusage lines

* fix license error

* fix license error
This commit is contained in:
ifurther 2020-08-28 23:43:07 +08:00 committed by GitHub
parent ab3fa81b6f
commit 85bafbf680
6 changed files with 94 additions and 0 deletions

View File

@ -0,0 +1,14 @@
TERMUX_PKG_HOMEPAGE=https://libimobiledevice.org/
TERMUX_PKG_DESCRIPTION="A library to communicate with services on iOS devices using native protocols."
TERMUX_PKG_LICENSE="LGPL-2.1"
TERMUX_PKG_LICENSE_FILE="COPYING"
TERMUX_PKG_VERSION=1.3.0
TERMUX_PKG_SRCURL=https://github.com/libimobiledevice/libimobiledevice/archive/$TERMUX_PKG_VERSION.tar.gz
TERMUX_PKG_SHA256=acbfb73eabee162e64c0d9de207d71c0a5f47c40cd5ad32a5097f734328ce10a
TERMUX_PKG_DEPENDS="usbmuxd, libusbmuxd, openssl"
TERMUX_PKG_BUILD_IN_SRC=true
termux_step_configure() {
./autogen.sh --prefix=$TERMUX_PREFIX \
--host=$TERMUX_HOST_PLATFORM
}

View File

@ -0,0 +1,12 @@
--- a/configure.ac
+++ b/configure.ac
@@ -76,7 +76,7 @@
*)
AC_MSG_RESULT([${host_os}])
AX_PTHREAD([], [AC_MSG_ERROR([pthread is required to build $PACKAGE_NAME])])
- AC_CHECK_LIB(pthread, [pthread_once], [], [AC_MSG_ERROR([pthread with pthread_once required to build $PACKAGE_NAME])])
+ AC_CHECK_LIB(pthread, [pthread_once], [], [AC_MSG_NOTICE([pthread with pthread_once required to build $PACKAGE_NAME])])
;;
esac
AM_CONDITIONAL(WIN32, test x$win32 = xtrue)

View File

@ -0,0 +1,16 @@
TERMUX_PKG_HOMEPAGE=https://libimobiledevice.org
TERMUX_PKG_DESCRIPTION="A small portable C library to handle Apple Property List files in binary or XML format."
TERMUX_PKG_LICENSE="LGPL-2.1"
TERMUX_PKG_LICENSE_FILE="COPYING"
TERMUX_PKG_VERSION=2.2.0
TERMUX_PKG_SRCURL=https://github.com/libimobiledevice/libplist/archive/$TERMUX_PKG_VERSION.tar.gz
TERMUX_PKG_SHA256=7e654bdd5d8b96f03240227ed09057377f06ebad08e1c37d0cfa2abe6ba0cee2
TERMUX_PKG_BUILD_IN_SRC=true
termux_step_configure() {
PKG_CONFIG_PATH=$TERMUX_PREFIX/lib/pkgconfig
./autogen.sh --prefix=$TERMUX_PREFIX \
--without-cython \
--host=$TERMUX_HOST_PLATFORM
}

View File

@ -0,0 +1,16 @@
TERMUX_PKG_HOMEPAGE=https://libimobiledevice.org
TERMUX_PKG_DESCRIPTION="A client library for applications to handle usbmux protocol connections with iOS devices."
TERMUX_PKG_LICENSE="LGPL-2.1"
TERMUX_PKG_LICENSE_FILE="COPYING"
TERMUX_PKG_VERSION=2.0.2
TERMUX_PKG_SRCURL=https://github.com/libimobiledevice/libusbmuxd/archive/$TERMUX_PKG_VERSION.tar.gz
TERMUX_PKG_SHA256=8ae3e1d9340177f8f3a785be276435869363de79f491d05d8a84a59efc8a8fdc
TERMUX_PKG_DEPENDS="libusb, libplist, usbmuxd"
TERMUX_PKG_BUILD_IN_SRC=true
termux_step_configure() {
./autogen.sh --prefix=$TERMUX_PREFIX \
--without-preflight \
--without-systemd \
--host=$TERMUX_HOST_PLATFORM
}

16
packages/usbmuxd/build.sh Normal file
View File

@ -0,0 +1,16 @@
TERMUX_PKG_HOMEPAGE=https://libimobiledevice.org
TERMUX_PKG_DESCRIPTION="A socket daemon to multiplex connections from and to iOS devices."
TERMUX_PKG_LICENSE="custom"
TERMUX_PKG_LICENSE_FILE="COPYING.GPLv2, COPYING.GPLv3"
TERMUX_PKG_VERSION=1.1.1
TERMUX_PKG_SRCURL=https://github.com/libimobiledevice/usbmuxd/archive/$TERMUX_PKG_VERSION.tar.gz
TERMUX_PKG_SHA256=e7ce30143e69d77fc5aa6fb0cb5f0cfcdbeff47eb1ac7fd90ac259a90de9fadd
TERMUX_PKG_DEPENDS="libusb, libplist"
TERMUX_PKG_BUILD_IN_SRC=true
termux_step_configure() {
./autogen.sh --prefix=$TERMUX_PREFIX \
--without-preflight \
--without-systemd \
--host=$TERMUX_HOST_PLATFORM
}

View File

@ -0,0 +1,20 @@
--- a/configure.ac
+++ b/configure.ac
@@ -19,7 +19,7 @@
PKG_CHECK_MODULES(libusb, libusb-1.0 >= 1.0.9)
PKG_CHECK_MODULES(libplist, libplist-2.0 >= 2.2.0)
PKG_CHECK_MODULES(libimobiledevice, libimobiledevice-1.0 >= 1.3.0, have_limd=yes, have_limd=no)
-AC_CHECK_LIB(pthread, [pthread_create, pthread_mutex_lock], [AC_SUBST(libpthread_LIBS,[-lpthread])], [AC_MSG_ERROR([libpthread is required to build usbmuxd])])
+AC_CHECK_LIB(pthread, [pthread_create, pthread_mutex_lock], [AC_SUBST(libpthread_LIBS,[-lpthread])], [AC_MSG_NOTICE([libpthread is required to build usbmuxd])])
AC_ARG_WITH([preflight],
[AS_HELP_STRING([--without-preflight],
@@ -108,8 +108,6 @@
AC_SEARCH_LIBS([clock_gettime],[rt posix4])
# Checks for library functions.
-AC_FUNC_MALLOC
-AC_FUNC_REALLOC
AC_CHECK_FUNCS([strcasecmp strdup strerror strndup stpcpy])
AC_CHECK_FUNCS([ppoll clock_gettime localtime_r])