new package: sshping (#7278)

This commit is contained in:
Pooya Moradi 2021-08-07 03:03:33 +04:30 committed by GitHub
parent 3bf997224e
commit 883994226a
No known key found for this signature in database
GPG Key ID: 4AEE18F83AFDEB23
2 changed files with 33 additions and 0 deletions

View File

@ -0,0 +1,14 @@
diff -uNr sshping-0.1.4/Makefile sshping-0.1.4.mod/Makefile
--- sshping-0.1.4/Makefile 2018-03-19 23:48:55.000000000 +0200
+++ sshping-0.1.4.mod/Makefile 2021-08-07 01:15:24.209724177 +0300
@@ -4,8 +4,8 @@
sshping: bin/sshping
-bin/sshping: src/sshping.cxx /usr/include/libssh/libssh.h
- g++ -Wall -I ext/ -o bin/sshping src/sshping.cxx -lssh
+bin/sshping: src/sshping.cxx
+ $(CXX) $(CXXFLAGS) $(CPPFLAGS) $(LDFLAGS) -Wall -I ext/ -o bin/sshping src/sshping.cxx -lssh
/usr/include/libssh/libssh.h:
echo '*** Please install libssh-dev, libssh-devel, or similar package'

19
packages/sshping/build.sh Normal file
View File

@ -0,0 +1,19 @@
TERMUX_PKG_HOMEPAGE=https://github.com/spook/sshping
TERMUX_PKG_DESCRIPTION="measure character-echo latency and bandwidth for an interactive ssh session"
TERMUX_PKG_LICENSE="MIT"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=0.1.4
TERMUX_PKG_SRCURL=https://github.com/spook/sshping/archive/v$TERMUX_PKG_VERSION.tar.gz
TERMUX_PKG_SHA256=589623e3fbe88dc1d423829e821f9d57f09aef0d9a2f04b7740b50909217863a
TERMUX_PKG_DEPENDS="libssh"
TERMUX_PKG_EXTRA_MAKE_ARGS="sshping man"
TERMUX_PKG_BUILD_IN_SRC=true
termux_step_pre_configure() {
rm -f CMakeLists.txt
}
termux_step_make_install() {
install -Dm700 -t $TERMUX_PREFIX/bin ./bin/sshping
install -Dm600 -t $TERMUX_PREFIX/share/man/man8 ./doc/sshping.8
}