Enable the zile package

The zile package no longer crashes after @iainnicol finding out
that the issue was rpl_malloc, so enable it.

See https://github.com/termux/termux-packages/pull/56
This commit is contained in:
Fredrik Fornwall 2015-11-15 16:43:01 -05:00
parent 150f95af27
commit 89df5522c6
4 changed files with 72 additions and 35 deletions

View File

@ -1,16 +0,0 @@
# NOTE: Zile currently segfaults. According to gdb, the crash is somewhere
# in GC_realloc. So it's maybe not zile's fault, but instead libgc's fault.
TERMUX_PKG_HOMEPAGE=https://www.gnu.org/software/zile/
TERMUX_PKG_DESCRIPTION="Lightweight clone of the Emacs text editor"
TERMUX_PKG_VERSION=2.4.11
TERMUX_PKG_SRCURL=https://ftp.gnu.org/gnu/zile/zile-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_DEPENDS="libgc, ncurses"
# Host build for man pages generated by help2man, see patch:
TERMUX_PKG_HOSTBUILD=yes
TERMUX_PKG_BUILD_IN_SRC=yes
termux_step_pre_configure () {
# Required because patch modifies a Makefile.am.
autoreconf
}

View File

@ -1,19 +0,0 @@
Use man pages generated by help2man in the host build.
diff -u -r ../zile-2.4.11/doc/Makefile.am ./doc/Makefile.am
--- ../zile-2.4.11/doc/Makefile.am 2014-02-24 21:42:16.000000000 +0000
+++ ./doc/Makefile.am 2015-11-14 19:40:13.163834200 +0000
@@ -27,11 +27,8 @@
EXTRA_DIST += doc/man-extras doc/zile.1.in
man_MANS = doc/zile.1
-doc/zile.1: $(srcdir)/doc/zile.1.in doc/Makefile.am config.status
- @test -d doc || mkdir doc
- rm -f $@ $@.tmp
- $(edit) $(abs_srcdir)/doc/zile.1.in >$@.tmp
- mv $@.tmp $@
+doc/zile.1:
+ cp $(top_srcdir)/../host-build/$@ $@
$(srcdir)/doc/zile.1.in: doc/man-extras build-aux/zile-help2man-wrapper configure.ac $(builddir)/src/zile$(EXEEXT)
@test -d doc || mkdir doc

13
packages/zile/build.sh Executable file
View File

@ -0,0 +1,13 @@
TERMUX_PKG_HOMEPAGE=https://www.gnu.org/software/zile/
TERMUX_PKG_DESCRIPTION="Lightweight clone of the Emacs text editor"
TERMUX_PKG_VERSION=2.4.11
TERMUX_PKG_SRCURL=https://ftp.gnu.org/gnu/zile/zile-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_DEPENDS="libgc, ncurses"
TERMUX_PKG_BUILD_IN_SRC=yes
termux_step_pre_make () {
# zile uses help2man to build the zile.1 man page, which would require
# a host build. To avoid that just copy a pre-built man page.
cp $TERMUX_PKG_BUILDER_DIR/zile.1 $TERMUX_PKG_BUILDDIR/doc/zile.1
$TERMUX_TOUCH -d "next hour" $TERMUX_PKG_BUILDDIR/doc/zile.1*
}

59
packages/zile/zile.1 Normal file
View File

@ -0,0 +1,59 @@
.\" DO NOT MODIFY THIS FILE! It was generated by help2man 1.45.1.
.TH ZILE "1" "April 2014" "Zile 2.4.11" "User Commands"
.SH NAME
Zile \- Zile Is Lossy Emacs
.SH SYNOPSIS
.B zile
[\fI\,OPTION-OR-FILENAME\/\fR]...
.SH DESCRIPTION
Zile is a lightweight Emacs clone that provides a subset of Emacs's
functionality suitable for basic editing.
.PP
Run Zile, the lightweight Emacs clone.
.PP
Initialization options:
.TP
\fB\-\-no\-init\-file\fR, \fB\-q\fR
do not load ~/.zile
.TP
\fB\-\-funcall\fR, \fB\-f\fR FUNC
call Zile Lisp function FUNC with no arguments
.TP
\fB\-\-load\fR, \fB\-l\fR FILE
load Zile Lisp FILE using the load function
.TP
\fB\-\-help\fR
display this help message and exit
.TP
\fB\-\-version\fR
display version information and exit
.PP
Action options:
.TP
FILE
visit FILE using find\-file
.TP
+LINE FILE
visit FILE using find\-file, then go to line LINE
.PP
Exit status is 0 if OK, 1 if it cannot start up, for example because
of an invalid command-line argument, and 2 if it crashes or runs out
of memory.
.SH FILES
~/.zile \(em user's Zile init file
.PP
$PREFIX/share/zile/dotzile.sample \(em which contains some useful
code for the init file.
.SH AUTHOR
Zile was written by Sandro Sigala, David A. Capello and Reuben Thomas.
The Lisp interpreter is based on code by Scott Lawrence.
.SH "REPORTING BUGS"
Report bugs to bug\-zile@gnu.org.
.SH COPYRIGHT
Copyright \(co 2014 Free Software Foundation, Inc.
GNU Zile comes with ABSOLUTELY NO WARRANTY.
You may redistribute copies of Zile
under the terms of the GNU General Public License.
For more information about these matters, see the file named COPYING.
.SH "SEE ALSO"
.BR emacs (1)