picolisp: Update from 15.11 to 16.2.7

This commit is contained in:
Fredrik Fornwall 2016-02-08 06:26:05 -05:00
parent 14fc08f7a6
commit 89f5e911e6
4 changed files with 19 additions and 25 deletions

View File

@ -1,8 +1,7 @@
TERMUX_PKG_HOMEPAGE=http://picolisp.com
TERMUX_PKG_DESCRIPTION="Lisp interpreter and application server framework"
TERMUX_PKG_VERSION=15.11
TERMUX_PKG_BUILD_REVISION=1
TERMUX_PKG_SRCURL=http://software-lab.de/picoLisp-${TERMUX_PKG_VERSION}.tgz
TERMUX_PKG_VERSION=16.2.7
TERMUX_PKG_SRCURL=http://software-lab.de/picoLisp.tgz
TERMUX_PKG_FOLDERNAME=picoLisp
TERMUX_PKG_BUILD_IN_SRC=true

View File

@ -1,12 +0,0 @@
diff -u -r ../picoLisp/lib/debug.l ./lib/debug.l
--- ../picoLisp/lib/debug.l 2015-04-03 03:09:48.000000000 -0400
+++ ./lib/debug.l 2015-10-01 18:39:47.475128813 -0400
@@ -8,7 +8,7 @@
# Browsing
(de doc (Sym Browser)
- (call (or Browser (sys "BROWSER") 'w3m)
+ (call (or Browser (sys "BROWSER") 'lynx)
(pack
"file:"
(and (= `(char '/) (char (path "@"))) "//")

View File

@ -1,7 +1,7 @@
diff -u -r ../picoLisp/src/Makefile ./src/Makefile
--- ../picoLisp/src/Makefile 2015-03-31 14:48:22.000000000 -0400
+++ ./src/Makefile 2015-09-24 05:23:56.372236679 -0400
@@ -6,111 +6,13 @@
--- ../picoLisp/src/Makefile 2016-02-02 10:52:49.000000000 -0500
+++ ./src/Makefile 2016-02-08 06:15:50.293964319 -0500
@@ -6,118 +6,13 @@
picoFiles = main.c gc.c apply.c flow.c sym.c subr.c big.c io.c net.c tab.c
@ -90,6 +90,12 @@ diff -u -r ../picoLisp/src/Makefile ./src/Makefile
- LCRYPT =
- STRIP = strip
-else
-ifeq ($(shell uname), IRIX64)
- OS = IRIX64
- CFLAGS += -std=gnu99
- DYNAMIC-LIB-FLAGS = -shared
- STRIP = strip -f
-else
-ifeq ($(shell uname -o), Cygwin)
- OS = Cygwin
- CFLAGS += -m32
@ -109,6 +115,7 @@ diff -u -r ../picoLisp/src/Makefile ./src/Makefile
-endif
-endif
-endif
-endif
+CCLD = $(CC)
+LCRYPT =

View File

@ -2,16 +2,16 @@ The crypt(3) function is not available in Android, so remove support
in ext for now.
diff -u -r ../picoLisp/src/ext.c ./src/ext.c
--- ../picoLisp/src/ext.c 2015-04-27 00:34:17.000000000 -0400
+++ ./src/ext.c 2015-11-27 06:07:18.767005597 -0500
@@ -252,6 +252,7 @@
--- ../picoLisp/src/ext.c 2015-11-27 02:25:22.000000000 -0500
+++ ./src/ext.c 2016-02-08 06:19:58.405969024 -0500
@@ -250,6 +250,7 @@
return T;
}
/*** Password hashing ***/
// (Ext:Crypt 'key 'salt) -> str
+#ifndef __ANDROID__
/*** Password hashing ***/
// (ext:Crypt 'key 'salt) -> str
any Crypt(any x) {
any y;
@@ -269,3 +270,4 @@
}
}