nodejs: Update from 11.14.0 to 12.1.0

This commit is contained in:
Fredrik Fornwall 2019-05-06 00:13:05 +02:00
parent a2b420dc93
commit 8a43705001
4 changed files with 35 additions and 39 deletions

View File

@ -1,9 +1,9 @@
TERMUX_PKG_HOMEPAGE=https://nodejs.org/
TERMUX_PKG_DESCRIPTION="Platform built on Chrome's JavaScript runtime for easily building fast, scalable network applications"
TERMUX_PKG_LICENSE="MIT"
TERMUX_PKG_VERSION=11.14.0
TERMUX_PKG_VERSION=12.1.0
TERMUX_PKG_REVISION=1
TERMUX_PKG_SHA256=9df61d885765fd56148807092d019f07ad593c85faab2c7caaad21b8e9f66de7
TERMUX_PKG_SHA256=1efb792c689fed2e028025e1398e84193281f329427a17a62b0bffee8e771395
TERMUX_PKG_SRCURL=https://nodejs.org/dist/v${TERMUX_PKG_VERSION}/node-v${TERMUX_PKG_VERSION}.tar.xz
# Note that we do not use a shared libuv to avoid an issue with the Android
# linker, which does not use symbols of linked shared libraries when resolving
@ -46,5 +46,6 @@ termux_step_configure() {
--cross-compiling
perl -p -i -e 's/LIBS := \$\(LIBS\)/LIBS := -lpthread/' \
$TERMUX_PKG_SRCDIR/out/deps/v8/gypfiles/torque.host.mk
$TERMUX_PKG_SRCDIR/out/tools/v8_gypfiles/torque.host.mk \
$TERMUX_PKG_SRCDIR/out/tools/v8_gypfiles/bytecode_builtins_list_generator.host.mk
}

View File

@ -0,0 +1,12 @@
diff -u -r ../node-v12.1.0/configure.py ./configure.py
--- ../node-v12.1.0/configure.py 2019-04-29 12:57:51.000000000 +0000
+++ ./configure.py 2019-05-05 21:21:04.289245037 +0000
@@ -931,7 +931,7 @@
else target_arch != host_arch)
want_snapshots = not options.without_snapshot
o['variables']['want_separate_host_toolset'] = int(
- cross_compiling and want_snapshots)
+ cross_compiling)
if options.with_node_snapshot:
o['variables']['node_use_node_snapshot'] = 'true'

View File

@ -1,13 +0,0 @@
diff -u -r ../node-v10.9.0/deps/v8/gypfiles/v8.gyp ./deps/v8/gypfiles/v8.gyp
--- ../node-v10.9.0/deps/v8/gypfiles/v8.gyp 2018-08-15 13:53:24.000000000 +0000
+++ ./deps/v8/gypfiles/v8.gyp 2018-08-23 21:43:30.588264328 +0000
@@ -2053,8 +2053,7 @@
# library order and break (see crbug.com/469973).
# These libraries do not exist on Mac hosted builds.
'libraries': [
- '-ldl',
- '-lrt'
+ '-ldl'
]
}]
]

View File

@ -1,18 +1,16 @@
diff -u -r ../node-v11.13.0/node.gyp ./node.gyp
--- ../node-v11.13.0/node.gyp 2019-03-28 09:27:13.000000000 +0000
+++ ./node.gyp 2019-03-31 18:43:41.463294068 +0000
@@ -965,101 +965,6 @@
diff -u -r ../node-v12.1.0/node.gyp ./node.gyp
--- ../node-v12.1.0/node.gyp 2019-04-29 12:57:54.000000000 +0000
+++ ./node.gyp 2019-05-05 20:54:54.823488546 +0000
@@ -1037,97 +1037,6 @@
} ],
]
}, # rename_node_bin_win
}, # specialize_node_d
- {
- 'target_name': 'cctest',
- 'type': 'executable',
-
- 'dependencies': [
- '<(node_lib_target_name)',
- 'rename_node_bin_win',
- 'deps/gtest/gtest.gyp:gtest',
- 'deps/histogram/histogram.gyp:histogram',
- 'node_dtrace_header',
- 'node_dtrace_ustack',
@ -29,13 +27,18 @@ diff -u -r ../node-v11.13.0/node.gyp ./node.gyp
- 'deps/v8/include',
- 'deps/cares/include',
- 'deps/uv/include',
- '<(SHARED_INTERMEDIATE_DIR)', # for node_natives.h
- 'test/cctest',
- ],
-
- 'defines': [ 'NODE_WANT_INTERNALS=1' ],
-
- 'sources': [
- 'src/node_snapshot_stub.cc',
- 'src/node_code_cache_stub.cc',
- 'test/cctest/gtest/gtest-all.cc',
- 'test/cctest/gtest/gtest_main.cc',
- 'test/cctest/node_test_fixture.cc',
- 'test/cctest/node_test_fixture.h',
- 'test/cctest/test_aliased_buffer.cc',
- 'test/cctest/test_base64.cc',
- 'test/cctest/test_node_postmortem_metadata.cc',
@ -45,7 +48,7 @@ diff -u -r ../node-v11.13.0/node.gyp ./node.gyp
- 'test/cctest/test_report_util.cc',
- 'test/cctest/test_traced_value.cc',
- 'test/cctest/test_util.cc',
- 'test/cctest/test_url.cc'
- 'test/cctest/test_url.cc',
- ],
-
- 'conditions': [
@ -63,7 +66,9 @@ diff -u -r ../node-v11.13.0/node.gyp ./node.gyp
- 'HAVE_INSPECTOR=1',
- ],
- }, {
- 'defines': [ 'HAVE_INSPECTOR=0' ]
- 'defines': [
- 'HAVE_INSPECTOR=0',
- ]
- }],
- ['OS=="solaris"', {
- 'ldflags': [ '-I<(SHARED_INTERMEDIATE_DIR)' ]
@ -85,21 +90,12 @@ diff -u -r ../node-v11.13.0/node.gyp ./node.gyp
- ],
- 'conditions': [
- ['OS=="win"', {
- 'libraries': [
- 'dbghelp.lib',
- 'PsApi.lib',
- 'Ws2_32.lib',
- ],
- 'dll_files': [
- 'dbghelp.dll',
- 'PsApi.dll',
- 'Ws2_32.dll',
- ],
- 'libraries': [ 'Ws2_32' ],
- }],
- ],
- }],
- ],
- }, # cctest
], # end targets
'conditions': [
# TODO(joyeecheung): do not depend on node_lib,
# instead create a smaller static library node_lib_base that does
# just enough for node_native_module.cc and the cache builder to