mpc: fixes for GNU libiconv dependency
This commit is contained in:
parent
49bd6d0ea8
commit
8aa8de24c3
@ -3,12 +3,14 @@ TERMUX_PKG_DESCRIPTION="Minimalist command line interface for MPD"
|
|||||||
TERMUX_PKG_LICENSE="GPL-2.0"
|
TERMUX_PKG_LICENSE="GPL-2.0"
|
||||||
TERMUX_PKG_MAINTAINER="Matthew Klein @mklein994"
|
TERMUX_PKG_MAINTAINER="Matthew Klein @mklein994"
|
||||||
TERMUX_PKG_VERSION=0.32
|
TERMUX_PKG_VERSION=0.32
|
||||||
|
TERMUX_PKG_REVISION=1
|
||||||
TERMUX_PKG_SRCURL=https://www.musicpd.org/download/mpc/${TERMUX_PKG_VERSION:0:1}/mpc-$TERMUX_PKG_VERSION.tar.xz
|
TERMUX_PKG_SRCURL=https://www.musicpd.org/download/mpc/${TERMUX_PKG_VERSION:0:1}/mpc-$TERMUX_PKG_VERSION.tar.xz
|
||||||
TERMUX_PKG_SHA256=7961d95b7ce019996beab281cf957e905667c989c53fffd13ade5e62fea331c7
|
TERMUX_PKG_SHA256=7961d95b7ce019996beab281cf957e905667c989c53fffd13ade5e62fea331c7
|
||||||
TERMUX_PKG_DEPENDS="libmpdclient"
|
TERMUX_PKG_DEPENDS="libiconv, libmpdclient"
|
||||||
|
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="-Diconv=enabled"
|
||||||
|
|
||||||
# There seems to be issues with sphinx-build when using concurrent builds:
|
# There seems to be issues with sphinx-build when using concurrent builds:
|
||||||
TERMUX_MAKE_PROCESSES=1
|
TERMUX_MAKE_PROCESSES=1
|
||||||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="-Diconv=enabled"
|
|
||||||
|
|
||||||
termux_step_pre_configure() {
|
termux_step_pre_configure() {
|
||||||
LDFLAGS+=" -liconv"
|
LDFLAGS+=" -liconv"
|
||||||
|
35
packages/mpc/meson.build.patch
Normal file
35
packages/mpc/meson.build.patch
Normal file
@ -0,0 +1,35 @@
|
|||||||
|
diff -uNr mpc-0.32/meson.build mpc-0.32.mod/meson.build
|
||||||
|
--- mpc-0.32/meson.build 2019-06-11 19:02:54.000000000 +0300
|
||||||
|
+++ mpc-0.32.mod/meson.build 2019-08-13 22:42:17.206151787 +0300
|
||||||
|
@@ -15,17 +15,7 @@
|
||||||
|
|
||||||
|
conf.set('HAVE_STRNDUP', cc.has_function('strndup', prefix: '#define _GNU_SOURCE\n#include <string.h>'))
|
||||||
|
|
||||||
|
-iconv = get_option('iconv')
|
||||||
|
-if iconv.disabled()
|
||||||
|
- iconv = false
|
||||||
|
-elif cc.has_function('iconv')
|
||||||
|
- iconv = true
|
||||||
|
-elif iconv.auto()
|
||||||
|
- iconv = false
|
||||||
|
-else
|
||||||
|
- error('iconv() not available')
|
||||||
|
-endif
|
||||||
|
-conf.set('HAVE_ICONV', iconv)
|
||||||
|
+conf.set('HAVE_ICONV', true)
|
||||||
|
|
||||||
|
configure_file(output: 'config.h', configuration: conf)
|
||||||
|
|
||||||
|
@@ -75,11 +65,7 @@
|
||||||
|
'.',
|
||||||
|
)
|
||||||
|
|
||||||
|
-if iconv
|
||||||
|
- iconv_sources = files('src/charset.c')
|
||||||
|
-else
|
||||||
|
- iconv_sources = []
|
||||||
|
-endif
|
||||||
|
+iconv_sources = files('src/charset.c')
|
||||||
|
|
||||||
|
executable('mpc',
|
||||||
|
'src/main.c',
|
Loading…
Reference in New Issue
Block a user