libical: Update from 3.0.4 to 3.0.5
This commit is contained in:
parent
6a8a34023e
commit
8b0a5b51f1
@ -1,9 +1,8 @@
|
||||
TERMUX_PKG_HOMEPAGE=http://libical.github.io/libical/
|
||||
TERMUX_PKG_DESCRIPTION="Libical is an Open Source implementation of the iCalendar protocols and protocol data units"
|
||||
TERMUX_PKG_LICENSE="LGPL-2.0"
|
||||
TERMUX_PKG_VERSION=3.0.4
|
||||
TERMUX_PKG_REVISION=1
|
||||
TERMUX_PKG_SHA256=72b216e10233c3f60cb06062facf41f3b0f70615e5a60b47f9853341a0d5d145
|
||||
TERMUX_PKG_VERSION=3.0.5
|
||||
TERMUX_PKG_SHA256=7ad550c8c49c9b9983658e3ab3e68b1eee2439ec17b169a6b1e6ecb5274e78e6
|
||||
TERMUX_PKG_SRCURL=https://github.com/libical/libical/releases/download/v$TERMUX_PKG_VERSION/libical-$TERMUX_PKG_VERSION.tar.gz
|
||||
TERMUX_PKG_DEPENDS="libxml2"
|
||||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS=" -DSHARED_ONLY=true -DICAL_GLIB=false -DUSE_BUILTIN_TZDATA=true -DPERL_EXECUTABLE=/usr/bin/perl"
|
||||
|
8
packages/libical/src-CMakeLists.txt.patch
Normal file
8
packages/libical/src-CMakeLists.txt.patch
Normal file
@ -0,0 +1,8 @@
|
||||
diff -u -r ../libical-3.0.5/src/CMakeLists.txt ./src/CMakeLists.txt
|
||||
--- ../libical-3.0.5/src/CMakeLists.txt 2019-05-16 12:11:15.000000000 +0000
|
||||
+++ ./src/CMakeLists.txt 2019-05-18 09:22:05.160236685 +0000
|
||||
@@ -4,4 +4,3 @@
|
||||
if(ICAL_GLIB)
|
||||
add_subdirectory(libical-glib)
|
||||
endif()
|
||||
-add_subdirectory(test)
|
@ -1,69 +0,0 @@
|
||||
--- ./src/test/stow.c 2017-11-19 14:32:53.000000000 +0000
|
||||
+++ ../stow.c 2017-12-07 20:41:54.498696535 +0000
|
||||
@@ -572,40 +572,41 @@
|
||||
if (opt->storage == STORE_IN_FILE && opt->output_file == 0) {
|
||||
char file[MAXPATHLEN];
|
||||
char *user = getenv("USER");
|
||||
- struct passwd *pw;
|
||||
+ #ifndef __ANDROID__
|
||||
+ struct passwd *pw;
|
||||
+ #endif
|
||||
|
||||
if (!user) {
|
||||
- fprintf(stderr,
|
||||
- "%s: Can't get username. Try explicitly specifying the output file with -o",
|
||||
- program_name);
|
||||
- exit(1);
|
||||
+ user = "TERMUX";
|
||||
}
|
||||
|
||||
/* Find password entry for user */
|
||||
/* cppcheck-suppress getpwentCalled as we don't care about multi-threaded in a test prog */
|
||||
- while ((pw = getpwent()) != 0) {
|
||||
- if (strcmp(user, pw->pw_name) == 0) {
|
||||
- break;
|
||||
+ #ifndef __ANDROID__
|
||||
+ while ((pw = getpwent()) != 0) {
|
||||
+ if (strcmp(user, pw->pw_name) == 0) {
|
||||
+ break;
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
+ if (pw == 0) {
|
||||
+ fprintf(stderr,
|
||||
+ "%s: Can't get get password entry for user \"%s\" "
|
||||
+ "Try explicitly specifying the output file with -o",
|
||||
+ program_name, user);
|
||||
+ exit(1);
|
||||
}
|
||||
- }
|
||||
-
|
||||
- if (pw == 0) {
|
||||
- fprintf(stderr,
|
||||
- "%s: Can't get get password entry for user \"%s\" "
|
||||
- "Try explicitly specifying the output file with -o",
|
||||
- program_name, user);
|
||||
- exit(1);
|
||||
- }
|
||||
|
||||
- if (pw->pw_dir == 0) {
|
||||
- fprintf(stderr,
|
||||
- "%s: User \"%s\" has no home directory. "
|
||||
- "Try explicitly specifying the output file with -o",
|
||||
- program_name, user);
|
||||
- exit(1);
|
||||
- }
|
||||
+ if (pw->pw_dir == 0) {
|
||||
+ fprintf(stderr,
|
||||
+ "%s: User \"%s\" has no home directory. "
|
||||
+ "Try explicitly specifying the output file with -o",
|
||||
+ program_name, user);
|
||||
+ exit(1);
|
||||
+ }
|
||||
|
||||
- snprintf(file, MAXPATHLEN, "%s/.facs/%s", pw->pw_dir, opt->calid);
|
||||
+ snprintf(file, MAXPATHLEN, "%s/.facs/%s", pw->pw_dir, opt->calid);
|
||||
+ #endif
|
||||
|
||||
opt->output_file = strdup(file);
|
||||
}
|
Loading…
Reference in New Issue
Block a user