update and enable package 'sslscan'
This commit is contained in:
parent
9dffff8858
commit
8f31b53ca1
@ -1,22 +0,0 @@
|
|||||||
diff --git a/Makefile b/Makefile
|
|
||||||
index 24e6a36..74c2647 100644
|
|
||||||
--- a/Makefile
|
|
||||||
+++ b/Makefile
|
|
||||||
@@ -1,7 +1,5 @@
|
|
||||||
# set gcc as default if CC is not set
|
|
||||||
-ifndef $(CC)
|
|
||||||
- CC=gcc
|
|
||||||
-endif
|
|
||||||
+CC?=gcc
|
|
||||||
|
|
||||||
GIT_VERSION = $(shell git describe --tags --always --dirty=-wip)
|
|
||||||
|
|
||||||
@@ -14,7 +12,7 @@ endif
|
|
||||||
OS := $(shell uname)
|
|
||||||
|
|
||||||
SRCS = sslscan.c
|
|
||||||
-PREFIX = /usr
|
|
||||||
+PREFIX ?= /usr
|
|
||||||
BINDIR = $(PREFIX)/bin
|
|
||||||
MANDIR = $(PREFIX)/share/man
|
|
||||||
MAN1DIR = $(MANDIR)/man1
|
|
@ -1,13 +0,0 @@
|
|||||||
# Status: Does not work with openssl 1.1 or later.
|
|
||||||
TERMUX_PKG_HOMEPAGE=https://github.com/rbsec/sslscan
|
|
||||||
TERMUX_PKG_DESCRIPTION="Fast SSL scanner"
|
|
||||||
TERMUX_PKG_VERSION=1.11.11
|
|
||||||
TERMUX_PKG_SRCURL=https://github.com/rbsec/sslscan/archive/${TERMUX_PKG_VERSION}-rbsec.tar.gz
|
|
||||||
TERMUX_PKG_SHA256=93fbe1570073dfb2898a546759836ea4df5054e3a8f6d2e3da468eddac8b1764
|
|
||||||
TERMUX_PKG_BUILD_IN_SRC=true
|
|
||||||
TERMUX_PKG_DEPENDS="openssl"
|
|
||||||
TERMUX_PKG_MAINTAINER="Pierre Rudloff @Rudloff"
|
|
||||||
|
|
||||||
termux_step_pre_configure() {
|
|
||||||
CPPFLAGS+=" -D__USE_GNU=1"
|
|
||||||
}
|
|
@ -1,35 +0,0 @@
|
|||||||
diff -u -r ../sslscan-1.11.7-rbsec/sslscan.c ./sslscan.c
|
|
||||||
--- ../sslscan-1.11.7-rbsec/sslscan.c 2016-06-13 08:42:11.000000000 -0400
|
|
||||||
+++ ./sslscan.c 2016-09-05 16:51:08.751161131 -0400
|
|
||||||
@@ -65,6 +65,7 @@
|
|
||||||
#endif
|
|
||||||
#else
|
|
||||||
#include <netdb.h>
|
|
||||||
+ #include <netinet/in.h>
|
|
||||||
#include <sys/socket.h>
|
|
||||||
#include <sys/select.h>
|
|
||||||
#endif
|
|
||||||
@@ -794,11 +795,11 @@
|
|
||||||
}
|
|
||||||
}
|
|
||||||
else
|
|
||||||
-#endif
|
|
||||||
{
|
|
||||||
printf("%sOpenSSL version does not support compression%s\n", COL_RED, RESET);
|
|
||||||
printf("%sRebuild with zlib1g-dev package for zlib support%s\n\n", COL_RED, RESET);
|
|
||||||
}
|
|
||||||
+#endif
|
|
||||||
|
|
||||||
// Disconnect SSL over socket
|
|
||||||
SSL_shutdown(ssl);
|
|
||||||
@@ -3762,10 +3763,6 @@
|
|
||||||
case mode_multiple:
|
|
||||||
printf("Version: %s%s%s\n%s\n%s\n", COL_GREEN, VERSION, RESET,
|
|
||||||
SSLeay_version(SSLEAY_VERSION), RESET);
|
|
||||||
-#ifdef OPENSSL_NO_SSL2
|
|
||||||
- printf("%sOpenSSL version does not support SSLv2%s\n", COL_RED, RESET);
|
|
||||||
- printf("%sSSLv2 ciphers will not be detected%s\n\n", COL_RED, RESET);
|
|
||||||
-#endif
|
|
||||||
#ifdef OPENSSL_NO_SSL3
|
|
||||||
printf("%sOpenSSL version does not support SSLv3%s\n", COL_RED, RESET);
|
|
||||||
printf("%sSSLv3 ciphers will not be detected%s\n", COL_RED, RESET);
|
|
8
packages/sslscan/build.sh
Normal file
8
packages/sslscan/build.sh
Normal file
@ -0,0 +1,8 @@
|
|||||||
|
TERMUX_PKG_HOMEPAGE=https://github.com/rbsec/sslscan
|
||||||
|
TERMUX_PKG_DESCRIPTION="Utility to discover supported cipher suites on SSL/TLS enabled servers"
|
||||||
|
TERMUX_PKG_LICENSE="GPL-3.0"
|
||||||
|
TERMUX_PKG_VERSION=2.0.5
|
||||||
|
TERMUX_PKG_SRCURL=https://github.com/rbsec/sslscan/archive/${TERMUX_PKG_VERSION}.tar.gz
|
||||||
|
TERMUX_PKG_SHA256=34a557a7996bb5c2f69fe512b7ef14ba272094178e76140535e50691bf934f99
|
||||||
|
TERMUX_PKG_DEPENDS="openssl"
|
||||||
|
TERMUX_PKG_BUILD_IN_SRC=true
|
Loading…
Reference in New Issue
Block a user