Merge branch 'master' into update-vimrc

This commit is contained in:
Leonid Pliushch 2019-04-13 18:30:02 +03:00 committed by GitHub
commit 8f4004bfbf
38 changed files with 153 additions and 154 deletions

View File

@ -9,31 +9,6 @@ This project contains scripts and patches to build packages for the [Termux](htt
More information can be found in the [docs](docs/) directory.
### Android 7 branch is in alpha testing !
Android 5/6 support will no longer be our priority. We are going to switch to API 24 target to ensure that Android's libc and linker is able to provide features we need.
Old (android 5) branch will continue to be served at https://termux.net and will receive package updates but no new packages will be added.
If you decided to test the new branch, follow these steps:
1. `pkg in termux-keyring`
2. Edit `$PREFIX/etc/apt/sources.list` and replace the line
```
deb https://termux.net stable main
```
with
```
deb https://dl.bintray.com/termux/termux-packages-24 stable main
```
3. Run `apt install --reinstall $(dpkg -l | grep ^ii | awk '{ print $2 }')`.
4. Report found issues. Note that issues only for official packages are accepted.
It is highly recommended to try to execute programs without `LD_LIBRARY_PATH` set. Most of them should continue to run since `DT_RUNPATH` field compiled-in ELF binary is used. Though, some programs are not working due to missing `DT_RUNPATH`, please check list in the related issue https://github.com/termux/termux-packages/issues/3490 and tell if we missed something.
## Directory Structure
- [disabled-packages](disabled-packages/): Packages that cannot be built or have serious issues.

View File

@ -1,9 +1,14 @@
TERMUX_PKG_HOMEPAGE=http://abook.sourceforge.net/
TERMUX_PKG_DESCRIPTION="Abook is a text-based addressbook program designed to use with mutt mail client"
TERMUX_PKG_LICENSE="GPL-2.0"
TERMUX_PKG_VERSION=0.6.0pre2
TERMUX_PKG_REVISION=2
TERMUX_PKG_VERSION=0.6.1
TERMUX_PKG_SHA256=f0a90df8694fb34685ecdd45d97db28b88046c15c95e7b0700596028bd8bc0f9
TERMUX_PKG_SRCURL=http://abook.sourceforge.net/devel/abook-$TERMUX_PKG_VERSION.tar.gz
TERMUX_PKG_SHA256=59d444504109dd96816e003b3023175981ae179af479349c34fa70bc12f6d385
TERMUX_PKG_DEPENDS="libandroid-support, ncurses, readline"
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--mandir=$TERMUX_PREFIX/share/man"
termux_step_pre_configure() {
aclocal
automake --add-missing
autoreconf
}

View File

@ -1,8 +1,8 @@
TERMUX_PKG_HOMEPAGE=https://beyondgrep.com/
TERMUX_PKG_DESCRIPTION="Tool like grep optimized for programmers"
TERMUX_PKG_LICENSE="Artistic-License-2.0"
TERMUX_PKG_VERSION=2.24
TERMUX_PKG_SHA256=8361e5a2654bc575db27bfa40470c4182d74d51098d390944d98fe7cd5b20d49
TERMUX_PKG_VERSION=2.28
TERMUX_PKG_SHA256=0ab3df19513a2c71aa7901f7f522a5baf72ce69e6e0e34879979f157210734f6
TERMUX_PKG_SRCURL=https://beyondgrep.com/ack-${TERMUX_PKG_VERSION}-single-file
TERMUX_PKG_SKIP_SRC_EXTRACT=yes
# Depend on coreutils for bin/env

View File

@ -1,9 +1,8 @@
TERMUX_PKG_HOMEPAGE=https://httpd.apache.org
TERMUX_PKG_DESCRIPTION="Apache Web Server"
TERMUX_PKG_LICENSE="Apache-2.0"
TERMUX_PKG_VERSION=2.4.38
TERMUX_PKG_REVISION=3
TERMUX_PKG_SHA256=7dc65857a994c98370dc4334b260101a7a04be60e6e74a5c57a6dee1bc8f394a
TERMUX_PKG_VERSION=2.4.39
TERMUX_PKG_SHA256=b4ca9d05773aa59b54d66cd8f4744b945289f084d3be17d7981d1783a5decfa2
TERMUX_PKG_SRCURL=https://www.apache.org/dist/httpd/httpd-$TERMUX_PKG_VERSION.tar.bz2
TERMUX_PKG_DEPENDS="apr, apr-util, pcre, openssl, libcrypt, libandroid-support, libnghttp2, libexpat, libuuid"
TERMUX_PKG_CONFFILES="

View File

@ -1,9 +1,8 @@
TERMUX_PKG_HOMEPAGE=https://blogc.rgm.io/
TERMUX_PKG_DESCRIPTION="A blog compiler"
TERMUX_PKG_LICENSE="BSD 3-Clause"
TERMUX_PKG_VERSION=0.12.0.123.acf1
TERMUX_PKG_REVISION=1
TERMUX_PKG_MAINTAINER="Rafael Martins @rafaelmartins"
TERMUX_PKG_SRCURL="https://travis-distfiles.rgm.io/blogc/blogc-0.12.0.123-acf1/blogc-0.12.0.123-acf1.tar.xz"
TERMUX_PKG_SHA256=c1885fd8d0068cb24fda899a236591af9daf492aec3601690e7d9a7badf97616
TERMUX_PKG_VERSION=0.15.1
TERMUX_PKG_SRCURL=https://github.com/blogc/blogc/releases/download/v$TERMUX_PKG_VERSION/blogc-$TERMUX_PKG_VERSION.tar.bz2
TERMUX_PKG_SHA256=90b0549116fdbd88270958d3efdcccbf4ee2fb188e2d3401ae70d7c1d87ad09d
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--disable-git-receiver --enable-make --enable-runserver --disable-tests --disable-valgrind"

View File

@ -1,14 +0,0 @@
Avoid make install trying to write to folders in /usr.
diff -u -r ../cmatrix-1.2/Makefile.in ./Makefile.in
--- ../cmatrix-1.2/Makefile.in 2017-06-23 11:51:59.000000000 +0200
+++ ./Makefile.in 2017-07-16 19:01:37.496306273 +0200
@@ -760,7 +760,7 @@
info-am:
-install-data-am: install-data-local install-man
+install-data-am: install-man
install-dvi: install-dvi-am

View File

@ -1,14 +1,15 @@
TERMUX_PKG_HOMEPAGE=https://github.com/abishekvashok/cmatrix
TERMUX_PKG_DESCRIPTION="Command producing a Matrix-style animation"
TERMUX_PKG_LICENSE="GPL-3.0"
local _REAL_VERSION=1.2
TERMUX_PKG_VERSION=${_REAL_VERSION}b
TERMUX_PKG_SHA256=6b0b9aff4585147843c4cf8a8c9c6048500f66dc4887a38922197dfa326b57c8
TERMUX_PKG_SRCURL=https://github.com/abishekvashok/cmatrix/archive/${_REAL_VERSION}.tar.gz
TERMUX_PKG_VERSION=2.0
TERMUX_PKG_SHA256=ad93ba39acd383696ab6a9ebbed1259ecf2d3cf9f49d6b97038c66f80749e99a
TERMUX_PKG_SRCURL=https://github.com/abishekvashok/cmatrix/archive/v${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--mandir=$TERMUX_PREFIX/share/man"
TERMUX_PKG_DEPENDS="ncurses"
termux_step_pre_configure() {
autoreconf -i
export ac_cv_file__usr_lib_kbd_consolefonts=no
export ac_cv_file__usr_share_consolefonts=no
export ac_cv_file__usr_lib_X11_fonts_misc=no

View File

@ -1,14 +1,21 @@
TERMUX_PKG_HOMEPAGE=https://ctags.io/
TERMUX_PKG_DESCRIPTION="Universal ctags: Source code index builder"
TERMUX_PKG_LICENSE="GPL-2.0"
TERMUX_PKG_VERSION=0.0.20180830
local _COMMIT=f9bbb35e7b4b053f04a1b6f0c2bbcea55641b2b6
TERMUX_PKG_SHA256=3585f1b9df43d7ecf31c06877fb7bfed4429a47fe95a8ab65da5738e76a442aa
TERMUX_PKG_VERSION=0.0.20190412
local _COMMIT=61cc66cfc796e707cfb13c5fed493af280378c75
TERMUX_PKG_SHA256=479abda4686fafd11cae40f646c2b692cc0209783d233b2534b339b838af9acc
TERMUX_PKG_SRCURL=https://github.com/universal-ctags/ctags/archive/${_COMMIT}.zip
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--enable-tmpdir=$TERMUX_PREFIX/tmp"
TERMUX_PKG_BUILD_IN_SRC="yes"
TERMUX_PKG_HOSTBUILD="yes"
termux_step_pre_configure() {
termux_step_post_extract_package() {
export regcomp_works=yes
./autogen.sh
}
termux_step_pre_configure() {
./autogen.sh
cp $TERMUX_PKG_HOSTBUILD_DIR/packcc $TERMUX_PKG_BUILDDIR/
touch -d "next hour" $TERMUX_PKG_BUILDDIR/packcc
}

View File

@ -1,6 +1,6 @@
diff -u -r ../ctags-8a60622839c98ef6fac1c57a5563812393c56c1d/configure.ac ./configure.ac
--- ../ctags-8a60622839c98ef6fac1c57a5563812393c56c1d/configure.ac 2017-09-01 11:04:30.000000000 +0200
+++ ./configure.ac 2017-09-01 23:38:48.761978655 +0200
diff -u -r ../ctags-61cc66cfc796e707cfb13c5fed493af280378c75/configure.ac ./configure.ac
--- ../ctags-61cc66cfc796e707cfb13c5fed493af280378c75/configure.ac 2019-04-12 19:56:22.000000000 +0000
+++ ./configure.ac 2019-04-13 07:08:50.478780864 +0000
@@ -7,7 +7,14 @@
# Process this file with autoconf to produce a configure script.
@ -17,7 +17,16 @@ diff -u -r ../ctags-8a60622839c98ef6fac1c57a5563812393c56c1d/configure.ac ./conf
AM_INIT_AUTOMAKE([foreign subdir-objects tar-ustar])
AM_SILENT_RULES([yes])
AC_CONFIG_HEADERS([config.h])
@@ -574,16 +581,7 @@
@@ -409,7 +416,7 @@
sprintf(buffer, "%zu", i);
return !(buffer[0] == '9' && buffer[1] == '9' && buffer[2] == '9');
}
-]])],[have_zu_formatter=yes],[have_zu_formatter=no])
+]])],[have_zu_formatter=yes],[have_zu_formatter=no], [have_zu_formatter=yes])
AC_MSG_RESULT($have_zu_formatter)
if test x$have_zu_formatter != xyes; then
@@ -594,16 +601,7 @@
AH_TEMPLATE([HAVE_LIBXML],
[Define this value if libxml is available.])

View File

@ -1,8 +1,8 @@
TERMUX_PKG_HOMEPAGE=http://www.tads.org/frobtads.htm
TERMUX_PKG_DESCRIPTION="TADS is a free authoring system for writing your own Interactive Fiction"
TERMUX_PKG_LICENSE="custom"
TERMUX_PKG_LICENSE="non-free"
TERMUX_PKG_VERSION=1.2.4
TERMUX_PKG_REVISION=2
TERMUX_PKG_REVISION=3
TERMUX_PKG_SHA256=705be5849293844f499a85280e793941b0eacb362b90d49d85ae8308e4c5b63c
TERMUX_PKG_SRCURL=https://github.com/realnc/frobtads/releases/download/$TERMUX_PKG_VERSION/frobtads-$TERMUX_PKG_VERSION.tar.bz2
TERMUX_PKG_RM_AFTER_INSTALL="share/frobtads/tads3/doc share/frobtads/tads3/lib/webuires"

View File

@ -1,9 +1,8 @@
TERMUX_PKG_HOMEPAGE=https://www.ghostscript.com/
TERMUX_PKG_DESCRIPTION="Interpreter for the PostScript language and for PDF"
TERMUX_PKG_LICENSE="AGPL-V3"
TERMUX_PKG_VERSION=9.26
TERMUX_PKG_REVISION=1
TERMUX_PKG_SHA256=b0d4916b669a63ed861f563c4607cc1230949c53431ab0798db8e680fdacc777
TERMUX_PKG_VERSION=9.27
TERMUX_PKG_SHA256=9e089546624296bf4aca14c2adcb0762b323ca77ae14176d21127b749baac8d6
TERMUX_PKG_SRCURL=https://github.com/ArtifexSoftware/ghostpdl-downloads/releases/download/gs${TERMUX_PKG_VERSION//.}/ghostpdl-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_DEPENDS="libandroid-support, libtiff, libjpeg-turbo, libpng, libexpat, freetype, fontconfig, libidn, littlecms, openjpeg"
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="

View File

@ -2,7 +2,7 @@ TERMUX_PKG_HOMEPAGE=http://www.graphicsmagick.org/
TERMUX_PKG_DESCRIPTION="Collection of image processing tools"
TERMUX_PKG_LICENSE="MIT"
TERMUX_PKG_VERSION=1.3.31
TERMUX_PKG_REVISION=1
TERMUX_PKG_REVISION=2
TERMUX_PKG_SHA256=096bbb59d6f3abd32b562fc3b34ea90d88741dc5dd888731d61d17e100394278
# Bandwith limited on main ftp site, so it's asked to use sourceforge instead:
TERMUX_PKG_SRCURL=http://downloads.sourceforge.net/project/graphicsmagick/graphicsmagick/${TERMUX_PKG_VERSION}/GraphicsMagick-${TERMUX_PKG_VERSION}.tar.xz
@ -13,4 +13,4 @@ ac_cv_func_ftime=no
--without-webp
--without-x
"
TERMUX_PKG_RM_AFTER_INSTALL="bin/*-config share/man/man1/*-config.1"
TERMUX_PKG_INCLUDE_IN_DEVPACKAGE="bin/*-config"

View File

@ -1,9 +1,8 @@
TERMUX_PKG_HOMEPAGE=https://gohugo.io/
TERMUX_PKG_DESCRIPTION="A fast and flexible static site generator"
TERMUX_PKG_LICENSE="Apache-2.0"
TERMUX_PKG_VERSION=0.54.0
TERMUX_PKG_REVISION=2
TERMUX_PKG_SHA256=fe0f4d4542491706cc19cb8c0acd63f1d9989cfbeaaad39d93031e91bf73fd91
TERMUX_PKG_VERSION=0.55.0
TERMUX_PKG_SHA256=4601d29e174c1829476e0a821073bcac6fc468864fccaac05d91f09a779334d9
TERMUX_PKG_SRCURL=https://github.com/gohugoio/hugo/archive/v$TERMUX_PKG_VERSION.tar.gz
termux_step_make() {

View File

@ -1,8 +1,8 @@
TERMUX_PKG_HOMEPAGE=https://thrysoee.dk/editline/
TERMUX_PKG_DESCRIPTION="Library providing line editing, history, and tokenization functions"
TERMUX_PKG_LICENSE="BSD 3-Clause"
TERMUX_PKG_VERSION=20181209-3.1
TERMUX_PKG_SHA256=2811d70c0b000f2ca91b7cb1a37203134441743c4fcc9c37b0b687f328611064
TERMUX_PKG_VERSION=20190324-3.1
TERMUX_PKG_SHA256=ac8f0f51c1cf65492e4d1e3ed2be360bda41e54633444666422fbf393bba1bae
TERMUX_PKG_SRCURL=https://thrysoee.dk/editline/libedit-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_DEPENDS="libandroid-support, ncurses"
TERMUX_PKG_RM_AFTER_INSTALL="share/man/man7/editline.7 share/man/man3/history.3"

View File

@ -1,8 +1,8 @@
TERMUX_PKG_HOMEPAGE=http://www.pixman.org/
TERMUX_PKG_DESCRIPTION="Low-level library for pixel manipulation"
TERMUX_PKG_LICENSE="BSD"
TERMUX_PKG_VERSION=0.38.0
TERMUX_PKG_SHA256=a7592bef0156d7c27545487a52245669b00cf7e70054505381cff2136d890ca8
TERMUX_PKG_VERSION=0.38.4
TERMUX_PKG_SHA256=da66d6fd6e40aee70f7bd02e4f8f76fc3f006ec879d346bae6a723025cfbdde7
TERMUX_PKG_SRCURL=https://cairographics.org/releases/pixman-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--disable-libpng"

View File

@ -0,0 +1,8 @@
TERMUX_PKG_HOMEPAGE=https://github.com/protobuf-c/protobuf-c
TERMUX_PKG_DESCRIPTION="Protocol buffers C library"
TERMUX_PKG_LICENSE="BSD 3-Clause"
TERMUX_PKG_MAINTAINER="Henrik Grimler @Grimler91"
TERMUX_PKG_VERSION=1.3.1
TERMUX_PKG_SHA256=51472d3a191d6d7b425e32b612e477c06f73fe23e07f6a6a839b11808e9d2267
TERMUX_PKG_SRCURL=https://github.com/protobuf-c/protobuf-c/releases/download/v${TERMUX_PKG_VERSION}/protobuf-c-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_DEPENDS="libprotobuf, protobuf"

View File

@ -1,8 +1,8 @@
TERMUX_PKG_HOMEPAGE=https://mariadb.org
TERMUX_PKG_DESCRIPTION="A drop-in replacement for mysql server"
TERMUX_PKG_LICENSE="GPL-2.0"
TERMUX_PKG_VERSION=10.3.13
TERMUX_PKG_SHA256=b2aa857ef5b84f85a7ea60a1eac7b34c0ca5151c71a0d44ce2d7fb028d71459a
TERMUX_PKG_VERSION=10.3.14
TERMUX_PKG_SHA256=ba1c94d92fc8ebdf9b8a1d1b93ed6aeeead33da507efbbd4afcf49f32023e054
TERMUX_PKG_SRCURL=https://ftp.osuosl.org/pub/mariadb/mariadb-$TERMUX_PKG_VERSION/source/mariadb-$TERMUX_PKG_VERSION.tar.gz
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
-DBISON_EXECUTABLE=$(which bison)

View File

@ -0,0 +1,25 @@
diff -u -r ../mariadb-10.3.14/client/CMakeLists.txt ./client/CMakeLists.txt
--- ../mariadb-10.3.14/client/CMakeLists.txt 2019-04-01 14:03:56.000000000 +0000
+++ ./client/CMakeLists.txt 2019-04-11 21:36:27.617921632 +0000
@@ -44,12 +44,6 @@
SET_TARGET_PROPERTIES(mysql PROPERTIES ENABLE_EXPORTS TRUE)
ENDIF(UNIX)
-MYSQL_ADD_EXECUTABLE(mysqltest mysqltest.cc COMPONENT Test)
-SET_SOURCE_FILES_PROPERTIES(mysqltest.cc PROPERTIES COMPILE_FLAGS "-DTHREADS")
-TARGET_LINK_LIBRARIES(mysqltest ${CLIENT_LIB} pcreposix pcre)
-SET_TARGET_PROPERTIES(mysqltest PROPERTIES ENABLE_EXPORTS TRUE)
-
-
MYSQL_ADD_EXECUTABLE(mysqlcheck mysqlcheck.c)
TARGET_LINK_LIBRARIES(mysqlcheck ${CLIENT_LIB})
@@ -94,7 +88,7 @@
PROPERTIES HAS_CXX TRUE)
-FOREACH(t mysql mysqltest mysqltest mysqlcheck mysqldump mysqlimport mysql_upgrade mysqlshow mysql_plugin mysqlbinlog
+FOREACH(t mysql mysqlcheck mysqldump mysqlimport mysql_upgrade mysqlshow mysql_plugin mysqlbinlog
mysqladmin mysqlslap async_example)
ADD_DEPENDENCIES(${t} GenError ${CLIENT_LIB})
ENDFOREACH()

View File

@ -1,11 +1,12 @@
--- ../HybridDsdDecoderPlugin.cxx.orig 2019-01-07 20:58:59.223328152 +0100
+++ ./src/decoder/plugins/HybridDsdDecoderPlugin.cxx 2019-01-07 21:00:02.953327686 +0100
@@ -40,8 +40,6 @@
diff -u -r ../MPD-0.21.7/src/decoder/plugins/HybridDsdDecoderPlugin.cxx ./src/decoder/plugins/HybridDsdDecoderPlugin.cxx
--- ../MPD-0.21.7/src/decoder/plugins/HybridDsdDecoderPlugin.cxx 2019-04-03 10:18:29.000000000 +0000
+++ ./src/decoder/plugins/HybridDsdDecoderPlugin.cxx 2019-04-11 23:28:00.503100747 +0000
@@ -39,8 +39,6 @@
without a DSD DAC, the PCM (=ALAC) part of the file is
better */
if (block.GetBlockParam("enabled") == nullptr) {
- LogInfo(hybrid_dsd_domain,
- "The Hybrid DSD decoder is disabled because it was not explicitly enabled");
- LogDebug(hybrid_dsd_domain,
- "The Hybrid DSD decoder is disabled because it was not explicitly enabled");
return false;
}

View File

@ -1,9 +1,9 @@
TERMUX_PKG_HOMEPAGE=https://www.musicpd.org
TERMUX_PKG_DESCRIPTION="Music player daemon"
TERMUX_PKG_LICENSE="GPL-2.0"
TERMUX_PKG_VERSION=0.21.6
TERMUX_PKG_VERSION=0.21.7
TERMUX_PKG_REVISION=1
TERMUX_PKG_SHA256=ad164cb90e8cafcaef10cc64bbe7969c85c7b31246eff907cc6012cbfa85ec82
TERMUX_PKG_SHA256=b33b03e813851387e28970536cd8513fad36ad47bde0928be25ca84a30bc8758
TERMUX_PKG_SRCURL=https://github.com/MusicPlayerDaemon/MPD/archive/v$TERMUX_PKG_VERSION.tar.gz
TERMUX_PKG_DEPENDS="libcurl, libid3tag, libopus, libpulseaudio, libmpdclient, openal-soft, libvorbis, libsqlite, ffmpeg, libmp3lame, libbz2, libogg, libnfs"
TERMUX_PKG_BUILD_DEPENDS="boost"

View File

@ -1,9 +1,12 @@
diff -u -r ../MPD-0.21.3/src/lib/gcrypt/meson.build ./src/lib/gcrypt/meson.build
--- ../MPD-0.21.3/src/lib/gcrypt/meson.build 2018-11-16 12:27:58.000000000 +0000
+++ ./src/lib/gcrypt/meson.build 2019-01-06 23:35:51.108609898 +0000
@@ -1,4 +1,4 @@
diff -u -r ../MPD-0.21.7/src/lib/gcrypt/meson.build ./src/lib/gcrypt/meson.build
--- ../MPD-0.21.7/src/lib/gcrypt/meson.build 2019-04-03 10:18:29.000000000 +0000
+++ ./src/lib/gcrypt/meson.build 2019-04-11 23:30:00.477643167 +0000
@@ -8,7 +8,7 @@
# will falsly assume it has found the gcrypt library for the target.
#
# See: https://github.com/MusicPlayerDaemon/MPD/pull/495
-gcrypt_dep = c_compiler.find_library('gcrypt', required: get_option('qobuz'))
+gcrypt_dep = c_compiler.find_library('gcrypt_disabled', required: get_option('qobuz'))
if not gcrypt_dep.found()
subdir_done()
if gcrypt_dep.found()
gcrypt_dep = dependency('libgcrypt')
endif

View File

@ -17,6 +17,8 @@ termux_step_extract_into_massagedir() {
cp -Rf $TERMUX_STANDALONE_TOOLCHAIN/sysroot/usr/include/* \
$TERMUX_PKG_MASSAGEDIR/$TERMUX_PREFIX/include
patch -d $TERMUX_PKG_MASSAGEDIR/$TERMUX_PREFIX/include/c++/v1 -p1 < $TERMUX_PKG_BUILDER_DIR/math-header.diff
cp $TERMUX_STANDALONE_TOOLCHAIN/sysroot/usr/lib/$TERMUX_HOST_PLATFORM/$TERMUX_PKG_API_LEVEL/*.o \
$TERMUX_PKG_MASSAGEDIR/$TERMUX_PREFIX/lib

View File

@ -0,0 +1,22 @@
--- data/data/com.termux/files/usr/include/c++/v1/cmath.orig 2019-03-24 00:31:49.512145195 +0000
+++ ./cmath 2019-03-24 00:32:19.392703442 +0000
@@ -302,7 +302,7 @@
*/
#include <__config>
-#include <math.h>
+#include <c++/v1/math.h>
#include "version"
#if !defined(_LIBCPP_HAS_NO_PRAGMA_SYSTEM_HEADER)
--- data/data/com.termux/files/usr/include/c++/v1/math.h.orig 2019-03-24 01:10:28.881807799 +0000
+++ ./math.h 2019-03-24 01:11:01.078384393 +0000
@@ -298,7 +298,7 @@
#pragma GCC system_header
#endif
-#include_next <math.h>
+#include "../../math.h"
#ifdef __cplusplus

View File

@ -1,8 +1,8 @@
TERMUX_PKG_HOMEPAGE=https://www.nginx.org
TERMUX_PKG_DESCRIPTION="Lightweight HTTP server"
TERMUX_PKG_LICENSE="BSD 2-Clause"
TERMUX_PKG_VERSION=1.15.10
TERMUX_PKG_SHA256=b865743abd52bce4745d0f7e7fedde3cafbaaab617b022c105e3e4e456537c3c
TERMUX_PKG_VERSION=1.15.11
TERMUX_PKG_SHA256=d5eb2685e2ebe8a9d048b07222ffdab50e6ff6245919eebc2482c1f388e3f8ad
TERMUX_PKG_SRCURL=http://nginx.org/download/nginx-$TERMUX_PKG_VERSION.tar.gz
TERMUX_PKG_BUILD_IN_SRC=true
TERMUX_PKG_DEPENDS="libandroid-glob, libcrypt, pcre, openssl"

View File

@ -1,10 +1,9 @@
TERMUX_PKG_HOMEPAGE=https://nodejs.org/
TERMUX_PKG_DESCRIPTION="Platform built on Chrome's JavaScript runtime for easily building fast, scalable network applications"
TERMUX_PKG_LICENSE="MIT"
TERMUX_PKG_VERSION=11.13.0
TERMUX_PKG_REVISION=1
TERMUX_PKG_VERSION=11.14.0
TERMUX_PKG_SHA256=9df61d885765fd56148807092d019f07ad593c85faab2c7caaad21b8e9f66de7
TERMUX_PKG_SRCURL=https://nodejs.org/dist/v${TERMUX_PKG_VERSION}/node-v${TERMUX_PKG_VERSION}.tar.xz
TERMUX_PKG_SHA256=7411952da11f6033d4ca5993d68f52b0d7eb90538099102c37d5221c445dc38a
# Note that we do not use a shared libuv to avoid an issue with the Android
# linker, which does not use symbols of linked shared libraries when resolving
# symbols on dlopen(). See https://github.com/termux/termux-packages/issues/462.

View File

@ -1,19 +0,0 @@
TERMUX_PKG_HOMEPAGE=https://github.com/termux/nonfree-packages
TERMUX_PKG_DESCRIPTION="Package repository containing software licensed under non-free/custom licenses."
TERMUX_PKG_LICENSE="Apache-2.0"
TERMUX_PKG_MAINTAINER="Leonid Plyushch <leonid.plyushch@gmail.com> @xeffyr"
TERMUX_PKG_VERSION=1.0
TERMUX_PKG_DEPENDS="termux-keyring"
TERMUX_PKG_PLATFORM_INDEPENDENT=yes
termux_step_make_install() {
mkdir -p $TERMUX_PREFIX/etc/apt/sources.list.d
echo "deb https://termux.com/nonfree-packages stable main" > $TERMUX_PREFIX/etc/apt/sources.list.d/nonfree.list
}
termux_step_create_debscripts() {
echo "#!$TERMUX_PREFIX/bin/sh" > postinst
echo "echo Downloading updated package list ..." >> postinst
echo "apt update" >> postinst
echo "exit 0" >> postinst
}

View File

@ -2,7 +2,7 @@ TERMUX_PKG_HOMEPAGE=https://github.com/mtoyoda/sl
TERMUX_PKG_DESCRIPTION="Tool curing your bad habit of mistyping"
TERMUX_PKG_LICENSE="custom"
TERMUX_PKG_VERSION=5.02
TERMUX_PKG_REVISION=1
TERMUX_PKG_REVISION=2
TERMUX_PKG_SRCURL=https://github.com/mtoyoda/sl/archive/${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=1e5996757f879c81f202a18ad8e982195cf51c41727d3fea4af01fdcbbb5563a
TERMUX_PKG_DEPENDS="ncurses"

View File

@ -2,31 +2,12 @@ TERMUX_PKG_HOMEPAGE=http://www.dest-unreach.org/socat/
TERMUX_PKG_DESCRIPTION="Relay for bidirectional data transfer between two independent data channels"
TERMUX_PKG_LICENSE="GPL-2.0"
TERMUX_PKG_DEPENDS="openssl, readline"
TERMUX_PKG_VERSION=1.7.3.2
TERMUX_PKG_REVISION=4
TERMUX_PKG_VERSION=1.7.3.3
TERMUX_PKG_SHA256=8cc0eaee73e646001c64adaab3e496ed20d4d729aaaf939df2a761e99c674372
TERMUX_PKG_SRCURL=http://www.dest-unreach.org/socat/download/socat-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=ce3efc17e3e544876ebce7cd6c85b3c279fda057b2857fcaaf67b9ab8bdaf034
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="ac_header_resolv_h=no ac_cv_c_compiler_gnu=yes ac_compiler_gnu=yes" # sc_cv_sys_crdly_shift=9 sc_cv_sys_csize_shift=4 sc_cv_sys_tabdly_shift=11"
TERMUX_PKG_BUILD_IN_SRC=yes
#TERMUX_PKG_HOSTBUILD=yes
termux_step_pre_configure() {
LDFLAGS="$LDFLAGS -llog" # uses syslog
}
#termux_step_configure() {
# From socat_buildscript_for_android.sh in socat source:
#./configure --host --disable-unix --disable-openssl --prefix=$TERMUX_PREFIX
# Replace misconfigured values in config.h and enable PTY functions
#mv config.h config.old
#cat config.old \
#| sed 's/CRDLY_SHIFT.*/CRDLY_SHIFT 9/' \
#| sed 's/TABDLY_SHIFT.*/TABDLY_SHIFT 11/' \
#| sed 's/CSIZE_SHIFT.*/CSIZE_SHIFT 4/' \
#| sed 's/\/\* #undef HAVE_OPENPTY \*\//#define HAVE_OPENPTY 1/' \
#| sed 's/\/\* #undef HAVE_GRANTPT \*\//#define HAVE_GRANTPT 1/' \
#> config.h
# Enable openpty() in Makefile
#mv Makefile Makefile.old
#cat Makefile.old | sed 's/error.c/error.c openpty.c/' > Makefile
#}

View File

@ -1,9 +1,9 @@
TERMUX_PKG_HOMEPAGE=https://www.stunnel.org/
TERMUX_PKG_DESCRIPTION="Socket wrapper which can provide TLS support to ordinary applications"
TERMUX_PKG_LICENSE="GPL-2.0"
TERMUX_PKG_VERSION=5.51
TERMUX_PKG_VERSION=5.53
TERMUX_PKG_REVISION=1
TERMUX_PKG_SHA256=77437cdd1aef1a621824bb3607e966534642fe90c69f4d2279a9da9fa36c3253
TERMUX_PKG_SHA256=80439896ee14269eb70bc8bc669433c7d619018a62c9f9c5c760a24515302585
TERMUX_PKG_SRCURL=https://www.stunnel.org/downloads/stunnel-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_DEPENDS="openssl"
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--disable-shared --with-ssl=$TERMUX_PREFIX --disable-fips"

View File

@ -1,9 +1,9 @@
TERMUX_PKG_HOMEPAGE=https://swi-prolog.org/
TERMUX_PKG_DESCRIPTION="Most popular and complete prolog implementation"
TERMUX_PKG_LICENSE="ISC"
TERMUX_PKG_VERSION=8.1.0
TERMUX_PKG_VERSION=8.1.3
TERMUX_PKG_SHA256=9cb94b04ce655e34fe6d270e40c4a90edeb4ce0f6e854ebb9e8e0bc254ae1f72
TERMUX_PKG_SRCURL=http://www.swi-prolog.org/download/devel/src/swipl-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=865a7eb4a0324b0b5b1ae667a2e2630333d4d889b9427a8653a0c265270a1581
TERMUX_PKG_DEPENDS="libarchive, libcrypt, libgmp, libjpeg-turbo, libyaml, ncurses, ncurses-ui-libs, pcre, readline, ossp-uuid"
TERMUX_PKG_FORCE_CMAKE=true
TERMUX_PKG_HOSTBUILD=true

View File

@ -1,9 +1,9 @@
TERMUX_PKG_HOMEPAGE=https://www.rarlab.com/
TERMUX_PKG_DESCRIPTION="Tool for extracting files from .rar archives"
TERMUX_PKG_LICENSE="custom"
TERMUX_PKG_VERSION=5.7.3
TERMUX_PKG_LICENSE="non-free"
TERMUX_PKG_VERSION=5.7.4
TERMUX_PKG_REVISION=1
TERMUX_PKG_SHA256=40e856b78374f258d8a1f5f02c02f828c5392a0118c9300fd169a300b520a444
TERMUX_PKG_SHA256=582dd038fd4632f32493928cae5b37dbb436752813da08a1ee5df2ab1ee7e7b4
TERMUX_PKG_SRCURL=https://www.rarlab.com/rar/unrarsrc-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_DEPENDS="libandroid-support"
TERMUX_PKG_BUILD_IN_SRC=yes

View File

@ -5,9 +5,9 @@ TERMUX_PKG_DEPENDS="ncurses, vim-runtime, python"
TERMUX_PKG_RECOMMENDS="diffutils"
# vim should only be updated every 50 releases on multiples of 50.
# Update both vim and vim-python to the same version in one PR.
TERMUX_PKG_VERSION=8.1.1100
TERMUX_PKG_VERSION=8.1.1150
TERMUX_PKG_REVISION=1
TERMUX_PKG_SHA256=d7f59c2a0a16983d71f0bb27560356fd1602134037abdecd90e4280f3cafa8e3
TERMUX_PKG_SHA256=3f5a614ffe829a5d1ce47ae1ccaa471af105c33a5e1b2316aabd4dd9894ec7c7
TERMUX_PKG_SRCURL="https://github.com/vim/vim/archive/v${TERMUX_PKG_VERSION}.tar.gz"
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
vim_cv_getcwd_broken=no

View File

@ -5,9 +5,9 @@ TERMUX_PKG_DEPENDS="ncurses, vim-runtime"
TERMUX_PKG_RECOMMENDS="diffutils"
# vim should only be updated every 50 releases on multiples of 50.
# Update both vim and vim-python to the same version in one PR.
TERMUX_PKG_VERSION=8.1.1100
TERMUX_PKG_VERSION=8.1.1150
TERMUX_PKG_REVISION=1
TERMUX_PKG_SHA256=d7f59c2a0a16983d71f0bb27560356fd1602134037abdecd90e4280f3cafa8e3
TERMUX_PKG_SHA256=3f5a614ffe829a5d1ce47ae1ccaa471af105c33a5e1b2316aabd4dd9894ec7c7
TERMUX_PKG_SRCURL="https://github.com/vim/vim/archive/v${TERMUX_PKG_VERSION}.tar.gz"
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
vim_cv_getcwd_broken=no

View File

@ -142,7 +142,7 @@ emergency_exit() {
json_metadata_dump() {
local old_ifs=$IFS
local license
local pkg_licenses
local pkg_licenses=""
IFS=","
for license in ${PACKAGE_METADATA['LICENSES']}; do
@ -550,10 +550,8 @@ process_packages() {
msg " * ${package_name}: skipping because field 'TERMUX_PKG_LICENSE' is empty."
SCRIPT_ERROR_EXIT=true
continue
elif grep -qP '.*custom.*' <(echo "${PACKAGE_METADATA['LICENSES']}"); then
msg " * ${package_name}: skipping because it has custom license."
SCRIPT_ERROR_EXIT=true
continue
elif grep -qP '.*(custom|non-free).*' <(echo "${PACKAGE_METADATA['LICENSES']}"); then
PACKAGE_METADATA["LICENSES"]=""
fi
PACKAGE_METADATA["DESCRIPTION"]=$(get_package_property "$package_name" "TERMUX_PKG_DESCRIPTION")