commit
91edc4d9a9
@ -4,12 +4,11 @@ TERMUX_PKG_LICENSE="Public Domain"
|
||||
TERMUX_PKG_MAINTAINER="@termux"
|
||||
# Note: Updating this version requires bumping libsqlite-tcl package as well.
|
||||
_SQLITE_MAJOR=3
|
||||
_SQLITE_MINOR=35
|
||||
_SQLITE_PATCH=5
|
||||
_SQLITE_MINOR=36
|
||||
_SQLITE_PATCH=0
|
||||
TERMUX_PKG_VERSION=${_SQLITE_MAJOR}.${_SQLITE_MINOR}.${_SQLITE_PATCH}
|
||||
TERMUX_PKG_REVISION=1
|
||||
TERMUX_PKG_SRCURL=https://www.sqlite.org/2021/sqlite-autoconf-${_SQLITE_MAJOR}${_SQLITE_MINOR}0${_SQLITE_PATCH}00.tar.gz
|
||||
TERMUX_PKG_SHA256=f52b72a5c319c3e516ed7a92e123139a6e87af08a2dc43d7757724f6132e6db0
|
||||
TERMUX_PKG_SHA256=bd90c3eb96bee996206b83be7065c9ce19aef38c3f4fb53073ada0d0b69bbce3
|
||||
TERMUX_PKG_DEPENDS="zlib"
|
||||
TERMUX_PKG_BREAKS="libsqlite-dev"
|
||||
TERMUX_PKG_REPLACES="libsqlite-dev"
|
||||
|
@ -2,9 +2,9 @@ TERMUX_PKG_HOMEPAGE=https://talloc.samba.org/talloc/doc/html/index.html
|
||||
TERMUX_PKG_DESCRIPTION="Hierarchical, reference counted memory pool system with destructors"
|
||||
TERMUX_PKG_LICENSE="GPL-3.0"
|
||||
TERMUX_PKG_MAINTAINER="@termux"
|
||||
TERMUX_PKG_VERSION=2.3.2
|
||||
TERMUX_PKG_VERSION=2.3.3
|
||||
TERMUX_PKG_SRCURL=https://www.samba.org/ftp/talloc/talloc-${TERMUX_PKG_VERSION}.tar.gz
|
||||
TERMUX_PKG_SHA256=27a03ef99e384d779124df755deb229cd1761f945eca6d200e8cfd9bf5297bd7
|
||||
TERMUX_PKG_SHA256=6be95b2368bd0af1c4cd7a88146eb6ceea18e46c3ffc9330bf6262b40d1d8aaa
|
||||
TERMUX_PKG_BREAKS="libtalloc-dev"
|
||||
TERMUX_PKG_REPLACES="libtalloc-dev"
|
||||
TERMUX_PKG_BUILD_IN_SRC=true
|
||||
|
@ -2,10 +2,9 @@ TERMUX_PKG_HOMEPAGE=https://newsboat.org/
|
||||
TERMUX_PKG_DESCRIPTION="RSS/Atom feed reader for the text console"
|
||||
TERMUX_PKG_LICENSE="MIT"
|
||||
TERMUX_PKG_MAINTAINER="@termux"
|
||||
TERMUX_PKG_VERSION=2.23
|
||||
TERMUX_PKG_REVISION=1
|
||||
TERMUX_PKG_VERSION=2.24
|
||||
TERMUX_PKG_SRCURL=https://newsboat.org/releases/${TERMUX_PKG_VERSION}/newsboat-${TERMUX_PKG_VERSION}.tar.xz
|
||||
TERMUX_PKG_SHA256=b997b139d41db2cc5f54346f27c448bee47d6c6228a12ce9cb91c3ffaec7dadc
|
||||
TERMUX_PKG_SHA256=62420688cca25618859548d10ff6df9ac75b9cf766699f37edd3e324d67c6ffb
|
||||
TERMUX_PKG_DEPENDS="libc++, libiconv, libandroid-support, libandroid-glob, json-c, libsqlite, libcurl, libxml2, stfl, ncurses, openssl"
|
||||
TERMUX_PKG_BUILD_IN_SRC=true
|
||||
TERMUX_PKG_RM_AFTER_INSTALL="share/locale"
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -uNr newsboat-2.17/src/tagsouppullparser.cpp newsboat-2.17.mod/src/tagsouppullparser.cpp
|
||||
--- newsboat-2.17/src/tagsouppullparser.cpp 2019-09-22 17:19:19.000000000 +0300
|
||||
+++ newsboat-2.17.mod/src/tagsouppullparser.cpp 2019-09-24 21:48:19.762987918 +0300
|
||||
@@ -515,7 +515,7 @@
|
||||
} else {
|
||||
for (unsigned int i = 0; entity_table[i].entity; ++i) {
|
||||
if (s == entity_table[i].entity) {
|
||||
- char mbc[MB_CUR_MAX];
|
||||
+ char mbc[16];
|
||||
int pos = wctomb(mbc, entity_table[i].value);
|
||||
if (pos == -1) {
|
||||
return std::string();
|
@ -1,5 +1,6 @@
|
||||
--- ./rust/libnewsboat/Cargo.toml.orig 2021-05-17 16:44:12.665188034 +0000
|
||||
+++ ./rust/libnewsboat/Cargo.toml 2021-05-17 16:44:22.377378220 +0000
|
||||
diff -uNr newsboat-2.24/rust/libnewsboat/Cargo.toml newsboat-2.24.mod/rust/libnewsboat/Cargo.toml
|
||||
--- newsboat-2.24/rust/libnewsboat/Cargo.toml 2021-06-20 20:40:09.000000000 +0300
|
||||
+++ newsboat-2.24.mod/rust/libnewsboat/Cargo.toml 2021-07-17 22:24:18.930766657 +0300
|
||||
@@ -17,7 +17,7 @@
|
||||
backtrace = "= 0.3"
|
||||
unicode-width = "0.1.8"
|
||||
@ -14,7 +15,7 @@
|
||||
default-features = false
|
||||
|
||||
-[dependencies.gettext-rs]
|
||||
-version = "0.6.0"
|
||||
-version = "0.7.0"
|
||||
-# Don't let the crate build its own copy of gettext; force it to use the one
|
||||
-# built into glibc.
|
||||
-features = [ "gettext-system" ]
|
||||
|
@ -1,7 +1,8 @@
|
||||
--- ./rust/regex-rs/Cargo.toml.orig 2021-05-17 15:54:50.865965562 +0000
|
||||
+++ ./rust/regex-rs/Cargo.toml 2021-05-17 15:54:57.293957473 +0000
|
||||
diff -uNr newsboat-2.24/rust/regex-rs/Cargo.toml newsboat-2.24.mod/rust/regex-rs/Cargo.toml
|
||||
--- newsboat-2.24/rust/regex-rs/Cargo.toml 2021-06-20 20:40:09.000000000 +0300
|
||||
+++ newsboat-2.24.mod/rust/regex-rs/Cargo.toml 2021-07-17 22:25:36.235307902 +0300
|
||||
@@ -12,4 +12,3 @@
|
||||
|
||||
bitflags = "1.2"
|
||||
libc = ">=0.2.69"
|
||||
-gettext-rs = "0.6.0"
|
||||
-gettext-rs = "0.7.0"
|
||||
|
@ -2,10 +2,9 @@ TERMUX_PKG_HOMEPAGE=https://www.passwordstore.org
|
||||
TERMUX_PKG_DESCRIPTION="Lightweight directory-based password manager"
|
||||
TERMUX_PKG_LICENSE="GPL-2.0"
|
||||
TERMUX_PKG_MAINTAINER="@termux"
|
||||
TERMUX_PKG_VERSION=1.7.3
|
||||
TERMUX_PKG_REVISION=2
|
||||
TERMUX_PKG_VERSION=1.7.4
|
||||
TERMUX_PKG_SRCURL=https://git.zx2c4.com/password-store/snapshot/password-store-${TERMUX_PKG_VERSION}.tar.xz
|
||||
TERMUX_PKG_SHA256=2b6c65846ebace9a15a118503dcd31b6440949a30d3b5291dfb5b1615b99a3f4
|
||||
TERMUX_PKG_SHA256=cfa9faf659f2ed6b38e7a7c3fb43e177d00edbacc6265e6e32215ff40e3793c0
|
||||
TERMUX_PKG_DEPENDS="bash, coreutils, gnupg (>= 2.2.9-1), tree"
|
||||
TERMUX_PKG_RECOMMENDS="git"
|
||||
TERMUX_PKG_SUGGESTS="pass-otp"
|
||||
|
@ -1,37 +1,32 @@
|
||||
diff --git a/src/password-store.sh b/src/password-store.sh
|
||||
index 7264ffc..f924de3 100755
|
||||
--- a/src/password-store.sh
|
||||
+++ b/src/password-store.sh
|
||||
@@ -11,7 +11,7 @@ GPG="gpg"
|
||||
export GPG_TTY="${GPG_TTY:-$(tty 2>/dev/null)}"
|
||||
which gpg2 &>/dev/null && GPG="gpg2"
|
||||
[[ -n $GPG_AGENT_INFO || $GPG == "gpg2" ]] && GPG_OPTS+=( "--batch" "--use-agent" )
|
||||
-
|
||||
+TMPDIR=$PREFIX/tmp
|
||||
PREFIX="${PASSWORD_STORE_DIR:-$HOME/.password-store}"
|
||||
EXTENSIONS="${PASSWORD_STORE_EXTENSIONS_DIR:-$PREFIX/.extensions}"
|
||||
X_SELECTION="${PASSWORD_STORE_X_SELECTION:-clipboard}"
|
||||
@@ -156,11 +156,11 @@ clip() {
|
||||
# trailing new lines.
|
||||
local sleep_argv0="password store sleep on display $DISPLAY"
|
||||
pkill -f "^$sleep_argv0" 2>/dev/null && sleep 0.5
|
||||
- local before="$(xclip -o -selection "$X_SELECTION" 2>/dev/null | $BASE64)"
|
||||
- echo -n "$1" | xclip -selection "$X_SELECTION" || die "Error: Could not copy data to the clipboard"
|
||||
+ local before="$(termux-clipboard-get 2>/dev/null | $BASE64)"
|
||||
+ echo -n "$1" | termux-clipboard-set || die "Error: Could not copy data to the clipboard"
|
||||
(
|
||||
( exec -a "$sleep_argv0" bash <<<"trap 'kill %1' TERM; sleep '$CLIP_TIME' & wait" )
|
||||
- local now="$(xclip -o -selection "$X_SELECTION" | $BASE64)"
|
||||
+ local now="$(termux-clipboard-get | $BASE64)"
|
||||
[[ $now != $(echo -n "$1" | $BASE64) ]] && before="$now"
|
||||
diff -uNr password-store-1.7.4/src/password-store.sh password-store-1.7.4.mod/src/password-store.sh
|
||||
--- password-store-1.7.4/src/password-store.sh 2021-06-11 19:49:06.000000000 +0300
|
||||
+++ password-store-1.7.4.mod/src/password-store.sh 2021-07-17 22:45:01.663534629 +0300
|
||||
@@ -168,7 +168,9 @@
|
||||
local paste_cmd=( xclip -o -selection "$X_SELECTION" )
|
||||
local display_name="$DISPLAY"
|
||||
else
|
||||
- die "Error: No X11 or Wayland display detected"
|
||||
+ local copy_cmd=( termux-clipboard-set )
|
||||
+ local paste_cmd=( termux-clipboard-get )
|
||||
+ local display_name="termux"
|
||||
fi
|
||||
local sleep_argv0="password store sleep on display $display_name"
|
||||
|
||||
# It might be nice to programatically check to see if klipper exists,
|
||||
@@ -172,7 +172,7 @@ clip() {
|
||||
# so we axe it here:
|
||||
qdbus org.kde.klipper /klipper org.kde.klipper.klipper.clearClipboardHistory &>/dev/null
|
||||
|
||||
- echo "$before" | $BASE64 -d | xclip -selection "$X_SELECTION"
|
||||
+ echo "$before" | $BASE64 -d | termux-clipboard-set
|
||||
) >/dev/null 2>&1 & disown
|
||||
echo "Copied $2 to clipboard. Will clear in $CLIP_TIME seconds."
|
||||
}
|
||||
@@ -225,7 +227,7 @@
|
||||
}
|
||||
trap remove_tmpfile EXIT
|
||||
else
|
||||
- [[ $warn -eq 1 ]] && yesno "$(cat <<-_EOF
|
||||
+ [[ $(uname -o) == "Android" ]] || [[ $warn -eq 1 ]] && yesno "$(cat <<-_EOF
|
||||
Your system does not have /dev/shm, which means that it may
|
||||
be difficult to entirely erase the temporary non-encrypted
|
||||
password file after editing.
|
||||
@@ -233,7 +235,7 @@
|
||||
Are you sure you would like to continue?
|
||||
_EOF
|
||||
)"
|
||||
- SECURE_TMPDIR="$(mktemp -d "${TMPDIR:-/tmp}/$template")"
|
||||
+ SECURE_TMPDIR="$(mktemp -d "${TMPDIR:-@TERMUX_PREFIX@/tmp}/$template")"
|
||||
shred_tmpfile() {
|
||||
find "$SECURE_TMPDIR" -type f -exec $SHRED {} +
|
||||
rm -rf "$SECURE_TMPDIR"
|
||||
|
@ -2,9 +2,9 @@ TERMUX_PKG_HOMEPAGE=https://www.phpmyadmin.net
|
||||
TERMUX_PKG_DESCRIPTION="A PHP tool for administering MySQL databases"
|
||||
TERMUX_PKG_LICENSE="GPL-2.0"
|
||||
TERMUX_PKG_MAINTAINER="@termux"
|
||||
TERMUX_PKG_VERSION=5.1.0
|
||||
TERMUX_PKG_VERSION=5.1.1
|
||||
TERMUX_PKG_SRCURL=https://files.phpmyadmin.net/phpMyAdmin/$TERMUX_PKG_VERSION/phpMyAdmin-$TERMUX_PKG_VERSION-all-languages.tar.xz
|
||||
TERMUX_PKG_SHA256=aa8ccf357f672012384df34e1c2bc70147476761c8458a0dad6233497e142c68
|
||||
TERMUX_PKG_SHA256=1964d7190223c11e89fa1b7970c618e3a3bae2e859f5f60383f64c3848ef6921
|
||||
TERMUX_PKG_DEPENDS="apache2, php"
|
||||
TERMUX_PKG_CONFFILES="etc/phpmyadmin/config.inc.php"
|
||||
|
||||
|
@ -2,13 +2,13 @@ TERMUX_PKG_HOMEPAGE=https://pngquant.org
|
||||
TERMUX_PKG_DESCRIPTION="PNG image optimising utility"
|
||||
TERMUX_PKG_LICENSE="GPL-3.0"
|
||||
TERMUX_PKG_MAINTAINER="@termux"
|
||||
TERMUX_PKG_VERSION=2.14.1
|
||||
TERMUX_PKG_VERSION=2.15.1
|
||||
# If both archives are .tar.gz then they overwrite eachother since they are the same version and hence the same name.
|
||||
# Work around this by using .zip for one of them...
|
||||
TERMUX_PKG_SRCURL=(https://github.com/pornel/pngquant/archive/$TERMUX_PKG_VERSION.tar.gz
|
||||
https://github.com/ImageOptim/libimagequant/archive/$TERMUX_PKG_VERSION.zip)
|
||||
TERMUX_PKG_SHA256=(5b2e29d61f548b18b0dd37156a49f87625123250577815add666e473fd1ca1af
|
||||
a78b09ee26e5563d90052f331c1c7849a31bd0dcf2b9b2f38df739640d748390)
|
||||
TERMUX_PKG_SHA256=(24856b28aca47ed78633fa625eb74b85782d62dacc4bca634fcedf2f6e95c4b7
|
||||
5c1d1c60f4a4e39f19a154e0f7aa23f895c7cadc634ba257835e520712902b7a)
|
||||
TERMUX_PKG_DEPENDS="libpng, littlecms, zlib"
|
||||
TERMUX_PKG_BUILD_IN_SRC=true
|
||||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--disable-sse"
|
||||
|
Loading…
Reference in New Issue
Block a user