vifm: Update from 0.9 to 0.9.1

This commit is contained in:
Fredrik Fornwall 2018-02-06 22:01:06 +01:00
parent 3609f0479e
commit 945c606b41
3 changed files with 37 additions and 17 deletions

View File

@ -1,8 +1,8 @@
TERMUX_PKG_HOMEPAGE=https://vifm.info/
TERMUX_PKG_DESCRIPTION="Vifm is an ncurses based file manager with vi like keybindings/modes/options/commands/configuration"
TERMUX_PKG_VERSION=0.9
TERMUX_PKG_SRCURL=https://github.com/vifm/vifm/archive/v0.9.tar.gz
TERMUX_PKG_SHA256=837337935627dafaff90da300dea0e35dd9ad1eb932294274ababee814f91649
TERMUX_PKG_VERSION=0.9.1
TERMUX_PKG_SHA256=f208cdcd912348df8e18214078ab2455831d05190078ab5af507bd9789ea8b04
TERMUX_PKG_SRCURL=https://github.com/vifm/vifm/archive/v${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_DEPENDS="ncurses, file"
termux_step_pre_configure() {

View File

@ -1,6 +1,7 @@
--- ../cache/vifm-0.9/configure.ac 2017-06-18 14:31:25.000000000 +0000
+++ ./configure.ac 2017-10-03 23:29:41.348507964 +0000
@@ -145,18 +145,11 @@
diff -u -r ../vifm-0.9.1/configure.ac ./configure.ac
--- ../vifm-0.9.1/configure.ac 2018-02-05 10:40:02.000000000 +0000
+++ ./configure.ac 2018-02-06 13:53:38.873777524 +0000
@@ -154,18 +154,11 @@
AC_CHECK_FUNC([getcwd], [], [AC_MSG_ERROR([getcwd() function not found.])])
AC_CHECK_FUNC([getenv], [], [AC_MSG_ERROR([getenv() function not found.])])
AC_CHECK_FUNC([geteuid], [], [AC_MSG_ERROR([geteuid() function not found.])])
@ -9,7 +10,7 @@
-AC_CHECK_FUNC([getgrgid_r], [], [AC_MSG_ERROR([getgrgid_r() function not found.])])
-AC_CHECK_FUNC([getgrnam], [], [AC_MSG_ERROR([getgrnam() function not found.])])
if test -n "$HAVE_MNTENT_H" ; then
AC_CHECK_FUNC([getmntent], [], [AC_MSG_ERROR([getmntent() function not found.])])
AC_CHECK_FUNC([getmntent], [], [AC_MSG_ERROR([getmntent() function not found.])])
fi
AC_CHECK_FUNC([getpid], [], [AC_MSG_ERROR([getpid() function not found.])])
AC_CHECK_FUNC([getppid], [], [AC_MSG_ERROR([getppid() function not found.])])
@ -19,29 +20,36 @@
AC_CHECK_FUNC([getpwuid_r], [], [AC_MSG_ERROR([getpwuid_r() function not found.])])
AC_CHECK_FUNC([ioctl], [], [AC_MSG_ERROR([ioctl() function not found.])])
AC_CHECK_FUNC([iswalnum], [], [AC_MSG_ERROR([iswalnum() function not found.])])
@@ -192,13 +185,11 @@
@@ -201,13 +194,11 @@
AC_CHECK_FUNC([rmdir], [], [AC_MSG_ERROR([rmdir() function not found.])])
AC_CHECK_FUNC([select], [], [AC_MSG_ERROR([select() function not found.])])
AC_CHECK_FUNC([setenv], [], [AC_MSG_ERROR([setenv() function not found.])])
-AC_CHECK_FUNC([setgrent], [], [AC_MSG_ERROR([setgrent() function not found.])])
AC_CHECK_FUNC([setlocale], [], [AC_MSG_ERROR([setlocale() function not found.])])
if test -n "$HAVE_MNTENT_H" ; then
AC_CHECK_FUNC([setmntent], [], [AC_MSG_ERROR([setmntent() function not found.])])
AC_CHECK_FUNC([setmntent], [], [AC_MSG_ERROR([setmntent() function not found.])])
fi
AC_CHECK_FUNC([setpgid], [], [AC_MSG_ERROR([setpgid() function not found.])])
-AC_CHECK_FUNC([setpwent], [], [AC_MSG_ERROR([setpwent() function not found.])])
AC_CHECK_FUNC([setsid], [], [AC_MSG_ERROR([setsid() function not found.])])
AC_CHECK_FUNC([setvbuf], [], [AC_MSG_ERROR([setvbuf() function not found.])])
AC_CHECK_FUNC([sigaction], [], [AC_MSG_ERROR([sigaction() function not found.])])
@@ -371,11 +362,6 @@
@@ -384,18 +375,6 @@
dnl from libc)
AC_CHECK_LIB(m, pow, [LIBS="$LIBS -lm"])
dnl Use pthread library
-AC_CHECK_LIB(pthread, pthread_create,
- [LIBS="$LIBS -lpthread"
- AC_CHECK_HEADER([pthread.h], [], [AC_MSG_ERROR([pthread.h header not found.])])
- ],
- [AC_MSG_ERROR([libpthread not found])])
-dnl Use pthread library
-AX_CHECK_COMPILE_FLAG([-pthread], [
- TESTS_CFLAGS="$CFLAGS -pthread"
- CFLAGS="$CFLAGS -pthread"
- ], [
- AC_CHECK_LIB(pthread, pthread_create,
- [LIBS="$LIBS -lpthread"
- AC_CHECK_HEADER([pthread.h], [], [AC_MSG_ERROR([pthread.h header not found.])])
- ],
- [AC_MSG_ERROR([libpthread not found])])
- ])
-
dnl Check for all required elements in pthread.h.
AC_CHECK_FUNC([pthread_create], [], [AC_MSG_ERROR([pthread_create() function not found.])])
AC_CHECK_FUNC([pthread_getspecific], [], [AC_MSG_ERROR([pthread_getspecific() function not found.])])

View File

@ -0,0 +1,12 @@
diff -u -r ../vifm-0.9.1/src/utils/path.c ./src/utils/path.c
--- ../vifm-0.9.1/src/utils/path.c 2018-02-05 11:40:02.000000000 +0100
+++ ./src/utils/path.c 2018-02-06 21:01:58.660741129 +0100
@@ -784,7 +784,7 @@
const char *
get_tmpdir(void)
{
- return env_get_one_of_def("/tmp/", "TMPDIR", "TEMP", "TEMPDIR", "TMP",
+ return env_get_one_of_def("@TERMUX_PREFIX@/tmp/", "TMPDIR", "TEMP", "TEMPDIR", "TMP",
(const char *)NULL);
}