neofetch: Patch for version 3.0

This commit is contained in:
Fredrik Fornwall 2017-01-23 13:16:21 +01:00
parent 127f27e83d
commit 947099c006
2 changed files with 42 additions and 0 deletions

View File

@ -0,0 +1,28 @@
diff -u -r ../neofetch-3.0/Makefile ./Makefile
--- ../neofetch-3.0/Makefile 2017-01-23 04:40:31.000000000 +0100
+++ ./Makefile 2017-01-23 13:04:18.588389799 +0100
@@ -1,4 +1,4 @@
-PREFIX = /usr
+PREFIX ?= /usr
all:
@echo Run \'make install\' to install Neofetch
@@ -6,15 +6,15 @@
install:
mkdir -p $(DESTDIR)$(PREFIX)/bin
mkdir -p $(DESTDIR)$(PREFIX)/share/man/man1
- mkdir -p $(DESTDIR)/etc/neofetch
+ mkdir -p $(DESTDIR)$(PREFIX)/etc/neofetch
mkdir -p $(DESTDIR)$(PREFIX)/share/neofetch/ascii/distro
cp -p neofetch $(DESTDIR)$(PREFIX)/bin/neofetch
cp -p neofetch.1 $(DESTDIR)$(PREFIX)/share/man/man1/neofetch.1
- cp -p config/config $(DESTDIR)/etc/neofetch/config
+ cp -p config/config $(DESTDIR)$(PREFIX)/etc/neofetch/config
cp -p ascii/distro/* $(DESTDIR)$(PREFIX)/share/neofetch/ascii/distro
uninstall:
rm -f $(DESTDIR)$(PREFIX)/bin/neofetch
rm -f $(DESTDIR)$(PREFIX)/share/man/man1/neofetch.1
rm -f -r $(DESTDIR)$(PREFIX)/share/neofetch
- rm -f -r $(DESTDIR)/etc/neofetch
+ rm -f -r $(DESTDIR)$(PREFIX)/etc/neofetch

View File

@ -0,0 +1,14 @@
diff -u -r ../neofetch-3.0/neofetch ./neofetch
--- ../neofetch-3.0/neofetch 2017-01-23 04:40:31.000000000 +0100
+++ ./neofetch 2017-01-23 13:12:25.682702897 +0100
@@ -3285,8 +3285,8 @@
if [[ -f "/etc/neofetch/config" ]]; then
default_config="/etc/neofetch/config"
- elif [[ -f "/data/data/com.termux/files/etc/neofetch/config" ]]; then
- default_config="/data/data/com.termux/files/etc/neofetch/config"
+ elif [[ -f "/data/data/com.termux/files/usr/etc/neofetch/config" ]]; then
+ default_config="/data/data/com.termux/files/usr/etc/neofetch/config"
else
[[ -z "$script_dir" ]] && script_dir="$(get_full_path "$0")"