ki18n: fix build
Seems we need to depend on qt5-qtdeclarative and disable python bindings (though the latter could probably be fixed somehow). Error from python bindings was: CMake Error at /data/data/com.termux/files/usr/share/ECM/find-modules/FindPythonModuleGeneration.cmake:170 (message): The max python version in PythonModuleGeneration must be updated. Call Stack (most recent call first): src/CMakeLists.txt:63 (find_package)
This commit is contained in:
parent
f766e7ffd3
commit
95a6737e95
@ -7,4 +7,4 @@ TERMUX_PKG_REVISION=5
|
||||
TERMUX_PKG_SRCURL="http://download.kde.org/stable/frameworks/${TERMUX_PKG_VERSION%.*}/ki18n-${TERMUX_PKG_VERSION}.tar.xz"
|
||||
TERMUX_PKG_SHA256=f2fc8c40c10576da8b74070b7dc8e752fdd04204cb2bfe522f37a0458fbaf881
|
||||
TERMUX_PKG_DEPENDS="qt5-qtbase, gettext"
|
||||
TERMUX_PKG_BUILD_DEPENDS="extra-cmake-modules, python, qt5-qtbase-cross-tools"
|
||||
TERMUX_PKG_BUILD_DEPENDS="extra-cmake-modules, python, qt5-qtbase-cross-tools, qt5-qtdeclarative"
|
||||
|
11
x11-packages/ki18n/src-CMakeLists.txt.patch
Normal file
11
x11-packages/ki18n/src-CMakeLists.txt.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- ../src-CMakeLists.txt.orig 2021-10-15 17:34:25.460656823 +0000
|
||||
+++ ./src/CMakeLists.txt 2021-10-15 17:34:39.275431640 +0000
|
||||
@@ -60,8 +60,6 @@
|
||||
REQUIRED_HEADERS KI18n_HEADERS
|
||||
)
|
||||
|
||||
-find_package(PythonModuleGeneration)
|
||||
-
|
||||
if (PythonModuleGeneration_FOUND)
|
||||
ecm_generate_python_binding(
|
||||
TARGET KF5::I18n
|
Loading…
Reference in New Issue
Block a user