new package: hexchat - a popular and easy to use graphical IRC (chat) client
This commit is contained in:
parent
35d04c575b
commit
9a15452fab
30
x11-packages/hexchat/build.sh
Normal file
30
x11-packages/hexchat/build.sh
Normal file
@ -0,0 +1,30 @@
|
||||
TERMUX_PKG_MAINTAINER="Leonid Plyushch <leonid.plyushch@gmail.com> @xeffyr"
|
||||
|
||||
TERMUX_PKG_HOMEPAGE=https://hexchat.github.io/
|
||||
TERMUX_PKG_DESCRIPTION="A popular and easy to use graphical IRC (chat) client"
|
||||
TERMUX_PKG_VERSION=2.14.2
|
||||
TERMUX_PKG_SRCURL=https://github.com/hexchat/hexchat/archive/v2.14.2.tar.gz
|
||||
TERMUX_PKG_SHA256=4f2c2137020913513ea559f788c41039ca6230764d8158862d5d1ee8785592d9
|
||||
TERMUX_PKG_DEPENDS="gdk-pixbuf, glib, gtk2, liblua, libnotify, libx11, openssl, pango-x, python"
|
||||
|
||||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
|
||||
-Dwith-libproxy=false
|
||||
-Dwith-libcanberra=false
|
||||
-Dwith-dbus=false
|
||||
-Dwith-lua=lua
|
||||
-Dwith-text=true
|
||||
-Dwith-perl=false
|
||||
-Dwith-sysinfo=false
|
||||
"
|
||||
|
||||
TERMUX_PKG_RM_AFTER_INSTALL="share/locale"
|
||||
|
||||
termux_step_post_make_install() {
|
||||
## TODO: patch it to force link with libandroid-shmem instead of
|
||||
## using wrapper.
|
||||
mkdir -p "${TERMUX_PREFIX}/libexec/"
|
||||
mv "${TERMUX_PREFIX}/bin/hexchat" "${TERMUX_PREFIX}/libexec/"
|
||||
sed "s|@TERMUX_PREFIX@|${TERMUX_PREFIX}|g" \
|
||||
"${TERMUX_PKG_BUILDER_DIR}/hexchat.in" > "${TERMUX_PREFIX}/bin/hexchat"
|
||||
chmod 700 "${TERMUX_PREFIX}/bin/hexchat"
|
||||
}
|
@ -0,0 +1,22 @@
|
||||
diff -uNr hexchat-2.14.2/meson_post_install.py hexchat-2.14.2.mod/meson_post_install.py
|
||||
--- hexchat-2.14.2/meson_post_install.py 2018-08-29 19:41:08.000000000 +0300
|
||||
+++ hexchat-2.14.2.mod/meson_post_install.py 2018-10-09 21:31:29.201613989 +0300
|
||||
@@ -7,18 +7,3 @@
|
||||
prefix = os.environ.get('MESON_INSTALL_PREFIX', '/usr/local')
|
||||
datadir = os.path.join(prefix, 'share')
|
||||
with_thememan = sys.argv[1] == 'true'
|
||||
-
|
||||
-# Packaging tools define DESTDIR and this isn't needed for them
|
||||
-if 'DESTDIR' not in os.environ:
|
||||
- print('Updating icon cache...')
|
||||
- subprocess.call(['gtk-update-icon-cache', '-qtf',
|
||||
- os.path.join(datadir, 'icons', 'hicolor')])
|
||||
-
|
||||
- print('Updating desktop database...')
|
||||
- subprocess.call(['update-desktop-database', '-q',
|
||||
- os.path.join(datadir, 'applications')])
|
||||
-
|
||||
- if with_thememan:
|
||||
- print('Updating mime database...')
|
||||
- subprocess.call(['update-mime-database',
|
||||
- os.path.join(datadir, 'mime')])
|
@ -0,0 +1,13 @@
|
||||
diff -uNr hexchat-2.14.2/plugins/lua/meson.build hexchat-2.14.2.mod/plugins/lua/meson.build
|
||||
--- hexchat-2.14.2/plugins/lua/meson.build 2018-08-29 19:41:08.000000000 +0300
|
||||
+++ hexchat-2.14.2.mod/plugins/lua/meson.build 2018-10-09 22:01:54.019863275 +0300
|
||||
@@ -1,8 +1,4 @@
|
||||
-if cc.get_id() == 'msvc'
|
||||
- lua_dep = cc.find_library('lua51')
|
||||
-else
|
||||
- lua_dep = dependency(get_option('with-lua'))
|
||||
-endif
|
||||
+lua_dep = cc.find_library('lua', dirs : '@TERMUX_PREFIX@/lib')
|
||||
|
||||
shared_module('lua', 'lua.c',
|
||||
dependencies: [libgio_dep, hexchat_plugin_dep, lua_dep],
|
3
x11-packages/hexchat/hexchat.in
Normal file
3
x11-packages/hexchat/hexchat.in
Normal file
@ -0,0 +1,3 @@
|
||||
#!@TERMUX_PREFIX@/bin/sh
|
||||
export LD_PRELOAD=@TERMUX_PREFIX@/lib/libandroid-shmem.so
|
||||
exec @TERMUX_PREFIX@/libexec/hexchat "${@}"
|
Loading…
Reference in New Issue
Block a user