libseccomp: update to 2.4.2
This commit is contained in:
parent
ca1d6a96e3
commit
9a90a47ace
@ -1,13 +0,0 @@
|
||||
--- ../Makefile.orig 2019-07-21 08:51:17.175911022 +0000
|
||||
+++ ./Makefile 2019-07-21 09:35:21.844941292 +0000
|
||||
@@ -22,8 +22,8 @@
|
||||
@rm -rf build
|
||||
|
||||
install:
|
||||
- @mkdir -p /usr/local/share/bettercap/caplets
|
||||
- @cp bettercap /usr/local/bin/
|
||||
+ @mkdir -p @TERMUX_PREFIX@/share/bettercap/caplets
|
||||
+ @cp bettercap @TERMUX_PREFIX@/bin/
|
||||
|
||||
docker:
|
||||
@docker build -t bettercap:latest .
|
@ -1,82 +0,0 @@
|
||||
--- ../configure.orig 2019-02-09 18:02:35.976650487 +0100
|
||||
+++ ./configure 2019-02-09 18:07:20.969981859 +0100
|
||||
@@ -10703,11 +10703,11 @@
|
||||
|
||||
done
|
||||
|
||||
- check_lib_no_libs dlm dlm_lock -lpthread
|
||||
+ check_lib_no_libs dlm dlm_lock
|
||||
if test $NOTFOUND = 0; then
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: no pkg for libdlm, using -ldlm" >&5
|
||||
$as_echo "no pkg for libdlm, using -ldlm" >&6; }
|
||||
- DLM_LIBS="-ldlm -lpthread"
|
||||
+ DLM_LIBS="-ldlm"
|
||||
HAVE_DLM=yes
|
||||
fi
|
||||
elif test $pkg_failed = untried; then
|
||||
@@ -10728,11 +10728,11 @@
|
||||
|
||||
done
|
||||
|
||||
- check_lib_no_libs dlm dlm_lock -lpthread
|
||||
+ check_lib_no_libs dlm dlm_lock
|
||||
if test $NOTFOUND = 0; then
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: no pkg for libdlm, using -ldlm" >&5
|
||||
$as_echo "no pkg for libdlm, using -ldlm" >&6; }
|
||||
- DLM_LIBS="-ldlm -lpthread"
|
||||
+ DLM_LIBS="-ldlm"
|
||||
HAVE_DLM=yes
|
||||
fi
|
||||
else
|
||||
@@ -13909,51 +13909,6 @@
|
||||
hard_bailout
|
||||
fi
|
||||
|
||||
-
|
||||
-################################################################################
|
||||
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for pthread_mutex_lock in -lpthread" >&5
|
||||
-$as_echo_n "checking for pthread_mutex_lock in -lpthread... " >&6; }
|
||||
-if ${ac_cv_lib_pthread_pthread_mutex_lock+:} false; then :
|
||||
- $as_echo_n "(cached) " >&6
|
||||
-else
|
||||
- ac_check_lib_save_LIBS=$LIBS
|
||||
-LIBS="-lpthread $LIBS"
|
||||
-cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
-/* end confdefs.h. */
|
||||
-
|
||||
-/* Override any GCC internal prototype to avoid an error.
|
||||
- Use char because int might match the return type of a GCC
|
||||
- builtin and then its argument prototype would still apply. */
|
||||
-#ifdef __cplusplus
|
||||
-extern "C"
|
||||
-#endif
|
||||
-char pthread_mutex_lock ();
|
||||
-int
|
||||
-main ()
|
||||
-{
|
||||
-return pthread_mutex_lock ();
|
||||
- ;
|
||||
- return 0;
|
||||
-}
|
||||
-_ACEOF
|
||||
-if ac_fn_c_try_link "$LINENO"; then :
|
||||
- ac_cv_lib_pthread_pthread_mutex_lock=yes
|
||||
-else
|
||||
- ac_cv_lib_pthread_pthread_mutex_lock=no
|
||||
-fi
|
||||
-rm -f core conftest.err conftest.$ac_objext \
|
||||
- conftest$ac_exeext conftest.$ac_ext
|
||||
-LIBS=$ac_check_lib_save_LIBS
|
||||
-fi
|
||||
-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_lib_pthread_pthread_mutex_lock" >&5
|
||||
-$as_echo "$ac_cv_lib_pthread_pthread_mutex_lock" >&6; }
|
||||
-if test "x$ac_cv_lib_pthread_pthread_mutex_lock" = xyes; then :
|
||||
- PTHREAD_LIBS="-lpthread"
|
||||
-else
|
||||
- hard_bailout
|
||||
-fi
|
||||
-
|
||||
-
|
||||
################################################################################
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether to enable selinux support" >&5
|
||||
$as_echo_n "checking whether to enable selinux support... " >&6; }
|
@ -2,9 +2,8 @@ TERMUX_PKG_HOMEPAGE=https://github.com/seccomp/libseccomp
|
||||
TERMUX_PKG_DESCRIPTION="Enhanced seccomp library"
|
||||
TERMUX_PKG_LICENSE="LGPL-2.1"
|
||||
TERMUX_PKG_MAINTAINER="Leonid Plyushch <leonid.plyushch@gmail.com> @xeffyr"
|
||||
TERMUX_PKG_VERSION=2.4.1
|
||||
TERMUX_PKG_REVISION=1
|
||||
TERMUX_PKG_VERSION=2.4.2
|
||||
TERMUX_PKG_SRCURL=https://github.com/seccomp/libseccomp/releases/download/v${TERMUX_PKG_VERSION}/libseccomp-${TERMUX_PKG_VERSION}.tar.gz
|
||||
TERMUX_PKG_SHA256=1ca3735249af66a1b2f762fe6e710fcc294ad7185f1cc961e5bd83f9988006e8
|
||||
TERMUX_PKG_SHA256=b54f27b53884caacc932e75e6b44304ac83586e2abe7a83eca6daecc5440585b
|
||||
TERMUX_PKG_BREAKS="libseccomp-dev"
|
||||
TERMUX_PKG_REPLACES="libseccomp-dev"
|
||||
|
@ -2,6 +2,7 @@ TERMUX_PKG_HOMEPAGE=https://mj.ucw.cz/sw/pciutils/
|
||||
TERMUX_PKG_DESCRIPTION="a collection of programs for inspecting and manipulating configuration of PCI devices"
|
||||
TERMUX_PKG_LICENSE="GPL-2.0"
|
||||
TERMUX_PKG_VERSION=3.6.2
|
||||
TERMUX_PKG_REVISION=1
|
||||
TERMUX_PKG_SRCURL=https://mj.ucw.cz/download/linux/pci/pciutils-${TERMUX_PKG_VERSION}.tar.gz
|
||||
TERMUX_PKG_SHA256=30005e341bb0ffa734174e592dc8f0dd928e1c9368b859715812149ed91d8f93
|
||||
TERMUX_PKG_DEPENDS="zlib"
|
||||
|
Loading…
Reference in New Issue
Block a user