chore(asciinema): update to 2.2.0
- update patch for locale checking UTF-8 support closes #10542 Signed-off-by: Aditya Alok <dev.aditya.alok@gmail.com>
This commit is contained in:
parent
3de8caaa47
commit
9c870ffee3
@ -1,14 +0,0 @@
|
||||
diff -u -r ../asciinema-2.0.2/asciinema/__main__.py ./asciinema/__main__.py
|
||||
--- ../asciinema-2.0.2/asciinema/__main__.py 2019-01-12 18:58:29.000000000 +0000
|
||||
+++ ./asciinema/__main__.py 2019-01-16 21:07:50.834574609 +0000
|
||||
@@ -50,10 +50,6 @@
|
||||
|
||||
|
||||
def main():
|
||||
- if locale.nl_langinfo(locale.CODESET).upper() not in ['US-ASCII', 'UTF-8', 'UTF8']:
|
||||
- print("asciinema needs an ASCII or UTF-8 character encoding to run. Check the output of `locale` command.")
|
||||
- sys.exit(1)
|
||||
-
|
||||
try:
|
||||
cfg = config.load()
|
||||
except config.ConfigError as e:
|
@ -2,9 +2,9 @@ TERMUX_PKG_HOMEPAGE=https://asciinema.org/
|
||||
TERMUX_PKG_DESCRIPTION="Record and share your terminal sessions, the right way"
|
||||
TERMUX_PKG_LICENSE="GPL-3.0"
|
||||
TERMUX_PKG_MAINTAINER="@termux"
|
||||
TERMUX_PKG_VERSION=2.1.0
|
||||
TERMUX_PKG_VERSION=2.2.0
|
||||
TERMUX_PKG_SRCURL=https://github.com/asciinema/asciinema/archive/v${TERMUX_PKG_VERSION}.tar.gz
|
||||
TERMUX_PKG_SHA256=f4f4a04ab891dd513c99f72527c83fa9e634e858f2744a17e80258b90a6bf409
|
||||
TERMUX_PKG_SHA256=cce6f0ed6bcf47d54fe5caae14862bfb5a2e39eec1b3b467a8ed1050c298d0ec
|
||||
TERMUX_PKG_AUTO_UPDATE=true
|
||||
# ncurses-utils for tput which asciinema uses:
|
||||
TERMUX_PKG_DEPENDS="python, ncurses-utils"
|
||||
@ -26,5 +26,5 @@ termux_step_make() {
|
||||
|
||||
termux_step_make_install() {
|
||||
export PYTHONPATH=$TERMUX_PREFIX/lib/python${_PYTHON_VERSION}/site-packages/
|
||||
python${_PYTHON_VERSION} setup.py install --prefix=$TERMUX_PREFIX --force
|
||||
python${_PYTHON_VERSION} -m pip install . --prefix="${TERMUX_PREFIX}" --force
|
||||
}
|
||||
|
22
packages/asciinema/locale.patch
Normal file
22
packages/asciinema/locale.patch
Normal file
@ -0,0 +1,22 @@
|
||||
# Termux doesn't provide locale support, but UTF-8 is the default.
|
||||
|
||||
--- ./asciinema/__main__.py.orig 2022-05-08 04:11:10.417277242 +0000
|
||||
+++ ./asciinema/__main__.py 2022-05-08 04:11:37.593919730 +0000
|
||||
@@ -35,17 +35,6 @@
|
||||
|
||||
|
||||
def main() -> Any:
|
||||
- if locale.nl_langinfo(locale.CODESET).upper() not in [
|
||||
- "US-ASCII",
|
||||
- "UTF-8",
|
||||
- "UTF8",
|
||||
- ]:
|
||||
- sys.stderr.write(
|
||||
- "asciinema needs an ASCII or UTF-8 character encoding to run. "
|
||||
- "Check the output of `locale` command.\n"
|
||||
- )
|
||||
- return 1
|
||||
-
|
||||
try:
|
||||
cfg = config.load()
|
||||
except config.ConfigError as e:
|
Loading…
Reference in New Issue
Block a user