new package: lite-xl (#483)

This commit is contained in:
Leap of Azzam 2021-11-10 04:29:51 +07:00 committed by Yaksh Bariya
parent 711c8e821b
commit 9f17fcbcd0
No known key found for this signature in database
GPG Key ID: F7486BA7D3D27581
2 changed files with 37 additions and 0 deletions

View File

@ -0,0 +1,20 @@
TERMUX_PKG_HOMEPAGE=https://github.com/lite-xl/lite-xl
TERMUX_PKG_DESCRIPTION="A lightweight text editor written in Lua"
TERMUX_PKG_LICENSE="MIT"
TERMUX_PKG_MAINTAINER="@leapofazzam123"
TERMUX_PKG_VERSION=2.0.3
TERMUX_PKG_SRCURL="https://github.com/lite-xl/lite-xl/archive/refs/tags/v$TERMUX_PKG_VERSION.tar.gz"
TERMUX_PKG_SHA256=6c8a4ea284f102f772e3aff583236e89d5b1171664526dd501000b681ae5c4e2
TERMUX_PKG_DEPENDS="sdl2, freetype, liblua52"
termux_step_pre_configure() {
# reproc needs librt but we don't have it
# and we can't directly patch subprojects
# because it needs to be patch after
# meson downloads it
echo 'INPUT(-lc)' > $TERMUX_PREFIX/lib/librt.so
}
termux_step_post_make_install() {
rm $TERMUX_PREFIX/lib/librt.so
}

View File

@ -0,0 +1,17 @@
diff -uNr lite-xl.orig/meson.build lite-xl/meson.build
--- lite-xl.orig/meson.build
+++ lite-xl/meson.build
@@ -47,11 +47,11 @@
libm = cc.find_library('m', required : false)
libdl = cc.find_library('dl', required : false)
threads_dep = dependency('threads')
- lua_dep = dependency('lua5.2', fallback: ['lua', 'lua_dep'],
+ lua_dep = dependency('lua52', fallback: ['lua', 'lua_dep'],
default_options: ['shared=false', 'use_readline=false', 'app=false']
)
pcre2_dep = dependency('libpcre2-8')
- sdl_dep = dependency('sdl2', method: 'config-tool')
+ sdl_dep = dependency('sdl2', method: 'pkg-config')
reproc_dep = dependency('reproc', fallback: ['reproc', 'reproc_dep'],
default_options: [
'default_library=static', 'multithreaded=false',