nushell: Update to 0.60.0

This commit is contained in:
Tee KOBAYASHI 2022-03-24 05:43:59 +09:00 committed by buttaface
parent 63a44b9133
commit a11ec235f0
4 changed files with 39 additions and 12 deletions

View File

@ -1,10 +1,11 @@
--- ./Cargo.toml.orig 2022-02-19 09:22:55.090670811 +0530
+++ ./Cargo.toml 2022-02-19 09:25:05.340670761 +0530
@@ -71,7 +71,6 @@
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -72,7 +72,7 @@
default = [
"nu-cli/shadow-rs",
- "sys-support",
"ctrlc-support",
"which-support",
"term-support",
[features]
plugin = ["nu-plugin", "nu-cli/plugin", "nu-parser/plugin", "nu-command/plugin", "nu-protocol/plugin", "nu-engine/plugin"]
-default = ["plugin", "which", "zip-support", "trash-support"]
+default = ["plugin", "which", "zip-support"]
stable = ["default"]
extra = ["default", "dataframe"]
wasi = []

View File

@ -2,10 +2,9 @@ TERMUX_PKG_HOMEPAGE=https://www.nushell.sh
TERMUX_PKG_DESCRIPTION="A new type of shell operating on structured data"
TERMUX_PKG_LICENSE="MIT"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=0.44.0
TERMUX_PKG_REVISION=2
TERMUX_PKG_VERSION=0.60.0
TERMUX_PKG_SRCURL=https://github.com/nushell/nushell/archive/$TERMUX_PKG_VERSION.tar.gz
TERMUX_PKG_SHA256=94bb003fd05b604a174a686c40286fef460bc06616a7d273c387a54a07576ecc
TERMUX_PKG_SHA256=9b9deb8e42cf18ccf328833a4d051fc14cef0be468afc3b0dbde6657deb9f079
TERMUX_PKG_AUTO_UPDATE=true
TERMUX_PKG_DEPENDS="openssl, zlib"
TERMUX_PKG_BUILD_IN_SRC=true

View File

@ -0,0 +1,11 @@
--- a/crates/nu-system/Cargo.toml
+++ b/crates/nu-system/Cargo.toml
@@ -14,7 +14,7 @@
[dependencies]
-[target.'cfg(target_os = "linux")'.dependencies]
+[target.'cfg(any(target_os = "linux", target_os = "android"))'.dependencies]
procfs = "0.12.0"
users = "0.11"
which = "4"

View File

@ -0,0 +1,16 @@
--- a/crates/nu-system/src/lib.rs
+++ b/crates/nu-system/src/lib.rs
@@ -1,11 +1,11 @@
-#[cfg(target_os = "linux")]
+#[cfg(any(target_os = "linux", target_os = "android"))]
mod linux;
#[cfg(target_os = "macos")]
mod macos;
#[cfg(target_os = "windows")]
mod windows;
-#[cfg(target_os = "linux")]
+#[cfg(any(target_os = "linux", target_os = "android"))]
pub use self::linux::*;
#[cfg(target_os = "macos")]
pub use self::macos::*;