openscad: link with boost "manually"

features/boost.prf might be the proper file to patch rather than doing this
This commit is contained in:
Henrik Grimler 2019-10-25 23:07:39 +02:00
parent 0753b8b696
commit a25d559f89
1 changed files with 11 additions and 0 deletions

View File

@ -0,0 +1,11 @@
--- ../CMakeLists.txt.orig 2019-10-25 22:29:54.800362557 +0200
+++ ./CMakeLists.txt 2019-10-25 22:30:48.421653704 +0200
@@ -688,6 +688,8 @@
target_link_libraries(OpenSCAD spnav)
endif()
+list(APPEND COMMON_LIBRARIES boost_thread boost_program_options boost_filesystem boost_system boost_regex)
+
target_link_libraries(OpenSCAD PRIVATE ${COMMON_LIBRARIES} ${PLATFORM_LIBS})
if(NOT HEADLESS)
target_link_libraries(OpenSCAD PRIVATE Qt5::Core Qt5::Widgets Qt5::Multimedia Qt5::OpenGL Qt5::Concurrent Qt5::Network ${QT5QSCINTILLA_LIBRARY} ${Qt5DBus_LIBRARIES} ${Qt5Gamepad_LIBRARIES})