graphviz: update to 2.42.3 (#5091)
* graphviz: update to 2.42.3 Add -landroid-glob where needed only and remove -D_typ_ssize_t=1 from CPPFLAGS, doesn't seem to be needed anymore. * graphviz: update patches, fix so that out-of-src build works
This commit is contained in:
parent
b7a1861d75
commit
a626f4fb63
@ -1,24 +0,0 @@
|
||||
diff -r -u graphviz-2.38.0/cmd/tools/Makefile.am src/cmd/tools/Makefile.am
|
||||
--- graphviz-2.38.0/cmd/tools/Makefile.am 2014-04-13 13:40:25.000000000 -0700
|
||||
+++ src/cmd/tools/Makefile.am 2016-04-09 09:34:27.178979677 -0700
|
||||
@@ -135,6 +135,7 @@
|
||||
gc_SOURCES = gc.c
|
||||
|
||||
gc_LDADD = \
|
||||
+ $(top_builddir)/lib/common/libcommon_C.la \
|
||||
$(top_builddir)/lib/ingraphs/libingraphs_C.la \
|
||||
$(top_builddir)/lib/cgraph/libcgraph.la
|
||||
|
||||
Only in src/cmd/tools: Makefile.am~
|
||||
diff -r -u graphviz-2.38.0/cmd/tools/Makefile.in src/cmd/tools/Makefile.in
|
||||
--- graphviz-2.38.0/cmd/tools/Makefile.in 2014-04-13 13:41:53.000000000 -0700
|
||||
+++ src/cmd/tools/Makefile.in 2016-04-09 09:35:23.858509449 -0700
|
||||
@@ -722,6 +722,7 @@
|
||||
|
||||
gc_SOURCES = gc.c
|
||||
gc_LDADD = \
|
||||
+ $(top_builddir)/lib/common/libcommon_C.la \
|
||||
$(top_builddir)/lib/ingraphs/libingraphs_C.la \
|
||||
$(top_builddir)/lib/cgraph/libcgraph.la
|
||||
|
||||
Only in src/cmd/tools: Makefile.in~
|
@ -1,15 +1,13 @@
|
||||
TERMUX_PKG_HOMEPAGE=https://www.graphviz.org/
|
||||
TERMUX_PKG_DESCRIPTION="Rich set of graph drawing tools"
|
||||
TERMUX_PKG_LICENSE="EPL-2.0"
|
||||
TERMUX_PKG_VERSION=2.40.1
|
||||
TERMUX_PKG_REVISION=11
|
||||
TERMUX_PKG_SRCURL=https://fossies.org/linux/misc/graphviz-$TERMUX_PKG_VERSION.tar.gz
|
||||
TERMUX_PKG_SHA256=ca5218fade0204d59947126c38439f432853543b0818d9d728c589dfe7f3a421
|
||||
TERMUX_PKG_VERSION=2.42.3
|
||||
TERMUX_PKG_SRCURL=https://www2.graphviz.org/Packages/stable/portable_source/graphviz-$TERMUX_PKG_VERSION.tar.gz
|
||||
TERMUX_PKG_SHA256=8faf3fc25317b1d15166205bf64c1b4aed55a8a6959dcabaa64dbad197e47add
|
||||
TERMUX_PKG_DEPENDS="libandroid-glob, libc++, libcairo, pango, libexpat, libltdl, librsvg, libgd, zlib"
|
||||
TERMUX_PKG_BREAKS="graphviz-dev"
|
||||
TERMUX_PKG_REPLACES="graphviz-dev"
|
||||
TERMUX_PKG_BUILD_DEPENDS="libtool"
|
||||
TERMUX_PKG_BUILD_IN_SRC=true
|
||||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
|
||||
--enable-guile=no
|
||||
--enable-java=no
|
||||
@ -33,14 +31,14 @@ TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
|
||||
TERMUX_PKG_RM_AFTER_INSTALL="bin/*-config share/man/man1/*-config.1"
|
||||
|
||||
termux_step_pre_configure() {
|
||||
LDFLAGS+=" -landroid-glob"
|
||||
CPPFLAGS+=" -D_typ_ssize_t=1"
|
||||
./autogen.sh NOCONFIG
|
||||
export HOSTCC="gcc"
|
||||
}
|
||||
|
||||
termux_step_post_make_install() {
|
||||
# Some binaries (dot_builtins, gvpack) links against these:
|
||||
cd $TERMUX_PREFIX/lib
|
||||
for lib in graphviz/*.so.*; do
|
||||
for lib in graphviz/*.so*; do
|
||||
ln -s -f $lib $(basename $lib)
|
||||
done
|
||||
}
|
||||
|
11
packages/graphviz/cmd-edgepaint-Makefile.am.patch
Normal file
11
packages/graphviz/cmd-edgepaint-Makefile.am.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- ../cmd-edgepaint-Makefile.am.orig 2020-03-28 14:17:47.357033245 +0100
|
||||
+++ ./cmd/edgepaint/Makefile.am 2020-03-28 14:18:27.756954983 +0100
|
||||
@@ -31,7 +31,7 @@
|
||||
$(top_builddir)/lib/edgepaint/liblab_gamut.la \
|
||||
$(top_builddir)/lib/cgraph/libcgraph.la \
|
||||
$(top_builddir)/lib/cdt/libcdt.la \
|
||||
- $(ANN_LIBS) -lstdc++ -lm
|
||||
+ $(ANN_LIBS) -lc++_shared -lm
|
||||
|
||||
edgepaint.1.pdf: $(srcdir)/edgepaint.1
|
||||
- @GROFF@ -e -Tps -man -t $(srcdir)/edgepaint.1 | @PS2PDF@ - - >edgepaint.1.pdf
|
@ -1,12 +0,0 @@
|
||||
diff -u -r ../graphviz-2.40.1/cmd/edgepaint/Makefile.in ./cmd/edgepaint/Makefile.in
|
||||
--- ../graphviz-2.40.1/cmd/edgepaint/Makefile.in 2016-12-25 03:04:55.000000000 +0000
|
||||
+++ ./cmd/edgepaint/Makefile.in 2019-04-26 20:26:13.197184745 +0000
|
||||
@@ -585,7 +585,7 @@
|
||||
$(top_builddir)/lib/edgepaint/liblab_gamut.la \
|
||||
$(top_builddir)/lib/cgraph/libcgraph.la \
|
||||
$(top_builddir)/lib/cdt/libcdt.la \
|
||||
- $(ANN_LIBS) -lstdc++ -lm
|
||||
+ $(ANN_LIBS) -lc++_shared -lm
|
||||
|
||||
EXTRA_DIST = $(man_MANS) $(pdf_DATA) edgepaint.vcxproj*
|
||||
DISTCLEANFILES = $(pdf_DATA)
|
@ -1,21 +0,0 @@
|
||||
Do not require libltdl.la for building.
|
||||
|
||||
diff -u -r ../graphviz-2.40.1/configure ./configure
|
||||
--- ../graphviz-2.40.1/configure 2016-12-25 04:04:52.000000000 +0100
|
||||
+++ ./configure 2017-08-11 14:35:43.459379008 +0200
|
||||
@@ -19556,15 +19556,6 @@
|
||||
fi
|
||||
|
||||
|
||||
-if test -n "$with_ltdl_lib"; then
|
||||
- if test -f "$with_ltdl_lib/libltdl.la"; then :
|
||||
- else
|
||||
- as_fn_error $? "invalid ltdl library directory: \`$with_ltdl_lib'" "$LINENO" 5
|
||||
- fi
|
||||
-else
|
||||
- with_ltdl_lib=no
|
||||
-fi
|
||||
-
|
||||
case ,$with_included_ltdl,$with_ltdl_include,$with_ltdl_lib, in
|
||||
,yes,no,no,)
|
||||
case $enable_ltdl_convenience in
|
35
packages/graphviz/lib-cgraph.patch
Normal file
35
packages/graphviz/lib-cgraph.patch
Normal file
@ -0,0 +1,35 @@
|
||||
cgraph contains an empty malloc.h, that seems to be needed by files
|
||||
that are generated by yacc. This empty malloc.h is however also picked
|
||||
in other places (first error is from
|
||||
plugin/visio/VisioGraphic.cpp). By moving the empty malloc.h to
|
||||
include/ and only letting cgraph having `-Iinclude` we can make sure
|
||||
it is only picked up where it should be picked up.
|
||||
|
||||
Compiling on device works without this patch, but it gives warnings
|
||||
like
|
||||
```
|
||||
../../../lib/common/memory.c:47:10: warning: implicitly declaring library function 'malloc' with type 'void *(unsigned long)' [-Wimplicit-function-declaration]
|
||||
```
|
||||
|
||||
diff --git a/lib/cgraph/Makefile.am b/lib/cgraph/Makefile.am
|
||||
index bb6147b91..419940a7c 100644
|
||||
--- a/lib/cgraph/Makefile.am
|
||||
+++ b/lib/cgraph/Makefile.am
|
||||
@@ -8,10 +8,11 @@ pkgconfigdir = $(libdir)/pkgconfig
|
||||
|
||||
AM_CPPFLAGS = \
|
||||
-I$(top_srcdir) \
|
||||
- -I$(top_srcdir)/lib/cdt
|
||||
+ -I$(top_srcdir)/lib/cdt \
|
||||
+ -Iinclude
|
||||
|
||||
pkginclude_HEADERS = cgraph.h
|
||||
-noinst_HEADERS = agxbuf.h cghdr.h malloc.h
|
||||
+noinst_HEADERS = agxbuf.h cghdr.h include/malloc.h
|
||||
noinst_LTLIBRARIES = libcgraph_C.la
|
||||
lib_LTLIBRARIES = libcgraph.la
|
||||
pkgconfig_DATA = libcgraph.pc
|
||||
diff --git a/lib/cgraph/malloc.h b/lib/cgraph/include/malloc.h
|
||||
similarity index 100%
|
||||
rename from lib/cgraph/malloc.h
|
||||
rename to lib/cgraph/include/malloc.h
|
19
packages/graphviz/lib-fvc-Makefile.am.patch
Normal file
19
packages/graphviz/lib-fvc-Makefile.am.patch
Normal file
@ -0,0 +1,19 @@
|
||||
--- ../lib-gvc-Makefile.am.orig 2020-03-28 12:32:54.035832411 +0100
|
||||
+++ ./lib/gvc/Makefile.am 2020-03-28 12:37:57.988619047 +0100
|
||||
@@ -47,6 +47,7 @@
|
||||
$(top_builddir)/lib/xdot/libxdot_C.la \
|
||||
$(top_builddir)/lib/label/liblabel_C.la \
|
||||
$(top_builddir)/lib/common/libcommon_C.la
|
||||
+libgvc_C_la_LDFLAGS = -landroid-glob
|
||||
if WITH_ORTHO
|
||||
libgvc_C_la_LIBADD += $(top_builddir)/lib/ortho/libortho_C.la
|
||||
libgvc_C_la_DEPENDENCIES += $(top_builddir)/lib/ortho/libortho_C.la
|
||||
@@ -55,7 +56,7 @@
|
||||
libgvc_C_la_LIBADD += @LIBLTDL@ $(LIBLTDL_LDFLAGS)
|
||||
endif
|
||||
|
||||
-libgvc_la_LDFLAGS = -version-info $(GVC_VERSION) -no-undefined
|
||||
+libgvc_la_LDFLAGS = -version-info $(GVC_VERSION) -no-undefined -landroid-glob
|
||||
libgvc_la_SOURCES = $(libgvc_C_la_SOURCES)
|
||||
libgvc_la_LIBADD = $(libgvc_C_la_LIBADD) \
|
||||
$(top_builddir)/lib/xdot/libxdot.la \
|
28
packages/graphviz/lib-gvpr-Makefile.am.patch
Normal file
28
packages/graphviz/lib-gvpr-Makefile.am.patch
Normal file
@ -0,0 +1,28 @@
|
||||
--- ../lib-gvpr-Makefile.am.orig 2020-03-28 14:56:03.035919302 +0100
|
||||
+++ ./lib/gvpr/Makefile.am 2020-03-28 15:32:59.954957670 +0100
|
||||
@@ -3,6 +3,7 @@
|
||||
|
||||
pdfdir = $(pkgdatadir)/doc/pdf
|
||||
pkgconfigdir = $(libdir)/pkgconfig
|
||||
+HOSTCC ?= $(CC)
|
||||
|
||||
GVPR_VERSION="2:0:0"
|
||||
|
||||
@@ -21,7 +22,6 @@
|
||||
-DDFLT_GVPRPATH="\".$(PATH_SEPARATOR)$(pkgdatadir)/gvpr\""
|
||||
|
||||
pkginclude_HEADERS = gvpr.h
|
||||
-noinst_PROGRAMS = mkdefs
|
||||
noinst_HEADERS = actions.h compile.h gprstate.h parse.h queue.h trieFA.h trie.c
|
||||
noinst_LTLIBRARIES = libgvpr_C.la
|
||||
lib_LTLIBRARIES = libgvpr.la
|
||||
@@ -54,7 +54,8 @@
|
||||
libgvpr_la_LDFLAGS += -export-symbols-regex gvpr
|
||||
endif
|
||||
|
||||
-mkdefs_SOURCES = mkdefs.c
|
||||
+mkdefs$(EXEEXT):
|
||||
+ $(HOSTCC) $(srcdir)/mkdefs.c -o mkdefs$(EXEEXT)
|
||||
|
||||
gdefs.h: $(top_srcdir)/lib/gvpr/gprdata mkdefs$(EXEEXT)
|
||||
./mkdefs$(EXEEXT) gdefs.h < $(top_srcdir)/lib/gvpr/gprdata
|
44
packages/graphviz/lib-sfdpgen-PriorityQueue.c.patch
Normal file
44
packages/graphviz/lib-sfdpgen-PriorityQueue.c.patch
Normal file
@ -0,0 +1,44 @@
|
||||
--- ../PriorityQueue.c.orig 2020-03-28 14:42:15.234189565 +0100
|
||||
+++ ./lib/sfdpgen/PriorityQueue.c 2020-03-28 16:16:07.186610646 +0100
|
||||
@@ -11,6 +11,8 @@
|
||||
* Contributors: See CVS logs. Details at http://www.graphviz.org/
|
||||
*************************************************************************/
|
||||
|
||||
+#include <malloc.h>
|
||||
+
|
||||
#include "LinkedList.h"
|
||||
#include "PriorityQueue.h"
|
||||
#include "memory.h"
|
||||
@@ -18,12 +20,6 @@
|
||||
#include "assert.h"
|
||||
#include "arith.h"
|
||||
|
||||
-#define MALLOC gmalloc
|
||||
-#define REALLOC grealloc
|
||||
-#define FREE free
|
||||
-#define MEMCPY memcpy
|
||||
-
|
||||
-
|
||||
PriorityQueue PriorityQueue_new(int n, int ngain){
|
||||
PriorityQueue q;
|
||||
int i;
|
||||
@@ -50,15 +46,15 @@
|
||||
if (q){
|
||||
if (q->buckets){
|
||||
for (i = 0; i < q->ngain+1; i++) DoubleLinkedList_delete((q->buckets)[i], free);
|
||||
- FREE(q->buckets);
|
||||
+ free(q->buckets);
|
||||
}
|
||||
|
||||
if (q->where){
|
||||
- FREE(q->where);
|
||||
+ free(q->where);
|
||||
}
|
||||
|
||||
- FREE(q->gain);
|
||||
- FREE(q);
|
||||
+ free(q->gain);
|
||||
+ free(q);
|
||||
}
|
||||
}
|
||||
|
13
packages/graphviz/lib-vpsc-blocks.cpp.patch
Normal file
13
packages/graphviz/lib-vpsc-blocks.cpp.patch
Normal file
@ -0,0 +1,13 @@
|
||||
--- ../blocks.cpp.orig 2020-03-24 12:30:32.334785560 +0100
|
||||
+++ ./lib/vpsc/blocks.cpp 2020-03-24 12:34:15.597529253 +0100
|
||||
@@ -155,8 +155,8 @@
|
||||
//erase(doomed);
|
||||
}
|
||||
void Blocks::cleanup() {
|
||||
- vector<Block*> bcopy(begin(),end());
|
||||
- for(vector<Block*>::iterator i=bcopy.begin();i!=bcopy.end();i++) {
|
||||
+ vector<Block*> b_copy(begin(),end());
|
||||
+ for(vector<Block*>::iterator i=b_copy.begin();i!=b_copy.end();i++) {
|
||||
Block *b=*i;
|
||||
if(b->deleted) {
|
||||
erase(b);
|
@ -1,6 +1,5 @@
|
||||
diff -r -u graphviz-2.38.0/cmd/dot/Makefile.am src/cmd/dot/Makefile.am
|
||||
--- graphviz-2.38.0/cmd/dot/Makefile.am 2014-04-13 13:40:25.000000000 -0700
|
||||
+++ src/cmd/dot/Makefile.am 2016-04-04 15:38:30.797597592 -0700
|
||||
--- ../cmd-dot-Makefile.am.orig 2020-03-28 15:09:39.244338000 +0100
|
||||
+++ ./cmd/dot/Makefile.am 2020-03-28 15:10:03.697623920 +0100
|
||||
@@ -58,7 +58,6 @@
|
||||
# run "dot -c", if possible, to create plugin config
|
||||
install-exec-hook:
|
||||
@ -9,16 +8,3 @@ diff -r -u graphviz-2.38.0/cmd/dot/Makefile.am src/cmd/dot/Makefile.am
|
||||
|
||||
uninstall-hook:
|
||||
(cd $(DESTDIR)$(man1dir); for i in $(linkedman); do rm -f $$i; done;)
|
||||
Only in src/cmd/dot: Makefile.am~
|
||||
diff -r -u graphviz-2.38.0/cmd/dot/Makefile.in src/cmd/dot/Makefile.in
|
||||
--- graphviz-2.38.0/cmd/dot/Makefile.in 2014-04-13 13:41:50.000000000 -0700
|
||||
+++ src/cmd/dot/Makefile.in 2016-04-04 15:38:02.213908307 -0700
|
||||
@@ -1177,7 +1177,6 @@
|
||||
# run "dot -c", if possible, to create plugin config
|
||||
install-exec-hook:
|
||||
(cd $(DESTDIR)$(bindir); if test -x dot$(EXEEXT); then for i in $(linkedprogram); do rm -f $$i; $(LN_S) dot$(EXEEXT) $$i; done; fi;)
|
||||
- if test "x$(DESTDIR)" = "x"; then if test -x $(bindir)/dot$(EXEEXT); then if test -x /sbin/ldconfig; then /sbin/ldconfig 2>/dev/null; fi; $(bindir)/dot$(EXEEXT) -c; else $(bindir)/dot_static$(EXEEXT) -c; fi; fi
|
||||
|
||||
uninstall-hook:
|
||||
(cd $(DESTDIR)$(man1dir); for i in $(linkedman); do rm -f $$i; done;)
|
||||
Only in src/cmd/dot: Makefile.in~
|
||||
|
@ -1,26 +0,0 @@
|
||||
http://www.graphviz.org/content/cant-cross-compile-graphviz
|
||||
|
||||
diff -u -r ../graphviz-2.40.1/lib/gvpr/Makefile.am ./lib/gvpr/Makefile.am
|
||||
--- ../graphviz-2.40.1/lib/gvpr/Makefile.am 2016-08-09 23:02:10.000000000 +0200
|
||||
+++ ./lib/gvpr/Makefile.am 2017-01-19 20:01:22.745725697 +0100
|
||||
@@ -57,7 +57,7 @@
|
||||
mkdefs_SOURCES = mkdefs.c
|
||||
|
||||
gdefs.h: $(top_srcdir)/lib/gvpr/gprdata mkdefs$(EXEEXT)
|
||||
- ./mkdefs$(EXEEXT) gdefs.h < $(top_srcdir)/lib/gvpr/gprdata
|
||||
+ touch gdefs.h
|
||||
|
||||
EXTRA_DIST = $(man_MANS) $(pdf_DATA) gprdata mkdefs.c gdefs.h trie.c gvprlib.vcxproj*
|
||||
|
||||
diff -u -r ../graphviz-2.40.1/lib/gvpr/Makefile.in ./lib/gvpr/Makefile.in
|
||||
--- ../graphviz-2.40.1/lib/gvpr/Makefile.in 2016-12-25 04:04:59.000000000 +0100
|
||||
+++ ./lib/gvpr/Makefile.in 2017-01-19 20:02:07.293214993 +0100
|
||||
@@ -1084,7 +1084,7 @@
|
||||
- @GROFF@ -Tps -man $(srcdir)/gvpr.3 | @PS2PDF@ - - >gvpr.3.pdf
|
||||
|
||||
gdefs.h: $(top_srcdir)/lib/gvpr/gprdata mkdefs$(EXEEXT)
|
||||
- ./mkdefs$(EXEEXT) gdefs.h < $(top_srcdir)/lib/gvpr/gprdata
|
||||
+ touch gdefs.h
|
||||
|
||||
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
||||
# Otherwise a system limit (for SysV at least) may be exceeded.
|
@ -1,11 +0,0 @@
|
||||
--- src/lib/sfdpgen/PriorityQueue.c.orig 2016-04-01 08:29:58.788223689 -0700
|
||||
+++ src/lib/sfdpgen/PriorityQueue.c 2016-04-01 08:30:44.507731384 -0700
|
||||
@@ -11,6 +11,8 @@
|
||||
* Contributors: See CVS logs. Details at http://www.graphviz.org/
|
||||
*************************************************************************/
|
||||
|
||||
+void free(void *ptr);
|
||||
+
|
||||
#include "LinkedList.h"
|
||||
#include "PriorityQueue.h"
|
||||
#include "memory.h"
|
Loading…
Reference in New Issue
Block a user