apt: update to 2.2.0

This commit is contained in:
Lucy Phipps 2021-02-25 11:36:23 +00:00
parent e3e83f709c
commit adb1ddc2c8
No known key found for this signature in database
GPG Key ID: 8F688A3DB7869BFE
3 changed files with 23 additions and 11 deletions

View File

@ -10,10 +10,10 @@ diff -uNr apt-2.1.13/apt-pkg/CMakeLists.txt apt-2.1.13.mod/apt-pkg/CMakeLists.tx
${CMAKE_THREAD_LIBS_INIT}
${ZLIB_LIBRARIES}
${BZIP2_LIBRARIES}
diff -uNr apt-2.1.13/CMakeLists.txt apt-2.1.13.mod/CMakeLists.txt
--- apt-2.1.13/CMakeLists.txt 2020-12-10 16:40:27.000000000 +0200
+++ apt-2.1.13.mod/CMakeLists.txt 2020-12-11 18:10:24.236801758 +0200
@@ -188,14 +188,6 @@
diff -uNr apt-2.2.0/CMakeLists.txt apt-2.2.0.mod/CMakeLists.txt
--- apt-2.2.0/CMakeLists.txt 2020-12-10 16:40:27.000000000 +0200
+++ apt-2.2.0.mod/CMakeLists.txt 2020-12-11 18:10:24.236801758 +0200
@@ -189,14 +189,6 @@
endif()
endif()
@ -25,10 +25,10 @@ diff -uNr apt-2.1.13/CMakeLists.txt apt-2.1.13.mod/CMakeLists.txt
- set(RESOLV_LIBRARIES -lresolv)
-endif()
-
# Check multiversioning
include(CheckCxxTarget)
check_cxx_target(HAVE_FMV_SSE42_AND_CRC32 "sse4.2" "__builtin_ia32_crc32si(0,i)|__builtin_ia32_crc32hi(0,i)|__builtin_ia32_crc32qi(0,i)")
@@ -213,10 +205,6 @@
# Configure some variables like package, version and architecture.
set(PACKAGE ${PROJECT_NAME})
set(PACKAGE_MAIL "APT Development Team <deity@lists.debian.org>")
@@ -209,10 +201,6 @@
message(STATUS "Found dpkg data dir: ${DPKG_DATADIR_CMD}")
set(DPKG_DATADIR "${DPKG_DATADIR_CMD}" CACHE PATH "dpkg data directory")
endif()
@ -39,7 +39,7 @@ diff -uNr apt-2.1.13/CMakeLists.txt apt-2.1.13.mod/CMakeLists.txt
if (NOT DEFINED ROOT_GROUP)
execute_process(COMMAND id -gn root
OUTPUT_VARIABLE ROOT_GROUP OUTPUT_STRIP_TRAILING_WHITESPACE)
@@ -243,11 +231,9 @@
@@ -239,11 +227,9 @@
add_subdirectory(apt-private)
add_subdirectory(cmdline)
add_subdirectory(completions)

View File

@ -0,0 +1,12 @@
diff --git a/apt-pkg/contrib/configuration.cc b/apt-pkg/contrib/configuration.cc
index a8fced724..03bdb12a8 100644
--- a/apt-pkg/contrib/configuration.cc
+++ b/apt-pkg/contrib/configuration.cc
@@ -31,6 +31,7 @@
#include <string.h>
#include <algorithm>
+#include <array>
#include <fstream>
#include <iterator>
#include <numeric>

View File

@ -2,9 +2,9 @@ TERMUX_PKG_HOMEPAGE=https://packages.debian.org/apt
TERMUX_PKG_DESCRIPTION="Front-end for the dpkg package manager"
TERMUX_PKG_LICENSE="GPL-2.0"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=2.1.18
TERMUX_PKG_VERSION=2.2.0
TERMUX_PKG_SRCURL=http://deb.debian.org/debian/pool/main/a/apt/apt_${TERMUX_PKG_VERSION}.tar.xz
TERMUX_PKG_SHA256=224ade1bc189303b0620c55ac278cb419fdff7693765e6e864f82cf73bd3c766
TERMUX_PKG_SHA256=b25c9e6cb89e2e3c812584b38dfba333ff8be75e8e907a27a0394914abc36ca9
# apt-key requires utilities from coreutils, findutils, gpgv, grep, sed.
TERMUX_PKG_DEPENDS="coreutils, dpkg, findutils, gpgv, grep, libandroid-glob, libbz2, libc++, libcurl, libgnutls, liblz4, liblzma, sed, termux-licenses, xxhash, zlib"
TERMUX_PKG_CONFLICTS="apt-transport-https, libapt-pkg"