radare2: Update from 2.3.0 to 2.4.0

This commit is contained in:
Fredrik Fornwall 2018-03-08 14:26:33 +01:00
parent 58d5d4a7ec
commit af4b47cf36
3 changed files with 13 additions and 14 deletions

View File

@ -1,7 +1,7 @@
TERMUX_PKG_HOMEPAGE=https://rada.re
TERMUX_PKG_DESCRIPTION="Advanced Hexadecimal Editor"
TERMUX_PKG_VERSION=2.3.0
TERMUX_PKG_SHA256=50a5797f168b10e02bd9c4d4ff61fe0459e1b79710c27405c94753694d6b9b3c
TERMUX_PKG_VERSION=2.4.0
TERMUX_PKG_SHA256=e2edef4d70c7bbbb47d04002ce9d384eb2fc9c0cd4cbfde77cda8c10cae9ff24
TERMUX_PKG_SRCURL=https://github.com/radare/radare2/archive/$TERMUX_PKG_VERSION.tar.gz
TERMUX_PKG_BUILD_IN_SRC="yes"
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--with-compiler=termux-host"

View File

@ -41,18 +41,6 @@ diff -uNr radare2-2.0.0/libr/core/cconfig.c radare2-2.0.0.mod/libr/core/cconfig.
SETPREF ("http.root", "www", "http root directory");
#else
SETPREF ("http.root", R2_WWWROOT, "http root directory");
diff -uNr radare2-2.0.0/libr/debug/p/debug_rap.c radare2-2.0.0.mod/libr/debug/p/debug_rap.c
--- radare2-2.0.0/libr/debug/p/debug_rap.c 2017-10-09 18:05:53.000000000 +0300
+++ radare2-2.0.0.mod/libr/debug/p/debug_rap.c 2017-10-11 16:24:45.152199241 +0300
@@ -49,7 +49,7 @@
}
static char *r_debug_rap_reg_profile(RDebug *dbg) {
- char *out, *tf = r_file_temp ("/tmp/rap.XXXXXX");
+ char *out, *tf = r_file_temp ("@TERMUX_PREFIX@/tmp/rap.XXXXXX");
int fd = r_cons_pipe_open (tf, 1, 0);
r_io_system (dbg->iob.io, "drp");
r_cons_pipe_close (fd);
diff -uNr radare2-2.0.0/libr/include/r_magic.h radare2-2.0.0.mod/libr/include/r_magic.h
--- radare2-2.0.0/libr/include/r_magic.h 2017-10-09 18:05:53.000000000 +0300
+++ radare2-2.0.0.mod/libr/include/r_magic.h 2017-10-11 16:23:00.721073712 +0300

View File

@ -0,0 +1,11 @@
diff -u -r ../radare2-2.4.0/mk/termux-host.mk ./mk/termux-host.mk
--- ../radare2-2.4.0/mk/termux-host.mk 2018-03-05 17:12:35.000000000 +0000
+++ ./mk/termux-host.mk 2018-03-07 10:00:57.076202764 +0000
@@ -3,6 +3,7 @@
#RANLIB=ndk-ranlib
USERCC=gcc -fPIC -fPIE
CC_AR=${AR} -r ${LIBAR}
+PARTIALLD=${LD} -r --whole-archive
ONELIB=0
OSTYPE=android