openscad: skip (outdated?) boost check

Upstream issue: https://github.com/openscad/openscad/issues/3197
This commit is contained in:
Henrik Grimler 2020-02-14 20:51:01 +01:00
parent 4a20a80801
commit af69bf1923
1 changed files with 13 additions and 3 deletions

View File

@ -1,6 +1,16 @@
--- ../CMakeLists.txt.orig 2019-10-25 22:29:54.800362557 +0200
+++ ./CMakeLists.txt 2019-10-25 22:30:48.421653704 +0200
@@ -688,6 +688,8 @@
--- ../CMakeLists.txt.orig 2020-02-14 20:41:56.576884809 +0100
+++ ./CMakeLists.txt 2020-02-14 20:44:41.792539280 +0100
@@ -201,9 +201,6 @@
# Check if boost dependency libraries have been found too
list(LENGTH BOOST_DIRECTLY_REQUIRED_LIBRARIES BOOST_DIRECTLY_REQUIRED_LIBRARIES_LENGTH)
list(LENGTH Boost_LIBRARIES Boost_LIBRARIES_LENGTH)
- if(Boost_LIBRARIES_LENGTH EQUAL BOOST_DIRECTLY_REQUIRED_LIBRARIES_LENGTH)
- message(FATAL_ERROR "No dependent Boost libraries found. Your CMake (${CMAKE_VERSION}) version might be too old for the version of boost you are using (${Boost_MAJOR_VERSION}.${Boost_MINOR_VERSION}.${Boost_SUBMINOR_VERSION}). In that case, you should have received warnings above of the type: 'Imported targets not available for Boost version ${Boost_VERSION}'")
- endif()
find_package(HarfBuzz 0.9.19 REQUIRED QUIET)
message(STATUS "Harfbuzz: ${HARFBUZZ_VERSION}")
@@ -688,6 +685,8 @@
target_link_libraries(OpenSCAD spnav)
endif()